Video Screencast Help

Deploy Image Task Fails

Created: 27 Nov 2012 • Updated: 29 Nov 2012 | 10 comments
This issue has been solved. See solution.

I'm hoping someone can help... We currently have CMS 7.1.8400 up in our lab. For whever the reason, my Deploy Image Job constantly fails soon after the image is actually written to disk. The image is written successfully, as I can manually reboot to production and the VM boots as expected. I'm not exactly sure what's happening after the ghost process finishes in regards to the job that cause the job to fail. I know the product key is correct, and I've tried a combination of all other options. I have logging turned on, but can't seem to find logs specific to a particular task to troubleshoot the failure.

Any help would be greatly appreciated.

Josh

Comments 10 CommentsJump to latest comment

shailesh_mali@symantec.com's picture

Find the file named GHOSTERROR.txt in preboot ( usually you will find this file in folder in which Ghost binary exists )

If it exists then you would get error details in this file.

If it doesn't exist, then imaging has completed successfully, make sure your job doesn't include any other task ( which might be failing )

rckid's picture

Thanks for the info. The file doesn't exist, as the imaging process does complete. However, I believe it's failing at some other point in the "deploy image task"?? Still digging......

Josh

SteffenBorge's picture

Sounds like perhaps you are missing critical drivers. Such as either / or both the MSD (Hard drive drivers) and/or network drivers.

If the ghost image is succefully deployed, and right after it you get failed in the NS console.
Anyhu, you can do an eval to see if thats the problem.

"\\%NSSERVER%\Deployment\TaskHandler\ghost\DeployAnywhere.exe" /eval /target=D:\Windows /ddb=\\%NSSERVER%\Deployment\Task Handler\DriversDB

It will give you some info in the cmd window after you run it.
Change unc path to whatever you have with your installation, but this is usally the "standarad" paths.

 

 

 

rckid's picture

Not sure if the issue is related to drivers, as the result is the same regardless of me using the DeployAnywhere feature. Also, it's actually a VMware virtual machine that I'm using and I believe the nic and storage drivers are included..... However, when I run the following:

"\\%NSSERVER%\Deployment\Task Handler\ghost\DeployAnywhere.exe" /eval /target=D:\Windows /ddb=\\%NSSERVER%\Deployment\Task Handler\DriversDB,

I get access denied??

Josh

yogeshsadhu's picture

When the job fails does that gives any error message ?

Or is it failing at reboot to production task ?

Yogesh Sadhu.

If you feel your issue has been addressed,please use the "Mark as Solution" link for the relevant thread.

rckid's picture

As far as I can tell it's failing right after the image is laid down. I know this because I can reboot manually just fine.There has to be something else in the "Deploy Image Task" that's causing the job to fail.

Josh

rckid's picture

Attached are logs that i've retrieved from the client while in PE.

At the end of the ClientimageDeploy log, there's some logging regarding a failure, but I'm not sure what it means.

Any assistance would be very much appreciated. Thanks!

Josh

Thomas Baird's picture

I can't see the attached logs (maybe not approved yet?) but you DID mention that you turn OFF DeployAnywhere and it still fails?  If you do this, are the errors in the deploy job the same?

Do you have dual partitions in the image?  Or on the target system?  That is, do you have recovery partitoins or anything like that?  Not saying they're not supported - they are - just looking for information.

Also, see if there's a ghosterr.txt file (something like that) in the root of X.

Just a couple of thoughts.  Interesting...

Thomas Baird
Technical Solutions Architect @ www.xcendgroup.com
https://www2.gotomeeting.co

rckid's picture

Thomas,

Thanks for the reply. Here are the logs. Please let me know if you need more information. I'll check the things you mentioned in your post. Thanks!

Josh

 

AttachmentSize
Altiris_Logs.zip 7.27 KB
rckid's picture

Thanks to all that tried to help. I was able to resolve the issue by finding another post similar to mine. Appartently the issues was related to firm.exe in x32bit PE environment. I tried the same job in an x64biit environment and all went well. Thanks again!

 

Josh

SOLUTION