Video Screencast Help
Symantec to Separate Into Two Focused, Industry-Leading Technology Companies. Learn more.

DeployAnywhere fails on Critical Wireless NIC driver HP8188CE (Win7 x64) for HP Probook 4530s

Created: 05 Nov 2012 | 5 comments

I've been working on getting our Windows 7 x64 Pro image to work with our HP Probook 4530s model laptops.  After the laptop ghosts and runs DeployAnywhere, it fails because it is missing a critical device driver.  After doing a deployanywhere.exe /eval, the following if the missing driver that comes up.

Missing critical driver detected :

      type = NETWORK DEVICE

      PCI ID = PCI\VEN_10EC&DEV_8176&SUBSYS_1629103C&REV_01

      Desc = @system32\drivers\pci.sys,#640;Network Controller

      Inf Source = Windows InfDirectory

      INF File=

 

I've downloaded the lastest drivers from HP and from Realtek and imported them into the ddb and still get the Missing driver message.  I've also downloaded old drivers and get the same result.  I have booted up the laptop to Windows 7 x64 and installed the drivers by manually pointing the device to the inf I download from the HP website and it installs great.

 

Looking at the drivers.manifest.txt file under the ddb the hardware id clearly shows up under every driver I have uploaded for this device.  I've copied over an example and bolded the corrisponding Vendor-Device-Subsys numbers.

 

    "Realtek_Semiconductor_Corp.RTL8192Ce.1005.22.0615.2011" = {
        class = network,
        drivers = ({
            path = "Realtek_Semiconductor_Corp.RTL8192Ce.1005.22.0615.2011\\net8192ce.inf",
            devices = {
                0x10ec = {
                    0x8176 = (0x84b51043 0x820510ec 0x820210ec 0x820110ec 0x920410ec 0x920010ec 0x919910ec 0x919510ec 0x719410ec 0x820010ec 0x819510ec 0x615010ec 0x619510ec 0x619410ec 0x874a1462 0x2a571a3b 0x619310ec 0x619210ec 0x619110ec 0x61821025 0x61811025 0x618010ec 0x617910ec 0x617810ec 0x617710ec 0x617610ec 0x915010ec 0x920310ec 0x920210ec 0x920110ec 0x91981028 0x38741462 0x91971028 0x919610ec 0x919410ec 0x20571a3b 0x919310ec 0x919210ec 0x919110ec 0x91871025 0x91861025 0x16b310cf 0x1786103c 0x169f103c 0x918510ec 0x918410ec 0x918210ec 0x918110ec 0x917610ec 0x715010ec 0x824a1462 0x1a391a3b 0x719310ec 0x719210ec 0x719110ec 0x71821025 0x71811025 0x718010ec 0x717910ec 0x717810ec 0x717710ec 0x717610ec 0x815010ec 0x818a10ec 0x761110ec 0x23151a32 0x820410ec 0x820310ec 0x819910ec 0x1629103c 0x7185144f 0x3151a32 0x820610ec 0x8176185f 0x81981028 0x38241462 0x819710ec 0x81941028 0x11391a3b 0x819310ec 0x819210ec 0x819110ec 0x81871025 0x81861025 0x822210ec 0x821810ec 0x821710ec 0x821610ec 0x821510ec 0x822110ec 0x821410ec 0x821310ec 0x821210ec 0x821110ec 0x822010ec 0x821010ec 0x820910ec 0x820810ec 0x820710ec 0x821910ec 0x818510ec 0x818410ec 0x818210ec 0x818110ec 0x817510ec 0x817610ec),
                    0x8177 = (-0x1),
                    0x8178 = (0x84b61043 0x61801025 0x61791025 0x617810ec 0x91801025 0x91791025 0x917810ec 0x71801025 0x71791025 0x717810ec 0x14021b9a 0x14011b9a 0x14001b9a 0x762210ec 0x818910ec 0x11781a3b 0x819110ec 0x818310ec 0x818610ec 0x81801025 0x81791025 0x817810ec),
                    0x8191 = (-0x1)

 

Been working on this for a couple days now, and help would be appreciated.

Comments 5 CommentsJump to latest comment

EdT's picture

You need to check the driver database for any other drivers which may have a matching device ID in their INF files, as the problem could be caused by the operating system finding an older driver INF first and then trying to load an incompatible driver file.

The other question I have relates to your manual installation of the driver - do you get any unsigned driver messages when installing manually?

If your issue has been solved, please use the "Mark as Solution" link on the most relevant thread.

JonahG's picture

I deleted all the drivers from the database yesterday that I had installed for this model of wireless NIC and just uploaded one driver for 32 bit Win7 and one for 64 bit Win 7.  I checked the driver_manifest.txt file this morning and the only two drivers that show up while search for the device ID are the two I re-added.  Still am getting the missing driver error under 64 bit.  I tried imaging the laptop to Win7 x86 and all drivers including the wireless NIC loaded fine with DA. 

As for you other question, no I didn't get a unsigned driver message when I installed the driver manually on Win7 x64. 

If you have any other idea's to try, let me know.  I just thought of something I'm going to test right now (thinking maybe that 32 bit drivers if messing with the 64 bit one.)

 

Thanks

EdT's picture

Here is a list of the things I would look at.

1. Check the fileset of the driver files you are loading into the DeployAnywhere database. As a minimum, you need a SYS CAT and INF file. Open the INF file and check that the list of files that need to be installed are all present in the fileset that is added to the DeployAnywhere database. Make sure that this exact filelist is sufficient to allow a manual installation after the image is built. It is not unusual for a driver fileset to include some DLLs as well.

2. Check the machine bios settings to make sure that the NIC is enabled and what power options are defined. It occurs to me that if the NIC is powered down for some reason when the plug and play system looks for devices, then the driver would not get installed.

3. If the exact same machine works fine with the 32 bit driver set and 32 bit operating system install, then I would think point 2 is going to be the cause. In that case I am more likely to suspect the drivers, and I would be taking a closer look at the INF files to compare them.

4. Check if any of the 64 bit driver files are already present in the base operating system. There may be a conflict if they are already present, but don't correctly support your hardware.

5. If you are using WinPE as your boot image for the Ghost process, can I check that you are aware that WinPE needs Vista 32 bit drivers for supporting the NIC and SATA chipsets on the target machine, regardless of the operating system being deployed?  If you already know this, apologies for bringing it up, but we do get some users who think that the drivers to be added to WinPE need to be the same as the drivers for the operating system being imaged.  The DeployAnywhere driver database is a separate entity to the WinPE driver set.

6. On a machine with a working 64 bit NIC driver, open Device Manager, and check the Device ID or Hardware ID of the NIC chipset, then open the INF file that is in the DeployAnywhere database and verify that the Device ID is present in the list of devices that the INF supports.

7. Check the event logs on the machine after the NIC drivers have failed to install, in case there is an event message which provides any further information on the reason for failure.

8. Is the NIC device supporting an Ethernet network connection, or a Wireless chipset?  If the latter, then one other issue that may arise, is if the Wireless chipset has any dependency on another hardware interface which has not yet loaded a driver.  For example, I have seen laptops where the built in optical drive appears to be connected as a USB device. If your laptop's NIC were to be connected as a USB device, then it may not be possible to mount the device until the USB driver has loaded.  Yes, it's a long shot, but would explain why the same driver files appear to load happily after the machine has finished imaging.

If your issue has been solved, please use the "Mark as Solution" link on the most relevant thread.

UCLCHEMENG's picture

Heres an easy solution

Disable your wireless nw card in the bios and any other nw cards then re run the deployanywhere step. You can install the driver yourself once you can boot into windows.