Video Screencast Help
Symantec to Separate Into Two Focused, Industry-Leading Technology Companies. Learn more.

Deploying a script on Alteris

Created: 12 Sep 2012 • Updated: 12 Sep 2012 | 3 comments
This issue has been solved. See solution.

Hi,

I have an .exe that adds a password to the bios settings on our Dell PCs that is stored on one of our servers. I have created a batch file that copies the .exe to the C: and runs it.  This works with no problems when ran from the client.  I need to find a way of running this .exe from alteris, either running it directly or by running the batch file that copies then runs it locally.

The batch file contents are:

xcopy \\servername\apps\Dell_bios_set.exe c:\
start c:\dell_bios_set.exe

I have tried running this as a script but get an error.  I've also tried using the %AGENTIPADDR% and %COMPNAME% tokens, and tried using a file copy to get the exe to the PC before running it, but am getting nowhere.

If anyone has any ideas I'd love to hear them

Thanks

Comments 3 CommentsJump to latest comment

mortenleth's picture

I would assume that your problem is priviledges, with being 100% sure.

The thing is, when you run your script, if you haven't configured it to do otherwise, you run it using local system priviledges, which is the computer accout.
Try either giving the account rights to the folder, OR specify an account.

Kind Regards
Morten Leth

SOLUTION
andykn101's picture

If you're using DS 6.9 you can just create a Job with a "Distribute software" Task

Name: \\servername\apps\Dell_bios_set.exe

And that should be it.

Authorised Symantec Consultant (ASC) with Endpoint Management Limited, an Authorised Symantec Delivery Provider based in the UK.

Connect Etiquette: Please "Mark as Solution" posts that fix your problem.

Insert_username_here's picture

Thanks mortenleth, that looks to have been it.  I changed the account and It all runs fine now.

andykn101 - I can't see that on my task list, I'll have to look into it later

Thanks for the help guys.