Video Screencast Help

Deploying Sysprepped Image fails

Created: 06 Nov 2013 • Updated: 06 Nov 2013

I have been fighting with this and have had it intermittently work but now it consistently does not. I am hoping I simply made a procedural mistake, but I really don't know how I can strip it down my steps any further.

 

We just got a new batch of machines that we've never used before and haven't been on our domain. I created a Windows install with our key and proper settings, then installed the SMA on the machine. Next, I created a job with the following tasks:

 

  1. Run prepare for image capture (Set to Windows 7 Pro x64, current key).
  2. Boot to PXE
  3. Capture image

It successfully captures the image and I appear good to go. If I add the step "Reboot to production" the machine boots up as if it had just been deployed. The weird part happens if I wipe that machine and attempt to push the just-captured ghost image.

 

I created the job with the following steps:

  1. Boot to PXE
  2. Deploy Image, using current key
  3. Boot to production

Upon the boot to production step, Windows runs through its inital first-boot steps and hangs at "Setup is applying system settngs" and stops me with "Windows could not apply unattend settings during pass [specialize]". The install is hung from this point on and I can't do anything with the machine.

 

I'm pretty confident that the deploy image job is the one causing the problems, in that either Altiris isn't generating that unattend.xml file correctly, or that I'm not feeding it the correct settings. I did notice on the "Run for prepare image capture" job, that it is automatically putting something in the password fields on "Rejoin a domain after capture is complete". The machine isn't on a domain, and I'm not sure if I'm supposed to leave these random passwords in here or get rid of them.

 

Anyone steer me in the right direction? I did some googling on it, and a lot of people suggested looking at the logs in Windows\Panther, but I didn't see anything noteworthy in there.