Video Screencast Help

Deployment hard disk(s) issue - Diskpart!

Created: 20 Dec 2013 | 5 comments

We have a batch of new lenovo laptops delivered that come with 2 disks. The first is a small SSD disk and the 2nd larger  SATA disk. the problem seems to be that the disk arrangement keeps changing

e.g. I run diskpart on a machine and get this

Disk 0 - 22GB
Disk 1 - 298GB

I run it on another of the same model and get this

Disk 0 - 298GB
Disk 1 - 22GB

as the image needs to go on the large disk you can see the probelm I am going to have.! Is there any way to make ghost put the image on the largest disk!

(or any other solution out there)

 

Thanks

 

 

Operating Systems:

Comments 5 CommentsJump to latest comment

JannasTo's picture

OK, this is weird. I'm assuming this is not a deploymnet solution issue, but still - any pointers would be helpful. I just went to rebuild the same machine and the disk #s have changed when i run diskpart in Winpe - what was Disk 0 is now Disk 1. and 1 is now 0  - This is odd!

BBC's picture

Is this probably something you can configure in the BIOS of the systems? The alternative is to disable the express cache in the BIOS of the targets for the time of the build and enable it afterwards again.

-BBC

JannasTo's picture

I've just created a new job for the machines with the different hard disk. Couldn't find anything int he BIOS to help!

Thanks

 

Klim_Belchev's picture

This looks like a hybrid SSD/SATA disk.

I believe you use the Raid utility on the machine (usually Ctrl+I, after BIOS and before boot) rather than BIOS settings.

What we do is install the OS on the bigger slower disk and later use the SSD bit to speed up the system.

Hope this helps.

Phil_W's picture

I have seen a similar thing with HP laptops with a similar setup.

If you check within Windows, the drive is seen as a single disk, the solution in my case was to add the raid drivers to Windows PE, then PE only 'sees' one disk. I found that the HP drivers only worked with PE 4.