Video Screencast Help
Symantec to Separate Into Two Focused, Industry-Leading Technology Companies. Learn more.

Deployment Problems

Created: 07 Sep 2012 • Updated: 11 Sep 2012 | 7 comments
This issue has been solved. See solution.

Hi all.  I just recently got 7.1 and I am having some issues with deploying an image.  I have spent hours looking around for my solution before posting.  If this is TL;DR, just skip to the next to last and last paragraph.

Machine info that I "pull" from:

Win7 Pro 32 bit. The Symantec Management Agent and all plug-ins (the ones we currently want deployed anyway; for example Deployment Solution Plug-in) are installed.  That is pretty much it for now because I am testing and learning.

My Create Image Tasks:

Run Prepare for Image Capture (Sysprep seems to run fine although I still have a lot to learn).  Reboot to automation.
Run Create Image.  Imaging tool: Ghost.  Image type: Disk Image
Run Reboot to Production

All seems to go just fine.  Except after the computer I pull from reboots, the Symantec Management Agent does not initialize and I can no longer PCAnywhere into or send tasks and jobs.  But I am not too concerned with this right now.  I am focusing on pulling and pushing images.

Info about my Deploy Image: 

It is an identical laptop that boots to PXE. I set up .CSV file and import that into Predefined Computers.  It boots to PXE and pulls down the Preboot configuration and pushes the image.

My Deploy Image Tasks:

Run Deploy Image.  I uncheck the DeployAnywhere box because the hardware is identical.  I select the Generate Sysprep configuration file using inventory data radio button.  Again, I have to learn Sysprep and I do not have a custom Sysprep configuration file created yet.  This is all workgroup, so I don't plug in any details to join a domain.
Run reboot to automation.

The laptop boots into Windows and all seems well except for two problems (if not more).  And this is what where I need help.  The machine has no SID.  How did I look for the SID you might ask?  I run NewSID and it immediately tells me it was unable to access the computer's SID.  I am not running NewSID to apply a new SID, simply to see what the SID is.  I wanted to make sure the SID was not identical to the computer I "pulled" my image from.  The second problem is, the Symantec Management Agent does not initialize.  It has no Computer ID and shows no task server (I assume because the agent does not initialize).

Sorry for the novel, just trying to provide details in hope of help.  So, does anyone see what I am doing wrong in pushing my image?  Specifically, why does my laptop that I depoly to have no Machine SID and why does the agent not initialize?  I can no longer PCAnywhere into or send tasks and jobs (I assume because the agent does not initialize).  Thanks!

Comments 7 CommentsJump to latest comment

Indrek_K's picture

Hello joegman

Please have a look on the this KB

http://www.symantec.com/docs/HOWTO2169

I guess ths shuld help you understand you're issue better.

joegman's picture

Thank you for the link.  The link may have helped me understand a little better what is happening, but does not help me resolve the issue.  If I read the document correctly, it says: 

If you are using DS as a plugin for the Symantec Management Platform 7.0 or 7.1 and use the 'Create Image' task, the GUIDs should automatically be updated/unique on each machine imaged and the following steps are not necessary.

I am using 7.1 and using the Create Image task.

The link you provided says:

The Altiris Agent must be completely removed and then re-applied post-imaging1, or
^If I remove the agent before imaging, how would I image it?  It would not communicate with the NS, correct?

The GUID for the Altiris Agent must be removed and the Altiris Agent must be prevented from communicating with the Notification Server prior to the computer being renamed.
^So, once you push the image, you have to quickly pull the wire so the machines don't communicate with the NS?

I ran the resetGUID command with no improvement.  My computer's agent still will not initialize.

Indrek_K's picture

Hello

If you remove the agent from the client you have to manullyreboot to PXE and then when in WinPE you have to send capture image task and reboot to production afterwards.

Also second part do I understand correcty, you'r jobs are following prepare for image capture, reboot to PXE/automation, captur image, reboot to production.
 

If yes then my questin is following, new machine get's this image, does it change it's name also before booting to production(I mean do you manualy change the name when image is intalling or have set a token in the XML answer file) If not then this is problem.

Our NS check's client name and GUID as mentioned also in the KB I provided

SOLUTION
joegman's picture

I figured out one of my problems on my own, so hopefully this will help if anyone else has this problem.

The agent would not initalize on the machine I pushed to (just to recap, after pulling the image, the agent would not initalize on that computer either) because of a small DNS issue.  Right now I do not know how this setting got applied but I am thinking it was either sysprep or the prepare for image capture task.  Under advanced TCP/IP settings, DNS suffix for this connection: WORKGROUP

I noticed I could not ping altiris.  I could ping altiris.fully.qualfied.name.  The agent was trying to contact altiris but could not until I removed the DNS suffix.

joegman's picture

Again, thank you for your help, Indrek_K.  I have been reading your link and I hope to fully understand it soon.

Yes, you understood what I was saying and you are correct about my steps.

I have only depolyed this image one time and I used a CSV file to create a predefined computer.  Once the image was pushed, the computer had a unique name (defined in the CSV file).  In other words, it did not have the name of the source computer.  The only problem now is it has no machine SID.  

I am about to re-deploy that image to a computer that is already named and has the agent installed. I bet when I push it, it will use the name of the source computer.  And as you said, this is a problem.  I will report back.  

Indrek_K, are you saying I need to define the computer's name somehow?  I was hoping Altiris would look at the computer I want to image and say: "your current Windows name is computer2.  I am going to push an image to you, after that is done, I will rename you back to computer2"

joegman's picture

Some success just now.  When I pushed the image to an unknown computer using initial deployment and all went well. The computer had a new name (randomized I assume, but that's fine) Machine SID and new Symantec Computer ID.  I am in better shape than I thought.

Indrek_K's picture

The DS 7.1 is a little complicated, but when you get it running and know how and when then it does a really good job.