Video Screencast Help
Symantec to Separate Into Two Focused, Industry-Leading Technology Companies. Learn more.

Deployment Solutions 7.1 pxe boot from unmanaged computer

Created: 10 Oct 2012 | 12 comments

Hey guys,

I got a client that is a recognized managed computer by altiris to pxe boot into a pre-boot image without too much trouble. However now I'm having issues taking a blank machine that was just put onto the network and that altiris does not know - to pxe boot. I simple do not get the "hit f8 for altiris" message with the new client. It just goes straight to the next boot stage.

What are some points I should look to for trouble shooting? Anyone with Windows DHCP settings that can show me what they have? I'm a little confused about how the BootFile Name works and what to set this too (the managed computer doesn't even need this setting in DHCP for it to work correctly)

Thanks guys!

Comments 12 CommentsJump to latest comment

ldelossa's picture

Also something I don't understand is in my PXE servers policy settings, I set "predefined computers" to a different PXE boot image, however it still goes to the first boot image I configured it with. 

Few other questions I have now - I'm having trouble getting initial deployment settings to actually show up on a unrecognized client booted into winpe. Winpe is started but there is nothing but the cmd line and the background. If I change the initial deployment settings do I thus need to re-create the pre-boot environment. Going forward what are the times in which you need to re-create preboot environment. 

Indrek_K's picture

Hello Idelossa

First the unknown computers. Seeing the F8 is normal behaviour when you have not set respond to unknown computer with a WinPE automation. Set it to use some then save changes, Update the configuration of that server agent, clear out the SBSStore and restart _netboot services in correct order (1, 4, 3, 2).

For Initial Deployment you do not need to recreate preboot envionment, the same steps as for unknown computers should help. If not then check the logs in X:\Program Files\Altiris\Altiris Agnts\Logs to see if the connection is made and does it discover that there is an Initial Deployment.

I think that should answer all you're questions, If you don't understand some steps then I can make them clearer.

Best regards

ldelossa's picture

Indrek, 

Thanks I will check out the logs. The problem was not that I was presented with an F8 menu but rather there was none - it was actually caused by not having a DHCP scope options enabled. 

But exactly how do I configure a default image for the computer to boot into after hitting F8? "set it to use some" as you put -- no where have I seen a default method other then in the PXE boot policy - and even when  I have those set it shows me all my configured pre-boot images.

Indrek_K's picture

Hello

If PXE environemnt do not appear and no F8 for machines I would use following

http://www.symantec.com/docs/HOWTO7071

http://www.symantec.com/docs/HOWTO5258

 

About the menu if you select in console settings and PXE serve configuration you can set the environment there and then no need to press f8.

Hope this will help you.

ldelossa's picture

Indrek, 

The menu I'm referring to that is not showing up is the menu located WITHIN the preboot environment. Basically I'm hitting f8, going into the pre-boot environment (winPE) and then there is just NOTHING to do there, just a cmd line and nothing else. I have initial deployment set up but that does not seem like it's doing anything. It literally just sits there with an altiris background and nothing else. 

Indrek_K's picture

Hello Idelossa

Now this is the place where we should have a look in the logs.

When machine is in the Automation Environment (Altiris background)

Open the command prompt windows and located youself to X:\Program Files\Altiris\Altiris Agent\Logs

Open the logs in the using notepad and review them to see if connection to Server is made and does the client receive Initial Deploymant. They may seem complicated when you are looking at them first time. If you need help you can attach them here and I can have a look and maybe seewhat is causing the issue.

Best regards

ldelossa's picture

Indrek, 

Thanks for the help - I'm in an office is a little far away however I may be able to upload the log itself. I'll take a look to see what I find. 

ldelossa's picture

Indrek,

I got the logs from the winPE session - I will take a deeper look now however I figured I'd show them to you since you may have a better idea of whats going on. 

AttachmentSize
winPElogs.zip 3.52 KB
ldelossa's picture

Indrek,

I was able to get the initial deployment menu to show up once I went to the altiris server itself opened the Symantec Mnagement Agent -> went to settings -> hit update -> came back out and then clicked "check for tasks" under the task status tab. Is this necessary every time???

Also now that I have a task menu for unrecognized computers - how do I create a task menu for Recognized computers?? 

Indrek_K's picture

Hello Idelossa

If you make changes then yes alays need to update configuration in agent so the settins get known, by default it upates itself every hour.

For known computer there is no Initial Deployment from Symantec (coming in 7.5) some people use VB script for this.

Pkoutoulas's picture

What about it just sitting at a cmd prompt? I am having the same issue. In 6.9, when it would boot into automation, It would pop up with the Altiris screen and say Client Record Updated and wait for a job. Now it is just sitting there at an X:\ prompt. 

Ishani Bose's picture

Initial Deployment Menu is only displayed once for an unknown machine which is booting to PXE for the first time, i.e. the unknown client entry does not exists under Manage->Computers.

If a machine entry exists under Manage->computer and boot the machine to PXE.Initial Deployment menu will not be displayed.