Video Screencast Help
Protect Your POS Environment Against Retail Data Breaches. Learn More.

Desktop/Laptop Option 7.0 - Non-Admin accounts cannot run DLO Agent

Created: 25 May 2012 • Updated: 06 Jun 2012 | 3 comments
This issue has been solved. See solution.

Hopefully this will be the last major issue I run into.

I have been using the Install Agents tool from the server to install several users with the DLO client. It was working fine when I was installing it to our IT staff, but when I started trying to roll it out to our other users, I had some problems.

Whenever the installation finishes and I try to have the users run the DLO client, they get an error message: "V-138-32768-16389. Unspecificed Error. Failed to load configuration settings."

I'm stumped about this. I've tried setting up their accounts manually on the server side, no luck. (It wouldn't propogate the user or computer.) I tried to elevate them to Administrator privilege and run it, but it kept giving me the same error. The only time I managed to get it to run properly was by using Run As Administrator, and giving it the account info that was used to install the software. Normal users don't have access to this account info, so that's bad enough. But on top of that, when their account then shows up on the server, it uses that administrative account name instead of the user that's logged in to the computer.

I'm seriously getting frustrated with this, and have no idea how to get it to work. I can't imagine we're the only company with a setup like this, as I know most companies don't let regular users have admin rights. Can someone give me any suggestions on this, or point me to an article? I've already tried an old one dealing with database permissions, but they were all set up correctly already...

Note: I plan on submitting a support ticket for this. I just wanted to see if anyone else had this problem and any suggestions. If I get a solution through support, I'll post it back here for others.

Comments 3 CommentsJump to latest comment

Goltrek's picture

I'm having the exactly the same behavior, even with local admin accounts..!

First at all, let me explain my environment>

I have a server dedicated to run Microsoft SQL Server that support the DLO DataBase.
Another server, runs SYMANTEC DLO 7.

Our client computers run Windows 7 (64 and 32 bits).

I'm deploying the first SYMC DLO Agents. I started with a person from the IT Staff. We're not using Automated User Assigment rules; instead, we're provisioning users manually.

Doesn't matter what we do, we always received the same error:
"V-138-32768-16389.
Unspecificed Error. Failed to load configuration settings."

I checked that user can read/write on the NUDF.

In my case, (and for testing effects), I added the user account to the Local Administrators group on the Windows 7 computer.

We test in another computer, and the result is the same.

Gregg J's picture

Yeah, I've tried everything you have, and nothing has worked for me. I just submitted a support ticket for it, so hopefully I'll get this issue fixed relatively soon. As soon as I do, I'll post the solution I got here. Hopefully it will work for you too.

Gregg J's picture

Oddly enough, re-installing the server cleared up this issue. Apparently I had a corrupt file somewhere on the server that was stopping this from working properly. Thanks for the assistance, though.

SOLUTION