Video Screencast Help
Symantec Appoints Michael A. Brown CEO. Learn more.

Device Drivers

Created: 27 Feb 2009 • Updated: 23 May 2010 | 2 comments
This issue has been solved. See solution.

I'm new to repackaging and have a question about device drivers. I repackaged "Olympus Digital Wave Player" with WPS 6.0. This software is used to transfer wav files from a voice recorder to a workstation. I tested  the installation of the package (with normal user credentails), and it installed without any errors. But when i connect the voice recorder to a USB-port, the "detecting new hardware" screen appears, and asks me for credentials with administrative rights. How can i deploy the package, without being asked to install the driver?

Comments 2 CommentsJump to latest comment

spazzzen's picture

If I remember correctly, you can not package drives using WPS, but I am not an expert on this at all.  As for why it is asking for credentials to install the device, at that point its not using the package at all, hence the reason it is asking for administrative rights to install the driver.  Have you tried installing the software after the device is already plugged in?  Since the package has the admin rights in it, it may find the unknown device and auto install the drivers, but as I said before, I dont think wise can handle drivers.

kevin.elwell's picture

Please reference this article http://www.symantec.com/connect/articles/how-package-signed-device-driver-using-wise-package-studio as it has all the information about driver packaging.

 

Good luck!

 

Kevin

SOLUTION