Video Screencast Help
Symantec to Separate Into Two Focused, Industry-Leading Technology Companies. Learn more.

DFSR - Recovery

Created: 21 Oct 2013 | 7 comments

Hi all,

I am running BE2012 on a server running 2008 R2. The network is on 2 sites with DFSR running between the two sites. The issue we are having is recovery of a DFS file. The BE2012 is running on the DC with agents on Exchange and Files servers. Exchange backup is running fine.

The problem is a backup is run on the DC for the file server and picks up over 100GB of data. But when I try and recover a single file from that backup it shows the folders but 0Kb?????

I have adjusted backup selections to backup shadow copies, DFS, System state, all shared files etc. But nothing seems to work. All backups are completing successfully. Have removed the server and re-added, but no change.

Any ideas are welcome please.

Operating Systems:

Comments 7 CommentsJump to latest comment

Jaydeep S's picture

"But when I try and recover a single file from that backup it shows the folders but 0Kb?????"

DFS/R would be backed up and restored from Shadow Copy Components. Have you tried to recover from these files. The size showing incorrectly might be cosmetic.

3GITech's picture

Hi Jaydeep,

Yeah, have tried to restore. It restores the folders but no files. Tried on Shadow copies and direct file recovery. Nothing seems to work. Only folders are recovered. I am trying to recover these files to a different location to ensure it is the most up to date before moving them to the file structure if that makes any difference with DFS recovery?

Jaydeep S's picture

See if this helps as redirecting DFSR data is tricky.

http://www.symantec.com/docs/TECH85354

Avkash K's picture

If these DFSR data has long path names then job will get completed successfully, but no data will be backed up as per the below article.

If same is the case with u then u can try shortening the data path.

Or i would suggest to open the case with support to have the resolution on the same.

http://www.symantec.com/docs/TECH210203

Regards,

Avkash K

VJware's picture

Redirection is OK provided the target server has an active DFSR writer...(http://www.symantec.com/business/support/index?pag...)

What happens if you choose to redirect restore without restoring NTFS permissions ?

bandit61's picture

Check your selections under files and folders, attched you see ours and restore/redirect works fine.

files_folders.jpg
3GITech's picture

Hi VJ, I have changed the restore location back to the file server than is running the DFS but the folder properties is hsowing a file but nothing is dispalyed in the folder?

Hi Crypto_Bandit, I have changed the backup settings to be the same as your screen shot. Once the backup runs again I will update to the outcome. 

Many thanks everyone for the suggestions.