Video Screencast Help
Symantec to Separate Into Two Focused, Industry-Leading Technology Companies. Learn more.

Dialog Script Editor Regsitry Problem

Created: 28 Nov 2012 | 3 comments

Hi,

Can anyone explain why this might happen....

Using WiseScript Editor 8 and in the main script section I put this line to get a registry value out the 32 bit registry.

Rem ---Look for CRRedist2008 (Business Objects) ---
Get Registry Key Software\Business Objects\10.5\Report Application Server\InProcServer place in Variable CR-REDIST-VERSION

Which works absolutly fine.

However.....

If I open one of my dialogs and proceed into the Dialog Script Editor section, then paste the same line of code in and run it, then the application crashes on me with...

Problem signature:
Problem Event Name: BEX
Application Name: Setup.exe_unknown
Application Version: 1.0.0.0
Application Timestamp: 4f3d945b
Fault Module Name: GLC8DC1.tmp
Fault Module Version: 0.0.0.0
Fault Module Timestamp: 4f3db074
Exception Offset: 0000287c
Exception Code: c0000409
Exception Data: 00000000
OS Version: 6.1.7601.2.1.0.16.7
Locale ID: 2057
Additional Information 1: f050
Additional Information 2: f050b652f4a040a0e41eff43518f2a6c
Additional Information 3: fa59
Additional Information 4: fa59fe24eec0e2366b4b3ecb1d462bda

If I use a different registry key like this one

Rem ---Look for AltovaXML 2008 version ---
Get Registry Key Software\Altova\AltovaXML\Installation_v2008\Setup place in Variable ALTOVA-VERSION

Then it works correctly in both the main script section and within any dialog script editor.

Both examples have numeric values only in their values and both are a REG_SZ type.

Discussion Filed Under:

Comments 3 CommentsJump to latest comment

EdT's picture

WIS 8 is extremely old (mid 1990'S), so I have to scratch around in the depths of memory, but what I would try first is to reduce the length of your variable name CR-REDIST-VERSION  to something like CR-REDIST-VER

Something in the back of my mind says that the variable name needs to be no more than 15 chars long.

You can see that ALTOVA-VERSION is only 14 characters long so may not cause errors for that reason.

If your issue has been solved, please use the "Mark as Solution" link on the most relevant thread.

Paul1977's picture

Yeh that was the first thing I tried EdT, didn't make a difference though. I've actually got around the problem now anyway by just moving some of scripts around to different places but I'll have a play around with it later and see if I can get it working. If I do then I'll put the solution in this thread for all. Handy to know.

EdT's picture

Always worth mentioning what you have done already, to avoid duplication of ideas.

It is also worth single stepping through code that is "suspect" and monitoring the values entered into variables at each step. Ultimately though, it could well be a bug in the product, but the chances of viewing the release notes for your version are now zero, as there have been two changes of ownership of the Wise products since WIS 8 and at least three changes of knowledgebase platform, so ancient documentation has no doubt gone into the can.

One other thing I noted - your operating system version is reported as 6.1 which is Windows 7. If this is the 64 bit version, you should also be aware that Wise Installation Studio is a 32 bit application and your registry calls are therefore going to be redirected to the syswow64 part of the registry and you are not going to be able to read anything in the 64 bit areas of the registry.

If your issue has been solved, please use the "Mark as Solution" link on the most relevant thread.