Video Screencast Help
Scheduled Maintenance: Symantec Connect is scheduled to be down Saturday, April 19 from 10am to 2pm Pacific Standard Time (GMT: 5pm to 9pm) for server migration and upgrade.
Please accept our apologies in advance for any inconvenience this might cause.

Differential backup issue

Created: 19 Jan 2007 • Updated: 23 May 2010 | 11 comments

I am using differential (using archive bit) backups and it appears its not backing up modified files. Here is what Im seeing. I performed a full backup on 1/16/07 and it succeeded. I then changed the backup to differential. I modified a file on 1/1707. The differential then ran that night on 1/17/07 and it succeeded. When I go to restore and choose the differential backup set.. my file that modified 1/17/07 is not there. If I go to the full set I see the file, but its before it was modified and shows the date 9/5/06. What am I doing wrong? I appreciate any help. Thank you.

Comments 11 CommentsJump to latest comment

Phil Hess's picture

It appears anything new that is created is added to the differential, but anything that is modified is not. Do I need to changed the differential to use modified time instead of archive bit?

David Sanz's picture

No Phil

Everytime you add a file its archive bit is set, so any incremental or differential backup should copy it.

Make sure both the full and the differential backup use the archive bit.

Phil Hess's picture

The original Full backup was using the archive bit and the differential backup also using archive bit. New files were backed up, but modified files were not. Any ideas?

David Sanz's picture

Modify a file and have a look at the archive bit.

Has it been cheked?

Phil Hess's picture

Can you tell me exactly where to look for that? I modified a file and ran one of my scheduled differential backups manually and sure enough it backed it up. It just seems so hit or miss, but I need to make sure its working everytime.

Ken Putnam's picture

Are you using the same selection list for both the Full and the DIFF?

For some reason it needs to be the same select list, not two lists with the same entries (at least at one point it did)

If this response answers your concern, please mark it as a "solution"

Phil Hess's picture

Yes I am using the same list. Thanks for the replies, Im sticking with this method and keeping an eye on it.

Ken Putnam's picture

As far as manually checking the Archive Bit

From Windows Explorer, drill down 'til you find the file
Right Click\Properties\
Select Advanced
If the bit is set, it should say "Ready for Achiving"

It should stay like this until either an INCR or a FULL is run. Either will clear the bit

If this response answers your concern, please mark it as a "solution"

Phil Hess's picture

Ken, thanks for all the replies on this. Another questions regarding differential backups, last night I had one that was 14GB, usually only 100mb or so. I checked the log for the C: drive and it said 0 files different, but processed 14GB. Apparently the only thing that was changed on this server was security on the C: drive, would this cause the C: to be completely backed up again?

Ken Putnam's picture

MMMMMMM

I guess it could

Check the Archive Bit on a file (see prior post) verify that it is not set

Change rights and check again.

If this response answers your concern, please mark it as a "solution"

Phil Hess's picture

It appears it does. Went to a file in a certain directory, archive was unchecked. I then changed security on that directory and anything under it and went back to that same file and sure enough archive was checked.