Video Screencast Help
Symantec to Separate Into Two Focused, Industry-Leading Technology Companies. Learn more.

Difficulties with V. 6.4.1895 - due to changed temp-variables?

Created: 26 Jun 2013 | 5 comments

Helo,

after updating SWV from version 6.4.1711 to 18.95 I got several problems.

First problem Firefox portable doesn‘t start any longer after being packed in an empty layer while chromium-clone does for example.

Secondly SWV refuses the installation of a new – not empty – layer. A window always splashes up with the hint that the temporary path has not been found.

I must say that I have changed the temporary folders temp and tmp weeks before during the version 6.4.1711 was still installed and had no problems then before updating.These folders are now on another partition than c:.

As a first approach I have SWV deinstalled and the fsldr folder deleted. But this didn‘t help at all.Only the reimporting of the exported layers worked fine.

Thank you for ideas and help in advance.

Operating Systems:

Comments 5 CommentsJump to latest comment

ksreek's picture

Assuming the agent was upgraded with the layers already loaded, How does the variable path look like in the layer properties before and after upgrade ?

For E.g in a 6.4.1711 go to the properties of the layer and navigate to "Variables" tab identify the user variable path for [TEMP]

In a upgraded machine (1895) with pre-loaded layers the layer should have upgraded itself. Now in this version go to the layer properties and Navigate to the "Variables" tab and locate the Path for [TEMP]. Are they both the same before and after upgrade ?

Also comparing the layer structure inside the FSLRDR folder might also help to identify if something is breaking during the layer upgrade.

c:\fslrdr\{Magic Number for RO}\User_Template\[_B_]TEMP[_E_]

herbon's picture

Helo,

thank you to ksreek for your quick reply and step-by-step instruction.
Meanwhile I followed your advice.
What I found:

1. Comparing the variables of some reimported programs (*.xpf- files), which are working fine, with new installed layers there are no differences between user and system variables. The actual temp folder is correctly recognized.

2. Concerning the folders in c:\fslrdr containing user_template\[_B_]TEMP[_E_] I didn‘t find anything, meaning the folders are empty.

Perhaps I should describe the errors more in detail to give you more insight.

First example empty layers:
As I said already only Firefox portable – firefox.exe autostart in a new empty layer – doesn‘t start while Iron portable (Chromium) for example works fine. The same ist true for example for Internet Explorer or Windows Mediaplayer. The Firefox layer becomes activated when trying to start Firefox. What is a little bit surprising: Right click on the activated Firefox layer doesn‘t display the deactivating option in the first step but in a second right click only.This is different in comparison to fine working layers. Deletion of firefox.exe autostart in the layer – and Firefox starts again.

Second example new layer with installed program:
While trying to install a program in a new layer – so not a portable one – different kinds of error messages are displayed:

Unable to execute file in the temporary directory. Setup aborted.
Error 2: System cannot find the file.
(Example 7PDF)

Or something like that:
Error writing the install information on harddisk. Check you have enough memory.
(Example: Nitro Reader)

Or:
Error! Can‘t intialize plug-ins directory. Please try again later
(Example: Avidemux)

Sometimes installation runs, but starting the program an error message is displayed too:
Error: couldn‘t locate runtime module...
(Example: FLV-Player)

So at last it‘s the same problem.

I thought about program interferences, as I had installed the EMET-Tool V. 4.0 of Microsoft rather about at the same time, when updating SWV..
But complete deinstallation of EMET didn‘t help.

So far what I found.

I would appreciate further ideas and help very much.
Thank you in advance.

herbon's picture

In addition to my posting above:

 

To find out more details I did a “tracking back“ by re-deinstallation of SWV and deletion of the fslrdr folder, additionally deletion of workspace entries in the registry. After that I have reinstalled the V. 1711 – and look – now in a short test approach Firefox portable started in an empty layer and programs could be installed in new layers again. So it was as before. Only the exported *xpf-files couldn't be reimported due to an 1042 error. As I found an earlier posting of Jordan, this was not really surprising.

(http://www.symantec.com/connect/forums/error-code-1042-when-trying-activate-newly-imported-layer)

So far so good. Then I have installed V. 1895 – and had the same problems as before.

Another additional problem became clear: Trying to download or to save a file in Chromium-Iron, which is installed in SWV, always was stopped by an general error message or by“no permission to save into this folder“ (I tried several folders).

Of course these are limited experiences related to my system. But I have no more another real idea concerning inteferences of SWV with my other intalled programs. There seems to be an error in V. 1895,  write access permissions/restrictions anyhow conflicting with those of windows (7) perhaps?

So my subject header maybe a bit misleading, because it seems not to be a real problem of the changed system variables – so far I can see.

What do the experts think about?

Thank you really for help in advance.

ksreek's picture

Now I would say ,Am also waiting in the same boat with you for any expert reply on this situation ;-)

While doing so , You comment : "Another additional problem became clear: Trying to download or to save a file in Chromium-Iron, which is installed in SWV, always was stopped by an general error message or by“no permission to save into this folder“ (I tried several folders)."  makes me think of a scenario i have seen in the past where a file download from internet explorer (launched from the virtual layer) would not download replicating the similar error message (Access denied/Cannot save etc) in a Win7 64 bit envirnment. Is yours win7 64 bit ?

Am still trying to look for more info as to what we did to mitigate it.

One thing you might want to try is to Right click on the layer and enable the flag "Keep file changes in the layer" and see how it reacts . Also we might want to keep in mind that we dont override any of the NTFS permissions that might exist unless it was explicitly modifed during the package capture.

Secondly , Can you also remove Firefox within the empty layer and just play around with JUST a Emply layer and layer and see if we are able to reproduce this in your environment. I was able to create, export and import and plain layer between these versions just fine...

herbon's picture

Helo,

 

thank you ksreek for your reply and help.

 

1. I have a 32 bit Win 7.

 

2. Right click and „Keep the file in layer“ doesn‘t change anything.

 

3. I am not sure what you mean with your 2nd advice “..just play around“. Fact is, that every playing meaning exporting a firefox layer and reimporting doesn‘t help (V. 1895)

As far as I understand - you have a parallel installation V 1711 and 1895?

Trying to install 1711 after 1895 was stopped here, because 1711 is the older version.

Doing installation of 1895 after 1711 will create an update to 1895 only. I can‘t see any option to get an parallel installation.

The only workaround I can see a until now is “donwstaging“ back to V. 1711, which did a really good job over here. That would mean reinstalling all my programs, because reimporting doesn‘t work (as told error 1042).

But this would be no satisfying solution of course.

Any other ideas? Thank you.