Video Screencast Help
Symantec to Separate Into Two Focused, Industry-Leading Technology Companies. Learn more.

DirectoryService: CreateDirectoryService number of tries: : 6

Created: 03 Feb 2013 • Updated: 12 Mar 2013 | 6 comments
Sarah.Seftel's picture
This issue has been solved. See solution.

Hi,

In one of my customers I have a weird issue.
when restarting EV serveices, I get event 8229 (DirectoryService: CreateDirectoryService number of tries: : 6) about 25-30 times before the rest of the services are coming up and I can connect to the VAC.

any ideas? what to check?

Sarah.

 

Comments 6 CommentsJump to latest comment

JesusWept3's picture

DTrace the DirectoryService
Thats typically when the Admin Service has been started and the Directory Service is starting or has been stopped

Based on the frequency I would almost expect it to be a backup type script that has a delay between starting the admin and the Directory service

However it could be a long long start up of the DS, so you have to get a dtrace to see whether somethings holding up.

So maybe if you have a chance, stop all the services, dtrace admin and directory, start admin service and the directory service and see whether it starts up quickly or not, and if not, check the dtrace and see whats taking so long

TonySterling's picture

In addition to what JW3 has suggested, does the EV Server have connection to the internet?

If not, try this:

1) Log onto the Enterprise Vault server as the vault service account.

2) Open Internet Explorer -> Tools -> Internet Options -> Advanced -> Scroll down  to Security and UNCHECK "Check for publisher's certificate revocation", Apply changes.

3) Start the Enterprise Vault services.

JesusWept3's picture

argh yeah, good catch tony! :)

Rob.Wilcox's picture

Is this every time the machine is restarted?

Does the server have access to the internet?
Does the server have a ton of other programs added to it's startup?
Is there connectivity delays/issues between the EV server and the SQL server hosting the EV databases?
Is there significant load on the SQL server?

StephenConnolly's picture

Does the certificate revocation actually resolve the problem? Most EV processes now have a config file that switches this off at the process level so no need for that IE change (in any case you have to remember to make that change when logged in as the VSA as it's effective on a per-user basis)

Stephen Connolly | Configuration Manager| Cofunds Ltd | LinkedIn

Sarah.Seftel's picture

Hi all,

the issue has been solved after applying the following SQL query from TN:

http://www.symantec.com/business/support/index?pag...

 

it looks like the DB were "stuck" and hence the retry logging to the directory.

once the SQL script run, watchfile table cleared - directory service comes up in first try.

SOLUTION