Video Screencast Help

Disable AOFO completely

Created: 21 Jul 2009 • Updated: 21 May 2010 | 5 comments

How do you prevent Backupexec from using AOFO on 2008 remote agent? I don't even have advanced open file license, it is unchecked in backup exec options and is unchecked for the job but no matter what it tries to use VSS. Gives me catastrophic error about VSS being disabled.  That was the only way I could even get it to backup anything was to disable VSS on the server.  Otherwise I would get empty folders in the backup, not it is getting the data but I get the error.  How can I just force it to do a standard backup and why is it overriding my setting of not using AOFO? Thanks

Comments 5 CommentsJump to latest comment

Ben L.'s picture

You will not be able to disable AOFO completely.  Certain parts of the OS can only get backed up using VSS. VSS should be set to manual on the OS so that it can be called when needed.  If you have AOFO unchecked in the job, but certain parts are still trying to use it for the backup it is because the OS requires that it be backed up with VSS.

If this response answers your concern, please mark it as a "solution"

RahulG's picture

You cannot disable it has it is by design of Windows 2008 it will use VSS to backup all the files and directories .It is recommended that to protect open files on Windows 2003/Windows 2008 machines, the backup job should be configured using the Microsoft Volume Shadow Copy Service (VSS) option that is available as part of the operating system.

barkster's picture

why is there no data being backup up when it was set to manual, I got no error or anthing just empty folders with a file in them that said dfsrPrivate when looked at restore. Weird thing is that they are all just simple shared folders on the same volume but when i had VSS to manual it would not backup large folder(200gb) but it did backup a seperate small folder on the same volume. Does this have something to do with those folders being part of DFS

Ben L.'s picture

Does this have something to do with those folders being part of DFS - Yes, DFS data can only be backed up via Shadow Copy Components.

Your other option would be to disable the DFS services during the backup. When DFS is turned off you would be able to do a flatfile backup without AOFO.

If this response answers your concern, please mark it as a "solution"

barkster's picture

that explains it, I just set it to use Shadow Copy and will test it, thanks for the help.