Video Screencast Help

Disable Indexing for FSA performance

Created: 28 Jun 2013 • Updated: 23 Feb 2015 | 5 comments
Icento's picture
This issue has been solved. See solution.

Dear all,

For a large FSA archiving project, I need to know if it is possible to postpone the index process.

Does anyone knows how to postpone of temporary disable the index process?

Its Enterprise Vault 10.0.3 /w hotfix 2 archiving 60TB on several clustered fileservers.

Thanks in advance,

André

Operating Systems:

Comments 5 CommentsJump to latest comment

bdk1's picture

Hi Andre,
I might look at the problem from different angle, in that if have the resources available you could scale up indexing using one or more dedicated indexing server in an indexing group.
Although you will need to bear in mind that once they have been added to an indexing group they can't be removed.

Bradley

Rob.Wilcox's picture

I'd go back to the original question here.

Where are you seeing the performance hit?  And what effect is it having?

For example, you're archiving these files outside of the normal work day, right?  And it's taking some time...  sure...  and the EV server is running at, say 90%+ CPU...  but does that matter? And why does it matter? What impact is it having?

Jeff Shotton's picture

Index is a deferred process anyway. When archiving is happening at full bore, it is normal for indexing to lag behind slightly.

If you want to add items at a different time, set indexing into read-only with powershell, and make it read-write when you want to add items.

But for the fact Rob has already asked the questions above, I would be asking them too....

Regards,

Jeff

Jeff Shotton

Principal Consultant

Adept-tec Ltd

Website: here

Icento's picture

Dear all,

Thanks for your replies.

According the performance guide for FSA, there is a performance gain when deferring the index at the start of the archiving. Because of the limited time we have for the archiving, the customer decided to index the data after the archiving. All archiving points have the index on defer and indexing will be enabled later and with the setting brief.

Thanks for all the reactions.

regards,

André

______________________
Life is too short for drinking cheap beer

JesusWept3's picture

Don't do it, FSAUtility requires indexes to run properly and you don't wanna be in a situation where you need FSAUtility and you're stuck having to index items

SOLUTION