Video Screencast Help

Disabling Outlook 2010 Cache Exchange mode and Enterprise Vault tab is missing

Created: 08 Apr 2013 • Updated: 05 May 2013 | 2 comments
DMP's picture
This issue has been solved. See solution.

I desperatly searching in a way I can disable Outlook 2010 Cache Exchange for the computer and not just base on a user. Our scenario all our users are enable for Cache Exchange mode and Enterprise Vault work fine on their regular computers an the EV tab is displayed in Ourlook 2010 as it should. My problem is we do have users using shared computer and/or they often use Boardroom computer so I need to disable Cache Exchange mode so no creation of they OST is done so its not replicated onto all the computers they access. What seem to be the soloution for Microsoft Outlook for doing this for a computer level perspective is setting the NoOst=2 key [HKEY_LOCAL_MACHINE\SOFTWARE\Policies\Microsoft\Office\14.0\Outlook\OST] but this breaks EV client and the EV TAB will be missing and its probebly due that the User GPO is set with the following key:

HKEY_CURRENT_USER\Software\Policies\Microsoft\office\14.0\outlook\cached mode
"enable"=dword:00000001

From a previous post done by at https://www-secure.symantec.com/connect/forums/missing-enterprise-vault-tab-outlook-2010
they provide the following solution

HKEY_CURRENT_USER\Software\Policies\Microsoft\Office\14.0\Outlook\ost
dword: noost=2

And Enable Cached mode for own mailbox
HKEY_CURRENT_USER\Software\Policies\Microsoft\Office\14.0\Outlook\Cached Mode
Dword: Enable=0

The problem this involves the user GPO but I want to still make sute they have cache exchange mode on their own computer. So how can I get the EV 10.0.2 add-in to work without an OST in Outlook 2010.

Anyone has any recommendation I dont think our scenario is particuliar to us I'm sure this issue occures in other organization.

 

Operating Systems:

Comments 2 CommentsJump to latest comment

Rob.Wilcox's picture

I was the one who originally commented on the post that you linked to.

What is you're trying to do?

 

If you disable cached mode at the HKLM level, are you then trying to enable it again in the 'per user' setting?

 

Have you tried NoOst = 2, Enabled = 0, in HKEY_CURRENT_USER? Does it correctly stop OSTs being created? It shouldn't then have any affect on th Enterprise Vault Outlook Addin.

 

I can help you test it if you explain a little about what you're trying to achieve, and what you've tried.  Also have you asked Microsoft how to do what you ask?

Rob.Wilcox's picture

For what it's worth..

 

HKEY_CURRENT_USER

Software \ Policies \ Microsoft \ Office \ 14.0 \ Outlook \ OST

NoOst, a DWORD, value = 2

 

Software \ Policies \ Microsoft \ Office \ 14.0 \ Outlook \ Cached Mode

Enabled, a DWORD, value = 0

 

...  This causes Outlook to open in online mode, and the EV Outlook Addin is still available in the Outlook ribbon, and it works. Tested retrievals as well as archiving.

If you look in Control Panel -> Mail, at the Outlook profile.  You can not enable cached mode.
 
Setting those value in HKEY_LOCAL_MACHINE (Software \ Microsoft \ Office \ 14.0 \ Outlook \ OST, etc) does not appear to disable cached mode at all, and of course has no effect then on Enterprise Vault.
 
Setting those values in HKEY_LOCAL_MACHINE \ Software \ Policies \ Microsoft \ Office \ 14.0 \ Outlook, etc, does stop cached mode from being available, and the Outlook Add-in works fine.
 
So if you want to disable things on a PER MACHINE BASIS, then set them in HKEY_LOCAL_MACHINE... just on the shared computers.
SOLUTION