Video Screencast Help
Protect Your POS Environment Against Retail Data Breaches. Learn More.

Disabling PGP Notifier

Created: 21 Jun 2011 • Updated: 21 Jun 2011 | 3 comments

I have a question  on disabling PGP Notifier (the box that appears on the lower right corner every time an e-mail is sent) via Universal Server v3.1.2 and v2.12 for a PGP Dekstop client v10.0.2. Currently, all clients have the PGP Notifier enabled by default. As per the article found here, https://pgp.custhelp.com/app/answers/detail/a_id/2...; https://pgp.custhelp.com/app/answers/detail/a_id/1...; we edited the XML on v3.1.2 to add these two keys : enableAdminNotifierControl (Value: True) , useNotifier (Value:False). Once this was done, the PGP desktop client was manually forced to update policy and restarted for the policy to take effect.

However, even after a policy update, the PGP Notifer wasn't disabled on the client and the PGPPrefs.xml on the client had a 'usenotifier' value set to true. We're tyring to figure out a way to disable PGP Notifier globally via policy on the Universal Server v3.1.2 and v2.12, but haven't been successful. The only other way to go about it for now, we believe, is to script something that will parse the PGPPrefs.xml and change the usenotifier value to False. But moving forward, we'd definitely like to find out a way to do it via Policy on the Universal Server. Will this be possible? Would you say there is a fix for it and maybe we're not referring the right document? There's another document called 'Using PGP Desktop v10.1 with PGP Universal Server 3.1' that Symantec provided us with; that's where we got the 'enableAdminNotifierControl' setting from. Is there anything else that we can refer to or look into to see why the update isn't happening on the client side even after editing the XML prefs on the server?
 

PS: We have a ticket open with Symantec, and they referred us to the guide on 10.1. But like I mentioned, the fix didn't seem to work for us. 

Comments 3 CommentsJump to latest comment

Daichi Terada's picture

Hi Farooqui,

It is working in my environment (3.1/10.1).

Please double check if the two keys exist in XML Preferences Editor.

Consumer Policy --> <Your Consumer Policy> --> General --> Edit Preferences --> PGP Desktop Client

<key>enableAdminNotifierControl</key>
<true/>
<key>useNotifier</key>
<false/>

Also, please double check if the two keys exsit in PGPprefs.xml under adminPrefs section after manually updating policy.

<key>adminPrefs</key>

Thanks.

Daichi Terada, CISSP

Farooqui's picture

Daichi,

Thanks for replying.  We did exactly the same with Universal Server v3.1.2 and client v10.0.2, but what's happening on the client side (even after manually updating the policy) is this - the PGPPrefs.xml by default has useNotifier set to true because clients initially had the pop-up enabled.  After editing the XML file on the Universal Server, instead of overwriting the 'useNotifier' value to false, the server seems to append the enableAdminNotifierControl and useNotifier entries to the client PGPPrefs.xml file resulting in two values of useNotifier - one true, the other false.  The client of course just takes the 'true' value and still shows the pop-up. We're not sure why the server won't overwrite the useNotifier value and instead creates an additional entry.  Could it be a sync issue? Restarting PGP services and updating the policy manually on the client doesn't seem to do any good.

And it doesn't seem like these settings hold good only for v3.1/10.1 because even with the versions we're testing, the server does seem to append the entries, it just won't overwrite them. 

Another question, is it possible to completely grey out just the 'Notifier' piece under the 'Options' section for clients? 

Regards,

Hafsa Farooqui

Daichi Terada's picture

Hi Hafsa,

The feature was added in 3.1/10.1 so PGP Desktop needs to be 10.1+.

Yes, the keys can be added to PGPprefs.xml but it doesn't work with PGP Desktop 10.0.

Please upgrade your PGP Desktop to 10.1.

The "Notifier" in "Options" is disabled once the two keys are enabled on PGP Desktop.

Thanks.

Daichi Terada, CISSP