Video Screencast Help

Discovery Accelerator problems

Created: 26 May 2006 • Updated: 09 Oct 2012 | 6 comments
This issue has been solved. See solution.

I'm trying to complete a pretty large search and it never finishes. I've left it for over 24 hours and it hangs up around 96% complete. I'm trying to search across 8 journal archives and approximately 3000 mailbox archives so it is a pretty big search.

I've called Veritas tech support but of course have not heard back from them in 3 days - what a joke that is.

Is there any kind of verbose logging I can turn on so that if they ever do call me I can have this information ready? What other kinds of information can I gather?

Discussion Filed Under:

Comments 6 CommentsJump to latest comment

TonySterling's picture

In the search progress can you tell what index it is on? Have tried restarting the services? (DA and EV indexing)

You can run in console mode, here are the steps:

To create a console.exe.config file copy and paste the
DiscoveryService.exe.config file from the Discovery directory
and rename it to console.exe.config


Stop the Discovery Service.
Open a Command window
From the Command prompt locate the Discovery Accelerator install directory, this will be the location of the
console.exe.config file, and type the following:

Console.exe > consoledump.txt

Once you are finished reproducing, kill the process �console.exe� from task manager

It will be put in the Discovery Accelerator directory, and can be opened in notepad.

Mojorsn's picture

Jeff,

You could run a dtrace and log the discoveryservice and see what kind of information that gives you. Watch the size of the log file though, I have noticed on some dtraces the log files will grow rather quickly. Support will probably ask you for this.

Tom

Micah Wyenn 2's picture

Jeff,
This sounds to me like you might be running up against the ASP timeout limits. have you adjusted yours higher then the defaults?

micah

Jeff Jones's picture

Can you tell me what the ASP timeout limits are, and where to change them?

Micah Wyenn 2's picture

Jeff,
This might do it. If not, there's a couple more places we can explicitly set this. Keep in mind that this will change the ASP setting for your entire IIS site (which may not be what you really want). Try setting the following:

Customize the IIS and ASP services
a.From the IIS Manager, select the server and right click to select properties
b.Check the box marked �Enable Direct Metabase Edit�
c.Click okay
d.Navigate to �C:\Windows\system32\inetsrv�
e.Open the �Metabase.xml� file with notepad
f.Search on the text string �AspBufferingLimit�
g.Change the line to equal 16777216
h.Save the file
i.From the IIS Manager, select the server and right click to select properties
j.Un-Check the box marked �Enable Direct Metabase Edit�
k.Click okay
l.Right click on the IIS Manager, Select all tasks, Restart the IIS Services


micah

Logan Sutterfield's picture

Jeff,

There is not a dtrace for Discovery until V6, so Tony;s suggestion of a console dump is the only way to trace.

I would take a look at the timeout settings in the discovery..\webapp\web.config file to manipulate the session timeout settings.

SOLUTION