Video Screencast Help
Symantec to Separate Into Two Focused, Industry-Leading Technology Companies. Learn more.

Diskgroup is taking 15 min to online.

Created: 10 Sep 2012 • Updated: 12 Sep 2012 | 7 comments
This issue has been solved. See solution.

How do I figure out what is wrong? Is there an Override Attribute that will bring the diskgroup online fast? It doesn’t matter if I do a switch or just offline and online the Service group, the diskgroup takes about 1-1 1/2 min to go offline and 15 min to come online.

Discussion Filed Under:

Comments 7 CommentsJump to latest comment

sajith_cr's picture

Hi,

We need answers for few questions to help you.

Is it that only through VCS  diskgroup operations are taking time or commands like ` vxdg import <DG> `also taking time?

Also only DG import /deport is taking time or allVxVM commands  like "vxdisk -o alldgs list" are also taking time?

Do you have many disks in the system in error state?

Could you provide "vxdisk -o alldgs list" o/p

Regards,

Sajith

If this post has helped you, please vote or mark as solution.

mhab11's picture

If I deport and import the DG in VEA it still takes about 15 min.

No disks are in error state, one DG with 12 disks.

"vxdisk -o alldgs list" did not work so I did "vxdisk list" it took about 3 seconds to list all 14 disks that Veritas sees.

 

It seems to be getting worse, I just Imported again and it took almost 30 min.

 

If I import the DG through VEA all the disks show up but are stopped. VCS thinks the DG is online but non of the data is accessible. If I then offline the DG in VCS and online from VCS it takes almost 30 min but everything comes back as it should and the data it accessible.

 

mhab11's picture

If I deport and import the DG in VEA it still takes about 15 min.

No disks are in error state, one DG with 12 disks.

"vxdisk -o alldgs list" did not work so I did "vxdisk list" it took about 3 seconds to list all 14 disks that Veritas sees.

mhab11's picture

It seems to be getting worse, I just Imported again and it took almost 30 min.

mhab11's picture

Another piece, If I import the DG through VEA all the disks show up but are stopped. VCS thinks the DG is online but non of the data is accessible. If I then offline the DG in VCS and online from VCS it takes almost 30 min but everything comes back as it should and the data it accessible.

sajith_cr's picture

Looks like nothing much can be done from VCS front. I recommend to post this issue in VxVM forum.

Regards,

Sajith

If this post has helped you, please vote or mark as solution.

mhab11's picture

I did figure out what caused the problem in the first place. It appears that when I removed a switch and went to crossover cables then changed a .248 subnet to two .252 subnets one of my NIC resources started to fault a few times a day taking the SG offline then bringing it back online. As this was in the test lab it was not caught. It seems to have hosed my DG and even my scripts dont work correctly anymore. I think I may need to rebuild from the ground up.

SOLUTION