Video Screencast Help

Disks drives not shown (System Recovery 2011, 2013)

Created: 16 Apr 2013 • Updated: 13 Sep 2013 | 22 comments
ashton_har's picture
This issue has been solved. See solution.

I had installed on my notebook System Recovery 2011, it was running smoothly for several months.

I haven't run a backup job for a couple of months, and now the task is there but I can't run it, as it's greyed. The reason ? No disk drive is shown if you try to edit the task settings, or define a new backup ... (see the attached image, if it's shown..)

Upgraded to System Recovery 2013 hoping that the issue would be solved, but with no luck.. The problem is still there..

Any suggestions ?

Operating Systems:

Comments 22 CommentsJump to latest comment

DStain's picture

If you installed SSR 2013 over SSR 2011then you would have taken the 2011 settings with it.

Best to uninstall  and reinstall 2013 or clear the history by stopping the SSR service and deleting the .pqh files.

 

Deric 

ashton_har's picture

tried that (uninstall and clean install), but the result was the same...

DStain's picture

Did you clear the history by stopping the SSR service and deleting the .pqh files.

 

Deric

DStain's picture

When you uninstalled SSR and selected to delete all settings the files would have been deleted.

If not then go to Windows, Tools and Folder Options then View and enable "Show Hidden Files, Folders and Drives.

Then navigate to the directory eg. C:\ProgrammeData\Symantec\SymantecSystemRecovery\History and delete all the .pqh files. and schedule if necessary.

Restart the services or reboot the computer.

Deric

Dave_H's picture

Easy way to tell if it's a problem with the upgrade or history files would be to boot to the recovery disk and see if the partitions are visible.

The main reason why they would not be visible is partition problems.  I know that seems very unlikely since it was working fine before but if you want to rule that out please post a partinfo.

Go into the Program\SymantecSystemRecovery\Utility folder and double click partinfo,exe  It will make a text file in that same location called partinfo.txt.  You can attach it to a post by using the file attachment button below the text input box.

Dave

ashton_har's picture

Deleted the .pgh files from /history - restarted services/ rebooted, the problem is still there..

i attached the partinfo.txt file..

 

AttachmentSize
partinfo1.txt 33.08 KB
Markus Koestler's picture

Try to shrink the partitions which are not shown by some MB: https://www-secure.symantec.com/connect/forums/can...

*** Please mark thread as solved if you consider this to have answered your question(s) ***

Dave_H's picture

If you think back I'm sure the problem started when you installed Linux.  It looks like you used the Gparted tool from within the Linux setup to rearrainge the drive to be able to install the Linux partitions.

I have seen this several times recently but I can't seem to remember how it was resolved, I'll look at it more later but I have a hard time believing the starting sector of your EXT2/3 partition. If your going to try resizing any partitions I would suggest you try nudging that one back a little. Shrink the starting point of that partition back a few MB's because you can clearly see that the starting sector of it should not be the same as both the epbr and the unallocated space.

But please do so at your own risk.

Dave

 

 

 

ashton_har's picture

I've installed Ubuntu (12.04 at the time, the same day i've configured the Windows 7 partition also back on April, 2012). Ubuntu was upgraded to 12.10 on October and Symantec System Recovery was still working after that .

So it's not a problem with installing linux on the machine ..

Dave_H's picture

It really was because you can see the error in the partinfo file:

WARNING: Logical partition entries are not in sequential order.

Please post another one for us to look at.
 

 

Denus's picture

Make sure that the Partition/Drives you want to backup are not the actual backup Partition/Drives.

ashton_har's picture

tried to shrink the volumes, but the problem remains ...

Denus's picture

Maybe try this, i use this to delete old backup jobs locally (cached jobs)

1) Stop the service: 'Symantec System Recovery'

2) Delete all the files with extensions .pqh .pqj .sv2i in the following folders:

  • C:\programdata\symantec\symantec system recovery.
  • C:\programdata\symantec\symantec system recovery\History.
  • C:\programdata\symantec\symantec system recovery\Schedule.

3) Delete the RPAM folder located in the folder:

  • C:\programdata\symantec

4) Delete the hidden file vsnap.idx at the root of each drive being backed up (this is a hidden file)

5) Delete the RPAM_Store.dat from the backupdestination directory('s)

6) Move or rename the default recovery point

7) Start the symantec system recovery service and start a new backup job

ashton_har's picture

Tried all that but the problem is still there ...

Andy H.'s picture

Please post a new PARTINFO.TXT for review.

Andy Horlacher

Please mark this thread as 'solved' if it answers your question

ashton_har's picture

it's a problem with the grub 2.0 that was installed with upgrading to ubuntu 12.10 ...

 

for 2013

  • Symantec System Recovery 2013 does not support computers that use the GRUB boot loader.

  • Symantec System Recovery 2013 does not support computers that use Fedora Core3 Ext2/Ext3 or Grub 2 boot managers.

and 2011

  • Symantec System Recovery 2011 does not support computers that use the GRUB boot loader .

  • Symantec System Recovery 2011 does not support computers that use Fedora Core3 Ext2/Ext3 or Grub 2 boot managers.

ashton_har's picture

Deleted the Ubuntu 13.04 partitions and now SSR 2013 is working properly and sees my disks .

When Ubuntu was upgraded from the previous version (which hadn't grub 2.0) and changed the grub to 2.0 the problem appeared .

SOLUTION
Andy H.'s picture

Good news. Thank you for sharing that solution. 

Andy Horlacher

Please mark this thread as 'solved' if it answers your question

Denus's picture

One of our systems was not showing the C:\ drive in the list.

I tried to shrink the volume by 1MB but that didn't do the trick

 

i shrinked it with 2.294MB to make it 100.000MB, i rebooted the SSR console and the C:\ drive is shown now.

 

Hopefully this helped you, i found my answer in this post

 

http://www.symantec.com/connect/forums/system-reco...