Video Screencast Help
Protect Your POS Environment Against Retail Data Breaches. Learn More.

DLO 7.0 tries to connect only before VPN connection is established

Created: 16 Nov 2012 • Updated: 16 Nov 2012 | 3 comments

We recently upgraded from Backup Exec DLO 2010 R3 to Symantec DLO 7.0. Now, ca. 70 % of our users don't take backups anymore.

I found that the DLO client tries to connect to the DLO SQL server on startup - which fails of course because the VPN is not yet established - and then never retries. 

Is there any configuration setting for retry attempts? Or is there anything else we can do? After all, it worked fine with the old version.

 

This is the log from one of the affected clients (note that ALL entries are from before the VPN was established and the server name is correct):

 

Executable:dloclientu.exe

Machine: ...

User: ...

Domain: ...

Principle user: \...

Principle domain: 

Process domain: ...

Interactive User Name: \

Debug Mask: 0

Windows: 6.1.7601 Service Pack 1

Current directory: C:\Program Files (x86)\Symantec\Symantec DLO\DLO

Windows directory: C:\Windows

System directory: C:\Windows\system32

Path: C:\Windows\system32;C:\Windows;C:\Windows\System32\Wbem;C:\Windows\System32\WindowsPowerShell\v1.0\;C:\Program Files (x86)\Common Files\Roxio Shared\DLLShared\;C:\Program Files (x86)\Common Files\Roxio Shared\10.0\DLLShared\;C:\Program Files (x86)\Microsoft SQL Server\100\Tools\Binn\;C:\Program Files (x86)\Microsoft SQL Server\100\DTS\Binn\;C:\Program Files (x86)\Microsoft SQL Server\100\Tools\Binn\VSShell\Common7\IDE\;C:\Program Files\WIDCOMM\Bluetooth Software\;C:\Program Files\WIDCOMM\Bluetooth Software\syswow64;C:\Program Files (x86)\Enterprise Vault\EVClient\

11/16/12 09:15:56 dloclientu.exe 3596:  > client.cpp( 1571 )  -- LANGID == DEU --

11/16/12 09:15:56 dloclientu.exe 3596:  > client.cpp( 1803 )  BUILD INFO: Build 70049a 11/16/2012 09:15:56.910AM

11/16/12 09:15:56 dloclientu.exe 3596: E> client.cpp( 9020 ) Performing 'TechRefresh' for user . from staging area C:\.dlostaging\. 

11/16/12 09:15:56 dloclientu.exe 3596: E> client.cpp( 1889 )  CClientApp::InitInstance : TechRefresh() FAILED, res = e0140007

11/16/12 09:15:57 dloclientu.exe 3216: E> xmlpersist.cpp( 104 ) Fix for MP3 to MP4 export 

11/16/12 09:15:57 dloclientu.exe 3216: E> xmlpersist.cpp( 111 ) failed reading XML attribute for field GSServerLowDiskWarningPercentage: E0140007

11/16/12 09:15:57 dloclientu.exe 3216: W> shebang.cpp( 485 ) Shebang::Load failed loading DB failed loading cached settings

11/16/12 09:15:57 dloclientu.exe 3216: E> xmlpersist.cpp( 104 ) Fix for MP3 to MP4 export 

11/16/12 09:15:57 dloclientu.exe 3216: E> xmlpersist.cpp( 111 ) failed reading XML attribute for field GSServerLowDiskWarningPercentage: E0140007

11/16/12 09:16:20 dloclientu.exe 3216:  > adoutil.h( 70 ) Connection error: 80004005( 00000011 ) : [DBNETLIB][ConnectionOpen (Connect()).]SQL Server existiert nicht oder Zugriff verweigert.

11/16/12 09:16:20 dloclientu.exe 3216: E> adodb.cpp( 608 ) failed opening connection: ADODBError-_com_error: foundationerror=cc000064, comerr=80004005, nativeerror=17, conn=Provider=SQLOLEDB;Initial Catalog=DLO;Integrated Security=SSPI;Net=dbnmpntw;Address=\\SERVER\pipe\MSSQL$DLO\sql\query;Connect Timeout=20, query=, msg=Unbekannter Fehler, src=Microsoft OLE DB Provider for SQL Server, desc=[DBNETLIB][ConnectionOpen (Connect()).]SQL Server existiert nicht oder Zugriff verweigert.

11/16/12 09:16:20 dloclientu.exe 3216: E> adodb.cpp( 1232 ) ADODB::ExecuteQuery failed, caught ADODBError: ADODBError-_com_error: foundationerror=cc000064, comerr=80004005, nativeerror=17, conn=Provider=SQLOLEDB;Initial Catalog=DLO;Integrated Security=SSPI;Net=dbnmpntw;Address=\\SERVER\pipe\MSSQL$DLO\sql\query;Connect Timeout=20, query=, msg=Unbekannter Fehler, src=Microsoft OLE DB Provider for SQL Server, desc=[DBNETLIB][ConnectionOpen (Connect()).]SQL Server existiert nicht oder Zugriff verweigert.

11/16/12 09:16:20 dloclientu.exe 3216: E> xmlpersist.cpp( 104 ) Fix for MP3 to MP4 export 

11/16/12 09:16:20 dloclientu.exe 3216: E> xmlpersist.cpp( 111 ) failed reading XML attribute for field GSServerLowDiskWarningPercentage: E0140007

11/16/12 09:16:20 dloclientu.exe 3216: W> shebang.cpp( 485 ) Shebang::Load failed loading DB SQL load failure - probably no user

11/16/12 09:16:41 dloclientu.exe 3216:  > adoutil.h( 70 ) Connection error: 80004005( 00000011 ) : [DBNETLIB][ConnectionOpen (Connect()).]SQL Server existiert nicht oder Zugriff verweigert.

11/16/12 09:16:41 dloclientu.exe 3216: E> adodb.cpp( 608 ) failed opening connection: ADODBError-_com_error: foundationerror=cc000064, comerr=80004005, nativeerror=17, conn=Provider=SQLOLEDB;Initial Catalog=DLO;Integrated Security=SSPI;Net=dbnmpntw;Address=\\SERVER\pipe\MSSQL$DLO\sql\query;Connect Timeout=20, query=, msg=Unbekannter Fehler, src=Microsoft OLE DB Provider for SQL Server, desc=[DBNETLIB][ConnectionOpen (Connect()).]SQL Server existiert nicht oder Zugriff verweigert.

11/16/12 09:16:41 dloclientu.exe 3216: E> client.cpp( 3846 ) error loading database ADODBError-_com_error: foundationerror=cc000064, comerr=80004005, nativeerror=17, conn=Provider=SQLOLEDB;Initial Catalog=DLO;Integrated Security=SSPI;Net=dbnmpntw;Address=\\SERVER\pipe\MSSQL$DLO\sql\query;Connect Timeout=20, query=, msg=Unbekannter Fehler, src=Microsoft OLE DB Provider for SQL Server, desc=[DBNETLIB][ConnectionOpen (Connect()).]SQL Server existiert nicht oder Zugriff verweigert. - Verbindung mit DLO-Administrationsserver kann nicht hergestellt werden.

11/16/12 09:16:41 dloclientu.exe 3216: E> Client.h( 1076 ) CClientApp::_HandleError() : displaying error message: Die Konfigurationseinstellungen konnten nicht geladen werden.


Sie sind entweder nicht mit dem Netzwerk verbunden, oder der Server reagiert nicht. DLO muss eine Verbindung mit dem Server herstellen k÷nnen, um diesen Vorgang auszuf³hren.

11/16/12 09:16:41 dloclientu.exe 3216: E> Client.h( 1089 ) CClientApp::_HandleError() : no UI or UI is hidden. returning...

11/16/12 09:16:41 dloclientu.exe 3216: E> Client.h( 1109 ) CClientApp::_HandleError() : error shown. returning.

11/16/12 09:16:41 dloclientu.exe 3216: E> client.cpp( 2340 )  CClinetApp::StartupThread : InitializeDB FAILED result=CC000064 - THROWING res.

11/16/12 09:16:41 dloclientu.exe 3216: W> client.cpp( 2509 )  CClientApp::StartupThread : Caught param error exception, m_id=CC000064, ClientApp::StartupThread.InitializeDB - Verbindung mit DLO-Administrationsserver kann nicht hergestellt werden.

11/16/12 09:16:41 dloclientu.exe 3596: E> client.cpp( 1899 )  CClientApp::InitInstance : Initialize FAILED, res=3422552164
 

Comments 3 CommentsJump to latest comment

Backup_Exec's picture

Hi

 

It would be best to open a formal case with Symantec ,so your issue is immediately addresses and verified.

 

Additionally please try link below to see if that helps in resolving the issue

http://www.symantec.com/docs/TECH45315

http://www.symantec.com/docs/TECH49010

http://www.symantec.com/docs/TECH198424

 

Thanks

Sameer

Don't forget to give a "Thumbs Up" or Mark as "Solution" if someones advice has helped you.

stephan.vanhelden@uponor.com's picture

Thanks - it seems that this hint in TECH49010 at least improves the situation:

 

 

Open the registry Editor on the Client and Edit the following registry 
 
HKEY_LOCAL_MACHINE\SOFTWARE\Symantec\DLO\3.0\Client\DefaultMediaServer   [Type the IP instead of the Name.]