Video Screencast Help
Symantec to Separate Into Two Focused, Industry-Leading Technology Companies. Learn more.

DNS Alias for Altiris Service Desk (processmanager)

Created: 15 Aug 2012 | 15 comments

We are trying to forward a DNS alias (ex. servicedesk.com) within our network to the service desk (server/processmanager). We have set our DNS alias to point directly to the server. Then when we try to enable HTTP redirection in IIS on the server it crashes the process manager. At least that's the best way I can explain it, basically once we set the HTTP redirection for the default site on the service desk server, you can no longer get to the site. Even if you use the full /processmanager URL. 

I heard a while back that someone was able to get this to work, but I can't remember who it was. Any help would be greatly appreciated!

This is Altiris Service Desk 7.1 sp1 by the way. 

Comments 15 CommentsJump to latest comment

Aryanos's picture

We've done this but I think it was just a normal dns alias entry but I'd have to check with our datacentre guys who set this up.

I like my beats fast and my bass down low

DrTechy's picture

If you could ask I would appreciate it sooooo much! The problem is you can't create a DNS alias to point to URL, you can only create one to point directly to a server. At least that's how I have read, and that's what my DNS team is telling me. So I'm trying to redirect via IIS on the service desk server, but it keeps just crashing the processmanager for some reason. Any help is greatly appreciated!

Aryanos's picture

Here's what our DataCentre guy said he had to do:

  • DNS Alias points to <servername>.<domain>.local
  • Go on the service desk server and open up IIS
  • Expand Sites and click on Default Web Site
  • Under IIS heading you'll see ASP. Right-click on it and Explore
  • Make a copy of default.asp
  • Edit default.asp to the following:
<%
Select Case Request.ServerVariables("HTTP_HOST")
Case "<DNS alias>", "<DNS alias>.<domain>.local"
Response.Redirect "http://<DNS alias>/ProcessManager"
End Select
%>

I like my beats fast and my bass down low

DrTechy's picture

Thanks! I'm going to submit it to my sys admin to configure to see if it will work. I'll let you know, and thanks again!

Aryanos's picture

Did this work for you guys? I need to make sure my instructions are correct.

I like my beats fast and my bass down low

nazareth's picture

That is good. I was using a blank html file, with a meta tag redirect. I didn't know that this was an option in IIS. I guess this is Microsoft's equivalent of Apache's .htaccess?

Aryanos's picture

Not sure, our networks guys are in charge of things like this.

I like my beats fast and my bass down low

Rodrigo Faria's picture

This work's fine to me:

Go to IIS Manager, select the the Default Web Site (in my case).

Configure the HTTP Redirect with the following options:

Redirect requests to this destination: http://servicedesk.domain.local/ProcessManager

Mark: Only redirect requests to content in this directory (not subdirectories)

DrTechy's picture

Rodrigo,

So your process manager still loads correctly after putting in that redirect? It crashes mine every time. Won't load period after putting that in.

Rodrigo Faria's picture

DrTechy,

Yes, works fine.

What error your browser shows? 

DrTechy's picture

It doesn't show any error, just keeps trying to connect and eventually says unable to connect. The minute I remove the http redirect, it starts working almost immediately.

Rodrigo Faria's picture

The bindings options in the IIS is configured to a especified name or *?

DrTechy's picture

Rodrigo,

Thanks for the screenshots, I'll provide them to my sys admin today to see if we can get it to work. Here's a dumb question, and I haven't asked the sys admin yet, but does this service change require a reboot after making the change? I have a feeling they didn't do that when they tried the last time.

Mario