Video Screencast Help
Symantec to Separate Into Two Focused, Industry-Leading Technology Companies. Learn more.

DOS Ghost 8.3 doesn't always get IP Address via DHCP

Created: 11 May 2006 • Updated: 21 May 2010 | 6 comments
Andrew Paxie's picture

{Submitter's note: I am posting this from a customer who doesn't currently have access to this forum. I have performed some minor editing to ensure privacy.}

I have a Ghost 8.3 question and I Googled and searched the Symantec KB articles without any luck.

{...}

I am trying to switch my (and if it works more dev and QA) ghosting from external USB drives to using GhostCast, and I am having problems with Ghost and DHCP failures.

Network Performance

Getting an IP address on the {...} network in {our site} does not always succeed on the first try, and seeing DHCP warnings in NT event logs is a common occurrence. But I have yet to see any OS completely fail to get an IP.

Configuration

I am using Symantec Ghost Solution Suite 1.1.

I am testing on a DELL OptiPlex GX620 with an integrated Gb/s Broadcom network card.

First Attempt

Using Ghost I created a DOS boot disk using the generic PXE packet driver.

Ghost terminates with an error that it could not acquire an IP address from the DHCP server, or contact the DHCP server.

If I run Ghost several times maybe it gets an IP.

Second Attempt

Using Ghost I created a DOS boot disk using the Broadcom NDIS driver.

Ghost terminates with an error that it could not acquire an IP address from the DHCP server, or contact the DHCP server.

If I run Ghost several times maybe it gets an IP.

Other Experiments

I created a DOS network boot disk using the universal network bootdisk found at this location: http://www.netbootdisk.com/

Booting with this disk I always successfully get an IP, can ping, etc.

But, once I start Ghost, Ghost still sometimes, but less often, fail with the IP / DHCP errors

My Question

- Any ideas, recommendations, etc?

Discussion Filed Under:

Comments 6 CommentsJump to latest comment

Andrew Paxie's picture

{At the risk of looking like I'm answering my own question, I'm posting the following response.}

Have you considered using Windows PE (WinPE) and Ghost32.exe?

In my experience many of my networking problems been resolved once I started using the Windows networking stack and Ghost32.exe.

You will likely have to build your own copy of WinPE if it needs to be extended with a driver for your network chipset.

Andrew Paxie's picture

{Submitters note: Don't confuse this with a Dialogue. This response is posted on behalf of the (real) person who composed the original post.}

But DOS with Ghost boots in seconds and PE in a very long time, especially with lots of drivers included (booting PE from RAMDisk is faster, but still slow compared to DOS).

But DOS and Ghost sees RAID drives correctly and PE requires RAID drivers.Message was edited by:
Andrew Paxie
Oops - post => posted.

Andrew Paxie's picture

I don't propose to become an Apologist for Windows PE. What you observe with the current releases of Windows PE (up to and including WinPE 1.6) correspond to what I've observed.

Perhaps another forum user can offer some settings suggestions for the DOS network drivers. Any takers?

I encourage you to create a new thread containing your comments on RAID support under DOS compared to Windows PE.

D J's picture

Only recently I noticed that some of the network cards take longer to establish the connection when they are directly connected to a switch. This is not observed when booting to Windows probably because it takes longer to boot and the higher timeout values.
It is a long shot, but If the machine is directly connected to a switch, could you try connecting it through a simple hub?

Jeffery PinterParsons's picture

Have you determined if the switch has port fast enabled? By default, Cisco switches do not have this enabled.

For the LiveState Delivery Pre-OS, enabling port fast is required otherwise the PXE firmware will not get a DHCP offer. Sometimes it will but the majority of the time the DHCP discovery will fail.

What about running on a simple hub? Do you get the same behavior?

Andrew Paxie's picture

How about trying this setting change?

In the WATTCP.CFG file add the line
BOOTPTO=

An important note is that the field name must be given in uppercase.

Without any overriding value set in the WATTCP.CFG file, a default value of 15 seconds is used. Clearly this is sometimes not enough.

Where to place the WATTCP.CFG file? It would be nice if the requirement was "the same directory as GHOST.EXE", but in fact it needs to be in the "current working directory". All should be well if your batch files CD to \GHOST before launching GHOST.EXE.

This knowledge base article may be helpful to you in the future
"How and when to modify the Wattcp.cfg file"
Available: http://service1.symantec.com/SUPPORT/ghost.nsf/doc...