Video Screencast Help

"Driver has detected a controller error" - help and info pls

Created: 02 May 2012 • Updated: 14 May 2012 | 7 comments
This issue has been solved. See solution.

Hi

 

We are running B/Up Exec 2010R3 on a IBM X3650 (Win 2003 R2 standard SP2) and the backup keeps failing.  It is using an IBM ULT3580-HH5 (LTO5) tape drive with an IBM SAS  controller card (actually an LSI 9212-4i4e).

I am now getting hardware errors (for about 1 week) but I have the latest drivers installed for the hardware and I have updated BE with the latest hotfixes.

The error i get in BE is

The following event was reported on 5/1/2012 8:33:30 PM:

The driver detected a controller error on \Device\RaidPort1.

--------------------

This error signifies controller errors. These errors are generally caused by hardware that is not functioning correctly. To resolve these errors, try the following actions:

- Slow the SCSI bus.
- Verify that the latest SCSI drivers and firmware are loaded.

If these errors continue to occur, contact the hardware manufacturer.

In Windows Event Viewer I get

The description for Event ID ( 129 ) in Source ( Lsi_sas2 ) cannot be found. The local computer may not have the necessary registry information or message DLL files to display messages from a remote computer. You may be able to use the /AUXSOURCE= flag to retrieve this description; see Help and Support for details. The following information is part of the event: \Device\RaidPort1.

Followed by

Event ID:11

The driver detected a controller error on \Device\RaidPort1.

For more information, see Help and Support Center at http://go.microsoft.com/fwlink/events.asp.

I can't update the drivers (as they are the latest).....  I am stuck!

The SAS cable has been changed, does this point to a fault with the controller card or tape drive????

If I do a test run it completes successfully, however when I run the backup it does 380gb successfully and then asks for another tape (the overwrite/append times are fine and have been doubled checked!).  This happens every day.....

Any help or pointers would be extremely useful

Thanks

 

Comments 7 CommentsJump to latest comment

CraigV's picture

Hi,

 

Check the IBM server diagnostics and make sure you have no errors on the SCSI card, or drives in prefailure (I've seen prefailure drives cause all sorts of issues with backups).

You can also make sure that the Removable Storage service is stopped and disabled (it causes problems with the way BE tries to lock the drive exclusively!), and that you're using the Symantec drivers for the drive, and not the HP drivers.

Do that, and report back.

Thanks!

Alternative ways to access Backup Exec Technical Support:

https://www-secure.symantec.com/connect/blogs/alte...

davewingrave's picture

Hi

Ran the tapediag tool for IBM and did a full write test, this completed successfully and wrote the full 1.5tb to the tape.

Disabled the Removable Storage service.....

Backup ran last night and again reported Tape Alart Errors.  It again wrote 380gb to the tape and ejected it, asking for another tape.

I also uninstalled the tape drive and reinstalled, still no luck

 

Thanks

CraigV's picture

...did you check the IBM server diagnostic tools to make sure the SAS card isn't faulty? If the drive writes more data then this isn't the issue.

Try the following:

1. Update the drivers for the drive (Symantec drivers!), and the firmware.

2. See if there are any firmware updates for the SAS card and install them.

3. Run LiveUpdate and install any additional patches that are still outstanding.

Also, make sure that the SAS card the drive is attached too is supported for the tape drive.

If this still doesn't work, then try the following:

1. Make sure there are no Hard Write Errors (BE --> Devices --> Click on the tape!). If there are, this can cause issues during backups. Try with another tape (new if possible!).

2. Uninstall the drive from Windows Device Manager, then delete out of BE and disconnect the drive. Restart the server and let it boot into Windows. Turn the server off, reconnect the drive, and let it start up. Once done, start up the server, and once it boots into Windows, install the Symantec drivers for the drive using the Device Configuration Wizard.

Then try a backup again!

Thanks!

Alternative ways to access Backup Exec Technical Support:

https://www-secure.symantec.com/connect/blogs/alte...

pkh's picture

Is your job set to overwrite or append to the tape?  If it is the latter, set it to overwrite the tape.

Also, as a test, turn off the compression.

davewingrave's picture

Thanks CraigV

Spend yesterday trying to resolve

No faults in the hardware (or so it appears), updated all drivers/firmware, no BupEx updates to apply.

Removed tape device from windows, removed from BupExec, disconnected, rebooted server, etc etc as per your post...... 

No Luck!  It still writes 380ish GB to tape then ejects it and asks for another.

Stuck and don't know what to do......  I have ordered another card and cable.  Going to install into another piece of hardware on Tues and install 2010R3 again to see what happens

CraigV's picture

...what sort of compression are you getting on the tape?

Have you tried to repair the BEDB using BEutility.exe and then run the backup again?

Alternative ways to access Backup Exec Technical Support:

https://www-secure.symantec.com/connect/blogs/alte...

davewingrave's picture

Despite the tape utility telling me there was no issue with the hardware, this turned out to be a faulty drive!  IBM replaced the drive 3 days ago and we have successful backups now!

Thanks for the suggestions and help along the way!

SOLUTION