Video Screencast Help

DriverDB Management Page Error

Created: 14 May 2013 • Updated: 22 May 2013 | 12 comments
This issue has been solved. See solution.

I am trying to upload some drivers to the driver db for new computers, and I got this error.  I wasn't made aware of it until tonight. I am not sure what is going on.  I thought about upgrading the software to the latest version and see if that fixes anything, but curious if anyone knows why this is happening?  Below is the screenshot after clicking on "Add"

 Altiris - DB Error.PNG

 

Operating Systems:

Comments 12 CommentsJump to latest comment

Cyclones92's picture

I updated the software on the computer and still getting this error.  Can anyone assist me or help me out?

Thomas Baird's picture

Sounds like a timeout to me.  We saw this once before on a client where Bootwiz was taking too long to run.  Give this a shot.

Navigate to program files \ Altiris \ Deployment \ Web

Find the Web.config file and edit it.

Find the line that reads httpRuntime maxRequestLength="10000"

Before the closing /, add executionTimeout="1200"

Save the file

Restart IIS

Try again.

 

That should increase the timeout from the default 5 minutes to 10 minutes.  For one customer, that was enough.

 

Let us know.

Thomas Baird
Private Consultant & open to full-time opportunities.
That means I CAN help beyond the forum (directly).

 

Cyclones92's picture

That didn't work. :( I guess the issue isn't actually adding the drivers.  It's actually seeing the page pop up to actually add them...like to find the location of the drivers to add.  I used to be able to, but now it's not working for some reason...I just get the error message above.

Cyclones92's picture

Also, when I click the "Altiris Notification Server Log" to see the error to try and troubleshoot...I get the error below...not sure if this would help troubleshoot it as well.

Capture.PNG

Thomas Baird's picture

You may need to call in to let us dig into that.  That's the same thing I saw with the other customer - same messages, but either the time is not sufficient, or...  I don't know.  You could check IIS logs to see what's happening, but it's a very generic error.

Thomas Baird
Private Consultant & open to full-time opportunities.
That means I CAN help beyond the forum (directly).

 

Indrek_K's picture

Hello,

I agree with thomas for more info contact Support.

But if we want a possible workaround then try this.

Located DriverManager.exe in Deployment Share ghost folder.

Call it in CMD and use -? and it will also tell how to use it.

Best regards

Indrek

Thomas Baird's picture

One other thing I just thought of out-side a call.  Go to the DriversDB folder, and wipe out all the driver manifest files and try again.  My "hunch" is that it's not hanging on the driver manager, but on BootWiz, but that's just a hunch, so if it is hanging on the driver manifest files for whatever reason, maybe rebuilding them will help.  Generally I just search for all of them and wipe them out in one fell swoop rather than one folder at a time which is tedius beyond belief.  There's one "master" one in the root of the folder, and one mini one in each individual folder that is concatonated into the master one at the end of the run through the folders.

Thomas Baird
Private Consultant & open to full-time opportunities.
That means I CAN help beyond the forum (directly).

 

Cyclones92's picture

Thanks Thomas for the replies!

It appears that didn't work either.  I ended up taking all the drivers out of the folder and moved them to a new location.  I didn't start/stop any services after doing so, but I did reboot the server and still got the same results. After trying to click the "add", I ended up going to my event viewer and got the following errors to show.  One points to the bootwiz.exe and the other points to an .asp issue.

 

Here is the current setup.  I didn't leave the default location for the "deployment" folder the same.  I ended up copying the deployment folder to another folder that had a larger amount of size due to the images.  It has worked 100% for months now, but I wanted to throw that out there as well.  Here are the images in the order they appeared in the event log.

Capture1.PNG

Capture2.PNG

Capture3.PNG

 

Cyclones92's picture

Here's another update from the web logs.  I hope this helps in some way

 

2013-05-21 01:41:37 fe80::d94f:5727:aa0f:88d3%9 GET /Altiris/Deployment/DADriverEditor.aspx database=deployanywhere 80 ryback\administrator fe80::457e:78f5:4c37:a847%9 Mozilla/5.0+(compatible;+MSIE+10.0;+Windows+NT+6.1;+WOW64;+Trident/6.0;+MAAU) 302 0 0 0
 
 
2013-05-21 01:41:37 fe80::d94f:5727:aa0f:88d3%9 GET /altiris/NS/error.aspx aspxerrorpath=/Altiris/Deployment/DADriverEditor.aspx 80 ryback\administrator
Indrek_K's picture

Hello,

First a littl silly question, but how does the Symantec Management Agent on the NS show where the plugins are installed?

Are they all on same Drive eg: C:\Program Files\Altiris?

Also check if the ASPX we call exist C:\Program Files\Altiris\Deployment\Web\DADriverEditor.aspx

Also try to call this ASPX manually see what happens do we get a error or what will it show us

http:\\Localhost\Altiris\Deployment\DADriverEditor.aspx

Cyclones92's picture

Thanks Indrek_K!

The .aspx file did exist and the permissions were okay on it.  I posted the solution below. :)

Cyclones92's picture

Thank you all for the respones.  I was able to work with someone and they were able to assist me. After looking at the Altiris Log Viewer, we found out the permissions were being denied on the NSCAP shared folder.  Someone made permission changes on that folder and it solved the issue once I changed them back.  Just a note in case anyone else has this issue.  Below is the screenshot I took.

 

untitled.JPG

SOLUTION