Video Screencast Help
Symantec to Separate Into Two Focused, Industry-Leading Technology Companies. Learn more.

Drives are in use in storage unit

Created: 20 Oct 2012 • Updated: 03 Nov 2012 | 7 comments
This issue has been solved. See solution.

I have three policies running which are using the same STU. Three jobs (including the parent job) are active from the first policy, three (including the parent job) from the second policy. However, the one job from the third policy is coming in queued state.

MPX setting at the STU end is "7"

The MPX setting at the schedule end for the third policy of whose job is coming in queued state is set to "1" which is no multiplexing.

I have tried cancelling the queued job, changed the MPX schedule setting of that policy to "2" but still its coming in queued state. The job state is "Drives are in use in storage unit".

Kindly let me know how can I correct this. Thanks in advance.

Comments 7 CommentsJump to latest comment

Nicolai's picture

MPX limitation on the schedule level override the storage unit level. MPX setting of one on the schedule level will require at job to have exclusive access to a drive. 

With a MPX setting of two (on the 3rd policy) the job will run when only a single MPX stream is occupied by policy1 or policy two.

Assumption is the mother of all mess ups.

If this post answered your'e qustion -  Please mark as a soloution.

sabby's picture

Thanks for the post Nicolai,

I understood the point that if no multiplexing is set on the schedule then all the jobs of it will demand a separate drive.

But, how is "MPX limitation on the schedule level which is "1"overriding the STU level i.e. 7 "

I am getting confused here, if we set MPX setting to two (on the 3rd policy), that means we have activated MPX for that schedule and the drive should start that job even if 6 other job are active on that drive. Isnt it?

NOTE : Only one drive is present in the TLD.

Please explain.

 

 

 

Regards,

Sahil Bhatia

 

Nicolai's picture

No it does not. It a further limit you put on the STU level. You can't count each MPX setting on the schedule and match again the STU level.

The MPX level on schedule level defines how many stream you will allow from this schedule running on one tape drive. It's quite useful. Normal MPX well be set to 4-6 on the STU level - but if I have a 3 TB database i do not want it to MPX it with 6 other backup. Is this case I will set the MPX level to two on the schedule and the DB backup will only share 1 MPX stream with other backup.

Assumption is the mother of all mess ups.

If this post answered your'e qustion -  Please mark as a soloution.

Marianne's picture

When you make changes to a policy, force nbpem to re-read policy config before you submit the policy/schedule again:

nbpemreq -updatepolicies

Something else to check for queued job:
Retention level - same as rest of jobs?
Volume pool - same as rest of jobs?

Supporting Storage Foundation and VCS on Unix and Windows as well as NetBackup on Unix and Windows
Handy NBU Links

sabby's picture

Marianne,

The jobs running from the three different policies were of weekly backup schedule with same retention (1month) and volume pool.

However I didnt ran the mentioned command after changing the MPX setting of schedule to "2".

The job state I was getting was "Drives are in use in storage unit".

 

 

Regards,

Sahil Bhatia

 

Mark_Solutions's picture

Just to clarify .. changing the MPX level; of the job to 2 will not allow it to run with a tapes drive that is running six jobs even though it feels like it should have one stream free

It will only start to run when only one job is left running on a drive as then it would make a total of 2 streams running on that drive

It is always confusing but if you want everything to run togther set the MPX and STU levels to use the same value and if you need to restrict a policy or a client then set the maximum number of job sper policy or maximum number of streams per client to the desired value.

For example ... STU has MPX of 7; Schedule has MPX of 7; the third policy which you don't wnt to run that many streams you set to have a maximum number of jobs to 2 on the Attributes tab.

Hope this helps

Authorised Symantec Consultant

Don't forget to "Mark as Solution" if someones advice has solved your issue - and please bring back the Thumbs Up!!.

SOLUTION
Nicolai's picture

Sabby - The MPX setting on the schedule level is not a reservation of MPX stream for that particular job. 

Assumption is the mother of all mess ups.

If this post answered your'e qustion -  Please mark as a soloution.