Video Screencast Help

ds 6.9 sp1 and windows 7 - errors

Created: 12 Mar 2010 • Updated: 31 Oct 2010 | 8 comments

first off, does my version support w7?  should i upgrade to sp3?

i'm booting off a usb using redployt (or rdeploy) for a stand-alone pc

upload/download an image is fine

trying to boot the pc after the restore i get a "missing boot manager" screen though

tried playing with bcdedit by booting off usb into winpe, but than i get a "bootmgr is missing" error each time

i'm pretty sure i can put the original w7 dvd in and repair, but i'm trying to find a fix

i'd like to deploy a usb drive w/ the image on it to restore when necessary to a stand-alone pc (won't be connected to the network)

any help would be greatly appreciated...

Comments 8 CommentsJump to latest comment

kade714's picture

just wanted to add that i tried setting the following before shutting down and creating an image:
bcdedit /set {bootmgr} device BOOT
bcdedit /set {default} device BOOT
bcdedit /set {default} osdevice BOOT

also tried setting various bcdedit options after the restore

am i supposed to prep the image more beforehand?

just wondering what the "right" way is to do it with altiris before going the all-microsoft route

thanks

Mr Gadget's picture

Try making a text file and put your 3 lines of bcdedit in it. Point the bcdedit to c:\windows\system32\bcdedit.exe  Save the file as setupcomplete.cmd  Edit you image with imageexplorer in the deployment console.  Open the c:\windows\setup folder add a folder called scripts now select add a file and put this file into the scripts folder.  Deploy your image and see if you still get the can't boot message.

Mr Gadget's picture

Did you get your problem fixed?
I wasn't sure if you were using sysprep or not. I experienced this same problem  when using pxe boot through dos after sending a image to a computer, on reboot it gave the same boot error. You had the right idea with the script:
bcdedit /set {bootmgr} device BOOT
bcdedit /set {default} device BOOT
bcdedit /set {default} osdevice BOOT

The only fix when imaging in Dos is to reboot into a winpe disk or usb drive that goes to a dos prompt and run the 3 commands above.
Note:  The script above had a drive letter in them when I used them but I have to find my notes to remember where.
If you boot to winpe and run sysprep you shouldn't have this problem.

bhawver's picture

From what I understand, 6.9 SP3 is the first version that officially support Windows 7.  That's not to say you wouldn't be able to get it to work under prior releases.

I do believe you will need to sysprep the machine prior to taking an image.

Brian Hawver
Systems Engineer
Yaskawa America, Inc.

Connect Etiquette: "Mark as Solution" those posts which resolve your problem, and give a thumbs up to useful comments, articles and downloads.

Nelo's picture

Yes. It is recommended that you run sysprep before the image. if you have an image that reports a Windows Manager error then executing the following might address the issue:

bcdedit /set {default} device partition=c:
bcdedit /set {default} osdevice partition=c:
bcdedit /set {bootmgr} device partition=c:

Note. These values will need to change becuase Windows 7, Windows Vista SP1 and Windows 2008 R2 might have a hidden partition. So boot into automation and find where the boot files are. So your c: drive might have the boot files and the d: drive have the system files.

Nelo

JessicaD's picture
Kade714,
Microsoft does have an official Windows 7 Support Forum located here http://social.technet.microsoft.com/Forums/en-US/category/w7itpro/ . It is supported by product specialists as well as engineers and support teams. You may want to also check the threads available there for additional assistance and guidance.
Jessica
Microsoft Windows Client Team
Nelo's picture

kade714 It is recommend you sysprep the image before you capture the image, however, you could fix the issue at hand with bcdedit commands. If you installed WIndows 7 from a dvd then it adds a hidden partion (boot files) into  play. So boot to WinPE and do a c: and do a dir see if you have boot files only. then do a d: then a dir see if you have OS files. if that is the case. where c: = boot files and d: = OS then I execute the following command in WINPE same architecture are the OS installed.
bdcdedit /delete {default}  u should get feedback if it worked.
cd to d:\windows\system32\bcdboot.exe  where d: is the drive that has the OS files
finally, execute BCDBOOT d:\windows /s c:

The above command assumes that d:\windows is where the OS files are located and c: has the boot files.

cheers
Nelo

mudcat500's picture

kade714 - 2 thoughts here. I deploy server 2008 R2 which is similiar to Windows 7. My method works for the environment I work in which is DS here at our corporate headquarters for our data center server builds (approx 1500) and our DR site, and NO DS anywhere else (until we go to ns7x). We are a global company and are required to reach out to these locations and build servers as they have no IT folks onsite, so this method has been tried on our Asian, autralian, south american and European server builds.
1st - The hidden partition that is being put into your win7 image can be removed or prevented from happening in the 1st place, during the image creation process. This is causing the issues I saw in R2 with the same sypmtoms you described.  . I'm leaving in a few minutes and wish I had time to find this info but, if your problem still exists - respond to this. I'll look that info up and get it to you.
Also - to boot from USB is as simple as copying 3 folders and 1 boot.wim file created from most usb boot creators (I used WAIK).
First format the usb drive using diskpart commands (I can send you the ones that work for me), and then copying those 3 boot folders and 1 boot.wim file to the formatted usb drive.. This then makes the usb drive bootable.
I then copy over the DS files, OS files, post OS stuff (SAV, dat files, WSUS, WinZip, Dell Open Manage) and other apps that we require on all our servers onto the formatted, bootable USB drive.
First I'll boot to the USB drive (for our remote - global locations). Once WINPE loads and at the prompt, I'll run diskpart to list my disks, locate the USB drive and then assign that drive as another letter (like Z or something). This keeps the USB drive from being C.
Then I type in one command which kicks off a cmd I wrote for our environment. Depending on which command I type, will then install the OS version I want(r032/r064/r2 as well as win2k3 OS), along with all the post OS automation, app installs, SAV, WSUS and updates, before askiing you to logon the first time. The nice thing is its all local from the USB drive so you dont have to be network connected to do a complete secure install. (except a remote console connection - easier to do on servers)
Of course your unattend (old sysprep.inf) needs to be written correctly and image must be a sysprep'ed image.
I used this method around DS  previously but with Win7 /Server2008r2 - it was a big change in how MS does things.
Fortunately my company paid for an MS engineer to live onsite for 3 days and help us with the unattend file and automation thought process around the new OS. 

Email me for particulars if you havent resolved your issue or if you want to try another method. It works like a charm and is a consistent image process everytime. Its as simple as shiping the USB drive to remote sites (or providing them the share with all the instructions and bits), having them connect our Dell remote access port so we have remote connection to the device, they configure the drac IP and then insert the USB drive. From there I type a couple commands and walk away for 30-40 minutes.