Video Screencast Help

DS 6.9 SP6 building Surface Pro

Created: 18 Feb 2014 • Updated: 18 Mar 2014 | 23 comments
This issue has been solved. See solution.

I would like to PXE a sufrace, but I don't have the specific network adapter so I don't think that is possible.  So my other option is to use a USB boot drive, using a iso created boot image from the DS.  I know (pretty sure) that the USB drive has to be FAT32 for the Surface to be able to boot to it, but I am unable to get it to boot to the drive or the USB WinPE pxe thing. 

 

Has anyone else had any luck using the DS to build a Surface?

 

Thanks,

Operating Systems:

Comments 23 CommentsJump to latest comment

spazzzen's picture

note: without using the boot to nic. 

Also I can get it to boot to a usb, but only the windows cd, not the ds created pxe.

frickea86's picture

Spazzzen,

To boot a Surface II or I to PXE I believe you need to use a dock or the MS Surface Dongle which you mentioned.

I do know if you slap WinPE 4.0 on a USB stick formatted with NTFS it works fine.  I actually don't know how to get WinPE to boot properly if you don't use NTFS as you generally have to set the partition to active.  Again, never made a bootable WInPE usb stick without using NTFS, never had a reason not to.

So you can do boot it VIA usb stick but if you don't have a USB ethernet cable attached what good is it?  I guess you can add the wireless card drivers but I have no idea if thats even possible to connect to WiFI.

Just not understanding your direction here, why not pay the 40 bucks for the dongale that lets you do what you need, not sure why you wouldn't.

Also, if you have Secure Boot enabled and your WinPE OS doesn't have the right certificates installed, it will yell at you complaining about some security settings.  So I generally always disable Secure Boot before doing anything with them as its just a pain to get working.  I am betting its SecureBoot keeping you from booting into a WinPE USB stick as it will also keep you from booting into a PXE WinPE session.

I just successfully captured an image from a Surface II I have in my lab yesterday using 6.9 SP6 with secure boot disabled on the Surface without issues, so I know its do-able.

Jrr's picture

Could you tell me how did you PXE boot using DS 6.9 SP6, I am just starting to look into imaging a Surface. We have WinPE 4.0 32bit installed. 

Any help would be greatly appreciated.

Thanks

JR

spazzzen's picture

At this point it looks like I will be getting the offical dongle.  I had planned on getting one anyways, but was hoping to get the device built instead of having to wait for it to be ordered and delivered. 

 

As for the NTFS, for some reason with the surfaces, it will not let me boot to NTFS.  I have had this problem ever since using the Sufraces.  If I could boot to an NTFS usb device, i could at least replace my costum Windows 8 image with the one on the windows cd and use my xml file.  I would do this with FAT32 but the image is 6 gigs, and FAT only supports a max file size of 4 gigs.  I just tried using an NTFS WinPE boot usb, with no luck.  I already formated the Surface HD so now it just boots to the bios.  I already have the bios settings as you suggested, with SecureBoot off. 

 

Any other suggestions to try until i get the official Surface dongle? (also we do have the surface dock and it did do anything with that either.)

 

Thanks for the help though.

joel.iglesias's picture

Hey spazzzen,

I wrote this document a while back that covers imaging a device like the surface using ghost from a single USB drive. Give it a read and let me know if it helps you. Thanks!

https://www-secure.symantec.com/connect/forums/ima...

Fw7's picture

Hi Guys,

I'm looking for the same thing, deploying Surface Pro 2 via DS 6.9 SP6.

Unfortunately, even if having the official dongle, I'm unable to boot up on WinPE.

The surface boots well in PXE, but then shows "Failed to show PXE menu" and then exit the booting phase.

Does anyone have since this already ?

It's very frustrating to get that far and not beeing able to finish the WinPE process.

THanks!

spazzzen's picture

So i have the office MS dongle, but I still can't get it to PXE boot.  It actually does "try" to pxe boot, but it never makes it into PXE.  I saw it get an ip address, for the IP4, but never asks me which option to boot to or even trys to boot to the WinPE. 

 

Any way to get this working?

frickea86's picture

To get WinPE 4.0 to boot, I actually had to make sure Secure boot was off and I had to turn MTFTP off in the PXE manager for multicasting.

MTFTP settings are located: Tools -> PXE Config -> Multicast Tab -> Uncheck Enable MTFTP

I forget how to get into the BIOs on the Surface II, believe you press & hold the Volume UP while turning the tablet on.  Its the second option I believe listed.

Hope that helps....

Fw7's picture

Hi Frickea86,

Thanks for sharing your experience. I've tried your option, without any luck.

Could you describe what kind of DHCP you've set to have the correct bootstrap ?

Thank you !

spazzzen's picture



Secure boot is off, and same with MTFTP. 

 

 Do you have to use a 64 bit WinPE for the surface?  I seam to recall reading that somewhere and we don't have one due to issues we have run into.  Although it doesn't even get to the menu where I can pick which pxe option to boot to. 

I finally was able to get the information/error message using the iphone 5s slow motion camera:

 

nbp filename is bstrap\x64\bstrap.efi

nbp filesize is 0 bytes

pxe-e23: client received tftp error from server.

 

spazzzen's picture

Well... I finally got it to boot to a usb PXE... but still can't get it to image.

So as I said, even with the MS usb to NIC dongle and all the settings correct, I could not get PXE to work.  Also, I couldnt boot to a USB version of PXE or to an NTFS drive.  So here is what I ended up doing that got me to a working stat:
 

  1. Make a FAT bootable usb drive, and copy the contents of the Windows 8 CD. 
  2. Create a x64 PE image.
  3. Open the iso of the PE image and copy \source\boot.wim to the usb drive to \source\boot.wim

You will need to overwrite the existing boot.wim

This at least let me boot to the PXE and even run jobs.  The only problem is I am using a script with imagex to install the image.  The image gets pushed down then errors out here:

bcdboot.exe w:\windows

-I was able to get past this by using a bcdboot from another windows 8 system but then:

bcdedit.exe -set {bootmgr} device partition=w:

-errors out with "The boot configuration data store could not be opened".

So I think I have spent enough time just trying to get this to work, so I am giving up unless someone has another option.  I would like to eventually be able to build these, but I am not having any luck,and spending more time than I need to, to do this.

 

joel.iglesias's picture

Hey spazzzen,

Sorry to hear you are having so much trouble with this.  Can you verify that W: is the valid drive letter assignment for the target partition.  The letter "W" was being used in my write up to avoid drive letter assignment conflicts.  Specifically, if the Surface Pro hard drive is completely empty (not containing any partitions) at the time of booting WinPE, the bootable drive will recieve a drive letter assignment of "C:\" . Instead of going into additional detail about this I included a diskpart script that sets the Operating System partition to "W".  If you skip this critical step the bcdboot command will never work correctly.  Also out of curiosity...why are you using imagex instead of ghost?  Does your imagex image happen to be less than 4GB?

spazzzen's picture

So during the process I use diskpart to clean the drive and assign it to W, then the image is pushed. 

The final imagex after customizations is over 6 gigs, but I know it takes the image as I was able to browse to the drive and see all the files. 

I am using imageX to allow for offline image updates (not that I have any time to do that anymore). 

 

My process works fine for Dells' and I am also using imageX for Windows 7 and that has worked on every make and model we have.  I am only having problems with the MS Surface.

 

Thanks for any help.

Fw7's picture

Hi Spazzeen,

I've finally have been able to go over the PXE boot even if it's ultra slow so far.

As proposed by joel.iglesias, remember you have to create those two partitions:

- EFI around 100Mb
- MSR = 128Mb

In order to make it work, you have to capture the EFI partition from an existing install and deploy it prior the OS partition.

You can prepare all of that via diskpart & imagex. (noticing that GUI deploy image option isn't working anymore for that scenario.

Hope it helps.

Cheers

joel.iglesias's picture

Hey Spazzen,

I could be wrong about this...but I think your issue is with the bcdboot command is the way you are contructing the winpe environment.  You should contstruct your WinPE 4.0 by using the waik kit instead of copying operating system files to the flash drive. We deploy UEFI devices using the method in the article i posted so I know that process works.  Here is what we do from start to finish...

Creation:
------------------------------------------------------------------------------------

Install Windows 8 from scratch.

Create WinPE 4.0 using Waik. (FAT32 set as active)

Capture an Image of the entire drive including all partitions.
 

Deployment:
-------------------------------------------------------------------------------------

Diskpart Creating at minimum 2 partitions (System 100mb) and (NTFS rest of the drive).

Restore Only the NTFS Partition from the Image.

Copy boot files from restored NTFS Partition(W:) to System Partition (S:) using BCDBoot located on (W:)

(W:\Windows\System32\bcdboot W:\Windows /s S:)

Hope this helps you... :)

spazzzen's picture

Out of curiousity, why can't I use the DS created WinPE 4?  Also, script only doesn't work on the microsoft Surface.  I can build Dell PCs without any problems, so I don't think it is a problem with my commands.

 

I do create the 2 partitions with diskpart prior to the imaging.  Again, no problems on non-suface devices. 

 

Also, I think I am a step closer to understanding why the surface will not boot to PXE.  I just got a new Dell E7240 with a touch screen and found that if I try to boot to the UEFI NIC it fails and looks exactly like the surface pxe.  On the other hand, if I boot to legacy nic, it works fine. 

Is there some setting or something I need to change with PXE to get it to work with UEFI nic boot?

 

 

Thomas Baird's picture

This has been a fascinating read!

First, if you're using DHCP settings to point to PXE servers and are attempting to boot an EFI system, you're likely going to have problems.  Use IPHelpers on your routers instead and remove all your DHCP PXE related options.  The PXE server in DS 7.5 at least can handle both EFI and BIOS requests, but MS DHCP can only handle one OR the other type, but not both at the same time, so just quit using it and get IPHelpers in place.  That's the PXE issue.

As for if you can use the built in PE4, you probably can.  However, you'll have to build a USB installer from Boot Disk Creator 'manually' since the console doesn't support building that type of boot device, OR you'll have to get PXE working for EFI systems which the surface obviously is.

Based on everything I've just read, I think your main problem is the UEFI issue.  Make sure you're on the release of DS that actually supports UEFI for booting (it's a different boot file, so it had to be updated) of which DS 7.5 is one, and I think DS 6.9 SP6 is where it was added there, and then try again, but remember to use IPHelpers, not DHCP options!  Fix DHCP for UEFI, and you'll break all your older legacy systems...

Thomas Baird
Looking for opportunities
(translation: unemployed!  LOL)
Yes, able to help people beyond the forum if need be.

 

SOLUTION
spazzzen's picture

So we are using the IPHelpers since our PXE servers are on a different vlan.  I am also on DS 6.9 SP6. 

 

So i guess the question is how do I make a USB boot that supports UEFI, since I will still need to be able to build legacy systems. 

 

Also I think another part of my problem might be the image being UEFI, is there a way to verify this or change it?

 

Thanks,

Thomas Baird's picture

USB booting shouldn't have to specifically support UEFI.  You're booting from a local device, so the UEFI system needs to support USB.  PE4+ is required for full UEFI support per MS (though PE3 had some).  So PE 4 from any source should support that hardward.

We'd probably need to get more info about what you're actually seeing in USB booting.  My guess though is that once you get a bootable PE4 USB, it'll work, or rather, it should IF you modify the BIOS to suppor it which, for the surface, I've no idea how frnakly.

Thomas Baird
Looking for opportunities
(translation: unemployed!  LOL)
Yes, able to help people beyond the forum if need be.

 

spazzzen's picture

If I just make a iso using the boot disk creator, and put it on a USB that is known to boot on a surface, it doesn't appear to even try to boot to it.  My work around is to put it on a windows 8 boot usb but replace the boot.wim with the one created by the boot disk creator. 

I haven't had a chance to try booting to a WinPE 4.0 x32, but I will try that next. 

 

At this point I think I am just going to give up on the surfaces, and hope that no one actually wants to keep them (we are piloting them right now).  The Dell Venue 11's are better and fully support being in a corporate enviornment.  Meaning I already know I can PXE boot those.

Thomas Baird's picture

Boot disk creator should allow you to make an installer for USB drives and I swear I know people doing it, so if it doesn't work, maybe you could tell us what happens when you use it?  Remember, it's an ISO so it can't be copied to the drive, but burned to it sorta...

That said, what you're doing with the Win8Boot USB I've also seen, so not too bad.  :D

 

Oh, and you can feel free to ship me your wasted Surface.  I love them. :P

 

That said, if you like the Venue, why not stick with it, right?

Thomas Baird
Looking for opportunities
(translation: unemployed!  LOL)
Yes, able to help people beyond the forum if need be.

 

spazzzen's picture

Boot disk works fine for everything but the Surface.  I have used the same boot disk to boot every Dell system without any problems, but the Surface just doesn't like it for some reason. 

 

If it was up to me, I would have no problems sending these Shirfaces out.  I don't think I can emphasize just how much I dislike them =P. 

 

As for the Venue, I believe the plan is to stop purchasing the Surfaces and purchase the Venues.  They were not out when we originally started our Windows 8 Pilot and the Latitude 10s (The predecessor to the venue) was a huge pile of crap (mainly because it was only 32 bit with a max of 2 gigs of ram).

Thomas Baird's picture

Well, I'll be anxiously watching to see if others have boot disk and/or PXE issues with Surfaces then!  Thanks for all the feedback!!

Thomas Baird
Looking for opportunities
(translation: unemployed!  LOL)
Yes, able to help people beyond the forum if need be.