Video Screencast Help
Symantec to Separate Into Two Focused, Industry-Leading Technology Companies. Learn more.

DS 6.9 UEFI PXE boot?

Created: 29 Oct 2013 | 8 comments

I have a brand new HP EliteOne 800 G1 machine here, but I'm unable to PXE boot it as it uses the new UEFI network boot, and there's no option in the BIOS to enable Legacy boot for the NIC.  I've read the KB article on adding UEFI support for DS 7.1 (http://www.symantec.com/docs/HOWTO83482), but we're still running DS 6.9 here.  Does 6.9 support UEFI PXE boot?

Operating Systems:

Comments 8 CommentsJump to latest comment

XB's picture

Apparantly UEFI support will be there in DS 6.9 SP6.

If a Connect post helped you out, be sure to click "Mark As Solution" or the "Thumbs Up" button to let other users know about it.

YannickVR's picture

From the HP EliteOne 800 manual:

You can use F5 to disable individual boot items, as well as disable EFI boot and/or legacy boot.

 

For UEFI boot you need WinPE4 and a UEFI bootprogram in your PXE/TFTP environment. I've seen articles about replacing the DS6.9 TFTP with another one, might be the way to go to get UEFI support.

DaveJ's picture

Thanks for the tip.  However, the F5 option only disables boot items, it doesn't enable legacy network boot.

I looked around in the BIOS a bit more and what worked for me was going into the Security, Secure Boot Configuration menu and disabling Secure Boot.  There is an option there to enable Legacy Boot, and with that enabled the NIC can be selected as a legacy boot source and UEFI boot can be disabled entirely.  That will work for me until DS SP6 is out.

cadalpias's picture

OK, 6.9 SP6 is out and I have it installed. I have WinPE 4.0 installed and is working. But to go along with this post, is there any way to have it actually boot from the UEFI PXE and not Legacy Mode PXE? I understand that PE 4.0 will enable UEFI support once you are in PE, but was there any changes to the actual PXE server in order enable UEFI PXE boot?

BBC's picture

If I remember this well, there is an option in the BIOS about secure boot. If this is enabled, you will fail as that is a setting required for UEFI and automatically disables any option for Legacy BIOS.

-BBC

Jamy69's picture

Hello,

On my DELL 5540 that I have a PXE Boot problem, the solution for me was to uncheck the MTFTP option.

Hope this help.

BBC's picture

@cadalpias

Booting WinPE4 via PXE is the process to go. You can configure a WinPE to contain more than one boot loader and the system can pick whichever is required from the client to boot off. I have not yet looked at the DS WinPE, but creating one with the Windows Kit actually allows to have multiple boot loaders and also define the order (means if loader #1 does not match, fall back to #2 and try to use that one).

@Dave

the BIOS config should look like this:

- Disable UEFI Boot Sources

- Move the NIC to position #1 of the Legacy Boot Sources

In case you receive machines delivered with Win 8.x preinstalled, you want to take into consideration the disk has to be wiped first and for us it turned out best to use Diskpart.

-BBC

mcsereed's picture

We have Lenovo's and had same issue with both the old and the new Altiris solutions. We had to disable the security chip in BIOS for the model machine we had and then changed in startup the UEFI/Legacy boot priority to Legacy first. No issues. Not sure if the other models of machine has the same result. Hope this points you into a solution.