Video Screencast Help

DS 7.1 Prep PC for Image Capture not working

Created: 06 Feb 2013 | 5 comments

I have read through the forum but I have not seen a solution that works. Thanks for reading.

 

I am trying to capture from a Dell Desktop PC an image with Windows 7 Enterprise SP1 64-bit.

The agent and all plug-ins are installed including Deployment Sulotion Plug-in V7.1.8400.

I run the job with the correct OS Type (Windows 7 Enterprise Service Pack 1(x64).

I have attempted with both "Current Key" and I have specified a key.

Windows on the image is not activated.

This task will not run in a Job or as a stand-alone task.

Everything reports as running on both the client and the SMP Console.

Eventually the task fails after over an hour with a return code of -1

Sysprep.exe is running on the target PC.

 

Thank you for your help.

 

C

Comments 5 CommentsJump to latest comment

Sally5432's picture

If you watch sysprep.exe run in task mgr, does the client ever attempt to reboot?

In the prepare for image  capture job, it's set to reboot to either automation or PXE.  If you send a job to just reboot to automation or PXE, does that work?

Are you running MP1? I had problems capturing the image too after MP1.  It was due to the reboot to PXE not working correctly which corrected itself once I deleted machine from console and let it re-add itself.

---
Don't forget to mark posts as helpful if they are, and mark answers as solutions.

cameron.ward's picture

As far as I can tell the client never tries to reboot.

 

I have tried both Automation and PXE, neither works.

 

I am running MP1 and have deleted the PC from the solverlight console under "All Computer" and then the Agent reports back and re-adds the PC.

 

No dice.

 

thanks for the reply. other ideas?

Sally5432's picture

Watch task manager and see if sysprep stops working.  If it does and there's no reboot - check windows logs around when sysprep finishes - any errors that give a clue?

 

---
Don't forget to mark posts as helpful if they are, and mark answers as solutions.

cameron.ward's picture

Sysprep doesn't finish. It just sits there for hours.

 

I can run sysprep manually, but I need the task to work properly.

 

There is nothing interesting in EventViewer, no alerts. Except that EV records that the Symantec Mgt Agent service has been disabled when I send the Prep for image capture job.

 

Thanks

C

Thomas Baird's picture

I've not seen Sysprep hang very often.  The error "should" show up either in the agent log (in production) and/or in the Sysprep log, which I THINK is generated in the windows\panther folder, but I'm not sure.  After googling this a bit, it looks like others have had Sysprep fail, and it can fail for a variety of reasons, including failing to read a DLL, or successfully scan a device.

It MIGHT be timing out as well, but that seems unlikely.  1 hour is a long run of sysprep (though I have seen 45 minutes before, so maybe not).  The default timeout for the Prepare for Image Capture task is 960 minutes, which is NOT the same as 60 minutes.  :P

 

Anyway, some thoughts.

Thomas Baird
Looking for opportunities
(translation: unemployed!  LOL)
Yes, able to help people beyond the forum if need be.