Video Screencast Help
Symantec Appoints Michael A. Brown CEO. Learn more.

DS7.1 - Problem capturing an image

Created: 14 Sep 2011 | 12 comments
matte2111's picture

Hello,

I'm trying to capture an image of a laptop with win7 Professional 64bit.

My DS7.1 environment has a configuration with automation folder, deployment solution plugin installed, driver added through Bootwiz, automation folder installed on the client, job created with 3 tasks (Prepare for image..., Create image, Reboot to).

What happens is that after the first task, booting to WinPE the environment seems to be corretly loaded and the WinPE screen appears BUT no image creation starts. Everything hangs. It seems that a black shell (it might be the one of the image creation) appears and immediately disappears but it's too fast to understand what's going on with that shell

The other shell (the X:\ one) is minimized but opening it I've checked that:

- ping to NS server works

- PECT agent is up (seen in taskmgr)

- log files don't show any error message

I don't really have any idea about how to solve this problem!

Anybody can help me?

 

Thank you very much

matteo

Comments 12 CommentsJump to latest comment

Benjamin Fuller's picture

Which log file are you checking? Considering there is no log file - what is the job status hanging at, booting to automation? I have seen this happen but usually there would be a log on the server that would determine whichever problem it was at the time.

 

Solutions to problems similar to what you are describing:

  • Not enough hard disk space on the location specified to create the Image
  • Invalid path to create the Image
  • Do not have permissions to the server share to create the image with the account specified

I would check those and if all of that clears, let me know. I have seen funkier things but won't go into details on every one of them... I could write a book!

You break IT, I fix IT!

matte2111's picture

Hi Benjamin, thank you for your reply.

I'm checking log files on the client side, with a notepad from the shell in the WinPE environment ( log files in C:\Program Files\altiris\altiris agent\logs).

The job status is hanging in "Create image (x64)" after a successfull "Prepare for image capture (x64)...".

On the server side i can't find any log in the Log Viewer (neither as an Error nor as a Warning).

About the proposed solutions:

- There is enough disk space on the location specified

- The path is valid

- Permissions are ok

A directory with a GUID is created in the image path location, but it's always empty.

The same job on another client (always x64) some weeks ago was completed successfully... but now that client is no more available for another test.

 

thanks

matteo

Pankaj Lokhande's picture

Hi,

Can you please attached Server Side and Client Side log files? Which imaging tool are using to create image? Have you tried executing this job on some other client machine?

Thanks

matte2111's picture

Hi,

I have tried with Rapideploy and Ghost for a lot of times: same result.

I had tried to execute the same job a couple of weeks ago on another client (always win7 pro 64bit) and it worked. But right now that client is no more available for another test.

The only thing that is changed is that the NS server and the testing client is on another windows domain (the company is migrating from xxx.it domain to yyy.local domain) BUT the ping from winPE to NS server is ok. And the Capture task creates a directory with a GUID in the image path location on the NS server... directory that keeps on being empty...

NOW, i did a last try with Ghost to take logs to attach to this post and... capture image is working... :-O

Maybe a little change in the atmosferic pressure makes it work... :-)

Anyway, I'd like to understand what was going before and why Rapideploy is still not working.

Server side log (only useful information):

<event date="Sep 15 08:10:22 +00:00" severity="4" hostName="ITL-ALTIRIS71" source="Altiris.TaskManagement.ClientTask.BaseClientTask.CheckIsTaskComplete" module="AtrsHost.exe" process="AtrsHost" pid="1436" thread="104" tickCount="240526375"><![CDATA[BaseClientTask.CheckIsTaskComplete(): Task Create win7-pro-64 image Automation (15/09/2011 10:05:12) - 1 child instances, all complete.]]></event>
<event date="Sep 15 08:10:22 +00:00" severity="4" hostName="ITL-ALTIRIS71" source="Altiris.TaskManagement.ClientTask.BaseClientTask.CheckExecutionStatus" module="AtrsHost.exe" process="AtrsHost" pid="1436" thread="104" tickCount="240526375"><![CDATA[BaseClientTask.CheckExecutionStatus(): Task "Create win7-pro-64 image Automation" (15/09/2011 10:05:12) - has met the minimum number of child instances complete.]]></event>
 

For the client side... I'm having some problem to get them...

 

 

Benjamin Fuller's picture

Ok - since you are using RDeploy, I will need to see your RDeploy log. Considering your are using 7.1 from the log above here is where you will get it from: (On the server of course)

"C:\Program Files\Altiris\Altiris Agent\Agents\Deployment\Task Handler\rdeploy\rdeploy.txt"

 

BE SURE to clear this out, then run the job and let it fail so all we see in the log is going to be the one job failure. This log should tell us all we need to know.

For future reference on logs etc, a good link to bookmark for all of the Altiris Log locations can be found here:

http://www.symantec.com/business/support/index?page=content&id=HOWTO42166

 

Please reply back with the log and we will get you squared away!

 

You break IT, I fix IT!

matte2111's picture

how comes that I can't find any Logs directory in "C:\Program Files\Altiris\Notification Server\" and "C:\Program Files\Altiris\Altiris Agent\"?

where can i find log files on client agent?

looking at options in Log Viewer it seems that Notification Server logs are read from "C:\Program Data\Symantec\SMP\Logs"

Nelo's picture

so if u go to x:\program files\altiris\altiris agent\logs u should have pectagent.log, agent.log and some task log files if the client talked to NS. Post the agent and the task file if possible.

Benjamin Fuller's picture

Make sure your logging is turned on! If you go to the provided hyperlink there is a walkthrough on how to make sure this is turned on:

http://www.symantec.com/business/support/index?page=content&id=HOWTO42166

You break IT, I fix IT!

matte2111's picture

Hi everybody,

here in attachment the log files I've found. Does anybdy see anything useful to understand what's going on?

 

Another question: we have migrated from DITALAV domain to XXX domain, but in the client log file i still read:

[......]

NS Server name in ini file=ITL-ALTIRIS71.ditalav.it

[......]

how can i update the NS name? Is ti resolved form a DNS (that means the problem is in the DNS) or is it configured somewhere on the NS settings?

AttachmentSize
Altiris Agent.rar 31.13 KB
Agent.txt 8.26 KB
AgentInventoryPlugin.txt 19.08 KB
ClientPreImage.txt 16.98 KB
PECTAgent.txt 9.57 KB
Thomas Baird's picture

Let's break this up.

1) we know that Ghost imaging is, or has, worked, correct?

2) we know that RDeploy failed, correct?  If it failed, it may be that the black screen you described in the original post was RDeploy attempting to run and failing.  If it does this, it generates a log on the server as posted by Benjamin.

2a) if Ghost fails, it creates a log on the Client in X, rather than on the server - just a difference in how each works.

3) We create the folder for the image prior to even attempting to capture it.  Creation of the folder is done by the server, NOT by Ghost or RDeploy, so creation of that folder tells us very little.

4) Being able to ping the server is not the same as having rights to the folder on the server for imaging.  For instance, people keep attempting to install Site Services on Domain Controllers, and then the logs show us failing to authenticate to them.  Yes, you can ping.  Yes, you can map a drive, but our processes fail to authenticate.  DC's are not supported, but the same principle holds true for the troubleshooting.  Being able to ping simply means you have network connectivity.  That's all.

5) Judging by two facts (Ghost ran, and RDeploy appears to have tried to run but failed), we are not dealing with authentication, task receipt, or anything else related to the client.  Thus, we can stop looking for plugins, or whatever.  Our focus can be simply on the execution of RDeploy and/or Ghost.  Thus, we need those two logs, for the most part, not much of anything else (though other logs can sometimes sumarize what those two say pretty well).  Make sense?

 

Sooooo, at this point, what exactly do you need, what is NOT working, and what do you want?

Thomas Baird
Private Consultant & open to full-time opportunities.
That means I CAN help beyond the forum (directly).

 

Benjamin Fuller's picture

As far as I am aware, you are only in need of getting RDeploy working still due to Ghost somehow working again. If we get the RDeploy log, that is all we SHOULD need to determine the problem you are having.

 

For DS 7.X it should be located on the server at: 

"C:\Program Files\Altiris\Altiris Agent\Agents\Deployment\Task Handler\rdeploy\rdeploy.txt"

 

For DS 6.X it should be located on the server at:

"c:\Program Files (x86)\Altiris\eXpress\Deployment Server\RDeploy\Windows\rdlog\NEWEST_LOG.TXT"

 

 

You break IT, I fix IT!

matte2111's picture

Ok, I'm gonna try to clear it up. Sorry if I have been a bit confusing.

I'm trying to configure my NS 7.1 to be working with Automation Folder and PXE, both to capture and deploy images.

At the beginning I was trying to make it working with Automation Folder, as explained in this post. After a bunch of tries, my job is working with Ghost but not working with RapiDeploy. Right now I can't replicate my test with RDeploy and when I did log files were disabled, that's why I can't attach any RDeploy log at the moment. But this is a problem I can manage later (at least Ghost is working...), when I will be able to replicate a RapiDeploy test with log activated.

After that I've tried an image capture through PXE (always on the same laptop with win7 Professional 64bit).

For this test my DS7.1 environment has the usual configuration with PXE, driver added through Bootwiz, job created with 3 tasks (Prepare for image..., Create image, Reboot to production) and so on. NS and client are on different VLANs:

1) one with static IP, no DHCP, containing the NS

2) the other one with DHCP, DNS, dinamic IP), with a LOGICAL router between them.

What happens is that the first task, "Prepare for image..." seems to hang waiting for the PXE.

I made another test: forcing a network boot the client hangs for some seconds trying to communicate with a DHCP... then send the error:

 PXE-E53: No boot filename received

PXE-M0F: Exiting PXE ROM 

One more information: we have migrated from XXX windows domain to YYY domain, that means the client might have some trouble getting the right information from the DNS to be able to connect to the NS. What might happen is that after a network boot the client contacts the old DNS server getting the old XXX domain suffix and this involves problem in the communication between client and NS when the agent tries to talk to the PXE server.

In the log files I can't find any useful information about this problem. But in the client log file i still read:

[......]

NS Server name in ini file=ITL-ALTIRIS71.ditalav.it [where "ditalav" is the OLD suffix]

[......]

how can i update the NS name? Is ti resolved form a DNS (that means the problem is in the DNS) or is it configured somewhere on the NS settings?

 

Sorry again if I've not been clear enough in my previous comments.

Thankx