Video Screencast Help
Symantec to Separate Into Two Focused, Industry-Leading Technology Companies. Learn more.

e00002f7

Created: 29 Dec 2013 | 11 comments
All Media Used
HHEO 14
Error category    : Resource Errors
Error             : e00002f7 - Cannot extract mailbox messages from the Exchange backup. Review the job log for more information.

For additional information regarding this error refer to link V-79-57344-759

HI my backup was working fine for more than one year

then suddenly start getting job failed and te above reason, it was recently updates to SP3

and also remote agents were updated ,

but still getting job failed

regards

Operating Systems:

Comments 11 CommentsJump to latest comment

Vishal Shinde's picture

Hello,

Can you let us know the following information:

What is the exchange version?

is it a standalone or clustered?

OS on which the Backup exec is installed?

and the OS on which exchange is installed?

Kind Regards,

Vishal

Vishal Shinde

Sr.Learning Consultant

Symantec Education Services

pkh's picture

If the only thing that has changed is that you updated to SP3, then you should log a support case with Symantec for them to investigate your problem.

Xmanster's picture

HI yes my backup was working for more than one year without issue, then was updated to SP3 and start getting this error.

i notice the backup will finish backing up, then when it verify i get this error

using : windows 2008 R2 sp1

exchange : 2010 , DAG , OS windows 2008 entreprise

backing up on TAPE

Vishal Shinde's picture

Hello,

Were there any updates for Exchange, Windows installed around the same time?

Backup Exec uses EWS (Exchange Web Servives) to build the catalog information; this seems like an issue in connectivity using the EWS profile.

You may check if the mailboxes are accessible with the provided exchange credentials using the EWS editor from the exchange Active node.

Please find the link to download EWS editor

 http://ewseditor.codeplex.com/

and you can follow the instruction to run the test in the following link”

http://www.cisco.com/en/US/products/sw/voicesw/ps2237/products_tech_note09186a0080c132c2.shtml

Do let us know the results of the EWS connectivity test using the Exchange credentials specified in the backup job.

Regards,

Vishal Shinde

Vishal Shinde

Sr.Learning Consultant

Symantec Education Services

pkh's picture

Can you explain what has this got to do with the user's problem and what Exchange credentials are you talking about?  Why does he has to extract the Exchange credentials?  Isn't the BESA used to access the mailboxes?

Can you also provide some Symantec documentation which links the user's problem to what you are asking him to do?

Xmanster's picture

thank you

i checked the document , i dont have the following in my registry

Key : HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\VirtFile
Value: VFF Extended Timeout
Type: DWORD
 
pkh's picture

... then add it in and see whether your job still fails.

Vishal Shinde's picture

Valid questions, will certainly help to provide an insight on “how GRT works for exchange 2010 DAG” for a novice user.

Issue:

GRT Enabled Backup job of Exchange 2010 DAG fails with the following error in the job log:

Error category    : Resource Errors

Error             : e00002f7 - Cannot extract mailbox messages from the Exchange backup. Review the job log for more information.

Analysis:

As evident from the error message, it cannot extract mailbox messages from the Exchange Backup.

Now to get further insight you must understand a little about how Exchange GRT works.

In general when an Exchange server is backed up with GRT enabled to tape, there are two distinct phases of the backup.

1.            Where the data moves from the application server to the media server and then to tape..(This is a Backup of complete Information store using Microsoft API )

2.            Where the data on the Exchange server is analyzed for content and saved in the catalogs.(this is when Exchange web services comes into picture.

The account specified for the Backup job logs on to the database with EWS profile and collects the required information.

This requires your VFF filter driver loaded and additionally Account specified for backup is provided with the necessary privileges as per Admin guide: (this account can be, but not restricted to BESA, it can certainly be a separate account for Exchange Backup purpose.)

About Backup Exec and Microsoft Exchange Web Services

http://www.symantec.com/docs/HOWTO73792

As this can evidently be a point of failure, I had suggested using the EWS Editor to be used and check for the credentials or possible failures in the EWS module connecting to the DAG node.

The steps will NOT have any implications on the exchange environment; it is merely used as step of isolation.

Just to recapitulate and to ensure if the questions are answered:

Can you explain what has this got to do with the user's problem and what Exchange credentials are you talking about?  Why does he has to extract the Exchange credentials?

I think the above content explains it.

Isn't the BESA used to access the mailboxes?

BESA can be used; however it is not mandatory to use BESA.

Can you also provide some Symantec documentation which links the user's problem to what you are asking him to do?

The below mentioned article explains about Backup Exec and Microsoft Exchange Web Services

http://www.symantec.com/docs/HOWTO73792

EWS is a Microsoft proprietary; hence troubleshooting EWS issues may not be documented in Symantec article.

Our goal is to find if EWS profile is created successfully and mailboxes are opened /viewed outside Backup Exec, this is a step for isolating the problem.

Regards,

Vishal Shinde

Vishal Shinde

Sr.Learning Consultant

Symantec Education Services

pkh's picture

1) Shouldn't this trouble-shooting be done by Symantec tech support, rather than the user?  You are recommending a third-party trouble-shooting method.  What if the method causes problems for the user?  Would you or Symantec bear the responsibility?

2) There are quite a few other users in the forum who reported similiary problems.  Are they supposed to trouble-shoot their problems the same way?

Xmanster's picture

good morning

thank you all for your support

sorry for the late replay was in new year leave

will check your suggestions and get back to you