Video Screencast Help
Symantec to Separate Into Two Focused, Industry-Leading Technology Companies. Learn more.

EC 25

Created: 28 Nov 2012 • Updated: 05 Feb 2013 | 12 comments
This issue has been solved. See solution.

Hello All,

I have a client gaalpa1glinkdc1-ebr.aldc.att.com(Win XP) and master asprod11.aldc.att.com(Solaris 10).
Media server is also gaalpa1glinkdc1-ebr.aldc.att.com.Detailed status of job is.
 

Nov 25, 2012 9:30:00 AM - requesting resource gaalpa1glinkdc1_lto
Nov 25, 2012 9:30:00 AM - requesting resource asprod11.aldc.att.com.NBU_CLIENT.MAXJOBS.gaalpa1glinkdc1-ebr.aldc.att.com
Nov 25, 2012 9:30:00 AM - requesting resource asprod11.aldc.att.com.NBU_POLICY.MAXJOBS.gaalpa1glinkdc1
Nov 25, 2012 9:30:13 AM - awaiting resource gaalpa1glinkdc1_lto. Waiting for resources.
          Reason: Drives are in use, Media server: gaalpa1glinkdc1-ebr.aldc.att.com,
          Robot Type(Number): TLD(0), Media ID: N/A, Drive Name: N/A,
          Volume Pool: Production, Storage Unit: gaalpa1glinkdc1_lto, Drive Scan Host: N/A,
          Disk Pool: N/A, Disk Volume: N/A
Nov 25, 2012 10:30:25 AM - granted resource  asprod11.aldc.att.com.NBU_CLIENT.MAXJOBS.gaalpa1glinkdc1-ebr.aldc.att.com
Nov 25, 2012 10:30:25 AM - granted resource  asprod11.aldc.att.com.NBU_POLICY.MAXJOBS.gaalpa1glinkdc1
Nov 25, 2012 10:30:25 AM - granted resource  AL1926
Nov 25, 2012 10:30:25 AM - granted resource  A000_F6_S8_D68
Nov 25, 2012 10:30:25 AM - granted resource  gaalpa1glinkdc1_lto
Nov 25, 2012 10:30:26 AM - started process bpbrm (pid=20544)
Nov 25, 2012 10:30:27 AM - connecting
Nov 25, 2012 10:30:27 AM - connected; connect time: 0:00:00
Nov 25, 2012 10:31:17 AM - mounting AL1926
Nov 25, 2012 10:32:00 AM - mounted AL1926; mount time: 0:00:43
Nov 25, 2012 10:32:52 AM - positioning AL1926 to file 1
Nov 25, 2012 10:32:55 AM - positioned AL1926; position time: 0:00:03
Nov 25, 2012 10:32:55 AM - begin writing
Nov 25, 2012 10:48:01 AM - end writing; write time: 0:15:06
cannot connect on socket  (25)
 

Output of ping,telnet and bptestbpcd is as :ping gaalpa1glinkdc1-ebr.aldc.att.com
gaalpa1glinkdc1-ebr.aldc.att.com is alive...........
 

telnet gaalpa1glinkdc1-ebr.aldc.att.com bpcd
Trying 130.8.58.178...
Connected to gaalpa1glinkdc1-ebr.aldc.att.com.
Escape character is '^]'.

Connection to gaalpa1glinkdc1-ebr.aldc.att.com closed by foreign host.

bptestbpcd -client gaalpa1glinkdc1-ebr.aldc.att.com -verbose
0 0 2
135.53.7.32:746 -> 130.8.58.178:13782
135.53.7.32:597 <- 130.8.58.178:995
PEER_NAME = asprod11.aldc.att.com
HOST_NAME = gaalpa1glinkdc1-ebr.aldc.att.com
CLIENT_NAME = gaalpa1glinkdc1-ebr.aldc.att.com
VERSION = 0x06540000
PLATFORM = win_x64
PATCH_VERSION = 6.5.6.0
SERVER_PATCH_VERSION = 6.5.6.0
MASTER_SERVER = asprod11.aldc.att.com
EMM_SERVER = asprod11.aldc.att.com
135.53.7.32:972 <- 130.8.58.178:935

Please suggest as what can be the reason for this error code.
Thanks

Comments 12 CommentsJump to latest comment

rahul466's picture

Please verify that the bprd and the bpdbm processes are running on Master server
 

Andy Welburn's picture

Have a look through the following guide. It includes some of the checks you have performed already plus one or two other things to check:

http://www.symantec.com/business/support/index?pag...

Marianne's picture

client gaalpa1glinkdc1-ebr.aldc.att.com(Win XP)

Media server is also gaalpa1glinkdc1-ebr.aldc.att.com.

Windows XP is ONLY supported as NBU client. 

Not sure how you managed to configure media server on unsupported OS?

Please also take note that NBU 6.x has reached EOSL on 3 October...

Supporting Storage Foundation and VCS on Unix and Windows as well as NetBackup on Unix and Windows
Handy NBU Links

Andy Welburn's picture

Good spot.

 

(I aren't saying *anything* about running 6.x though!!)

Mark_Solutions's picture

Agree with all of the above - although you issue is actually a 15 minute timeout - the job fails after 15 minutes of writing the last fragment

Increase the client read timeouts on the Media servers to a higher value

Of course you also need to upgrade and get everything supported!

Hope this helps

Authorised Symantec Consultant

Don't forget to "Mark as Solution" if someones advice has solved your issue - and please bring back the Thumbs Up!!.

Shekaib's picture

@Mariaanne-I did give incorrect info :( .OS for media server/client is Windows 2008.

@Mark-I increased  the client connect time out to 30 mins and client read was already 30 mins.

But the job again has failed with ec 25.Please suggest.

Mark_Solutions's picture

Did you increase the client read setting on your media server rather than on the client?

Is the client behind a firewall?

Authorised Symantec Consultant

Don't forget to "Mark as Solution" if someones advice has solved your issue - and please bring back the Thumbs Up!!.

Shekaib's picture

@Mark..I have increased the client read timout on mediaserver/client since they are same.

But the problem still exists.Backup runs for some time and then fails with ec 25.

error messages from detailed status.

 Error bptm (pid=34264) cannot add fragment to image database, error = cannot connect on socket

Error bpbrm (pid=13116) db_FLISTsend failed: cannot connect on socket (25)

Also the backup job for increamental schedule completes successfully but for full backup it fails .

Sorry,this forum was created way back in nov"12..but had some other issues so couldnt fix this.

Please help

Marianne's picture

Back to basics again, please...

Which Windows 2008 version on SAN media server?
If R2 - this is only supported as from NBU 7.0.

Seems this is not initial connect issue or even timeout problem, but a problem with SAN media server not being able to connect to bpdbm on master server to update metadata.

You need all of the following logs for troubleshooting:

On master: bpdbm (restart NBU on master to enable this log)
On San media server: bpbrm and bptm

PLEASE upgrade your environment as a matter of urgency - you find yourself without support on version 6.5.6. 
NBU 7.5.0.4 is the latest version.

Supporting Storage Foundation and VCS on Unix and Windows as well as NetBackup on Unix and Windows
Handy NBU Links

RamNagalla's picture

hi,

what is your backup selection? are you trying to backup the ALL_local Drives?

if yes, please try to backup with Multistream backup, and see if only specific stream if failing or all streams?

try to backup the multistream backup multipul time and make sure if only specific dirve is faiing for every time or its random failures.

and also Make sure you have Proper exclude list in place.

let us know how it is going with Multstreaming backup...

if its specific only for one drive,with this approach , we can drill down in issuse to Drive level, and also atleast few Drives will have good backup.

Shekaib's picture

@Marianne
Verion Media Server-Win 2008 R2

Also,as we have been informewd all servers which are still on 6.5x will be upgraded to newer versions by the end of this month..hopefully..:)

@Nagalla
We were trying to backup ALL_local Drives..
Enabled multistreaming.
 
Waiting for any stream to fail..as of now seems ok.

AttachmentSize
BPBRM.docx 49.25 KB
BPTM.docx 113.71 KB
Marianne's picture

I see different IP addresses being used for Master server.

I above bptestbpcd output we see IP address for Master as 135.53.7.32.
bpbrm log shows connection attempt to bpdbm (on master server) using IP address 135.53.7.33.

Why would that be? 
More than one IP address for Master in /etc/hosts on gaalpa1glinkdc1?

 

Supporting Storage Foundation and VCS on Unix and Windows as well as NetBackup on Unix and Windows
Handy NBU Links

SOLUTION