Video Screencast Help

ED800012 error restoring with SSR2013

Created: 15 Apr 2013 • Updated: 16 Apr 2013 | 5 comments
This issue has been solved. See solution.

As a former Norton Ghost user (many versions over the years), I tried, tested and then purchased the Symantec SSR2013 and have been using it to back Windows 7 32bit (Dell XPS 410) to external USB drive.

A few days ago I got some bad sectors identified on my c: drive, flagged by chkdsk.  A chkdsk c: /r wouldn't repair them.  Subsequently I was of course unable to backup the partition due to SSR2013 identifying the sector errors (even if I checked ignore sector errors).

I have a SSR2013 independent image backup from 5 days ago which completed normally and verified normally (which I alwasy do the verify). So following years of practice, I inserted a blank wiped disk into the pc, and booted from the SSR2013 Symantec Recovery Disk, to restore the 4 partitions (Dell utility, Recovery, C, and D).  I had to follow instructions to select by filename to get the correct partition order (I had run into that problem with Ghost in the past of not restoring partitions in the correct order).

The Del Utility partition and the Recovery partition seemed to restore, but a minute into the C: partition restore I got message ED800012.  "The internal structure of the recovery point file (CRC validation) is invalid, damaged or unsupported."  After reading lots of previous posts in this forum, I decided to copy the recovery points (including a verify) using SSR2013 and changed it to NO compression.  I also put the copied recovery points on a second internal hard drive to eliminate any USB questions/issues.  SSR2013 performed the copy and verification.

However, same ED800012 error.  As a final attempt, I bought a new 1TB Seagate drive and tried again, thinking the previously wiped drive might be an issue (even though I used SSR2013 to delete existing partitions and clear first tracks.)  Same results with new blank retail drive.

Since I was unable to create a backup image of the drive with 4k of sector errors, and I was unable to restore from a 5-day old good (no sector errors), I even went back another week.  Same errors.

Sorry to say but I had to use a competitor's product to copy-hard-drive to the new one.  No problems and no issues.

I've used and recommended Norton Ghost to clients since Norton Ghost 9.  I couldn't wait for a resolution so I had to resort to a backup (pun intended) plan of the backup plan.

I'd like to continue with Symantec and SSR2013 because I am familiar with it, but my confidence is a little shaken.  What did I do wrong?  Can anyone give me some suggestions of diagnosing these problems in the futrure what to do in an emergency when a ED800012 error occurs?  Or is there a SP1 fix available?

I'm confident that the independent recovery points are valid.

Operating Systems:

Comments 5 CommentsJump to latest comment

Chris Riley's picture

Have you tried opening the recovery point of C using the recovery point browser (just double click on v2i file from within windows explorer) and then do a manual verify?

Does this suceed or fail?

JohnTech's picture

Yes, I have manually verified all 4 recovery points (as well as the 4 no-compression ones) using the SSR 2013 browser.  All verified from within Windows 7 without any problems.

Might be an issue with booting from SRD Boot CD within the recovery program (I'm using the 32-bit version)

 "Sym_System_Recovery_2013_11.0.0.46600_English_Recovery_Disk.zip"

I'll test that.

JohnTech's picture

Chris, After booting from the SRD cd, I got the CRC error on the Recovery partition, which under Windows 7 verified perfectly.  I then booted from the 64-bit SRD cd and the Recovery partition verified ok!  It appears that my SRD cd which I was using was bad/corrupted.  

I'm going to remake both the 32 bit and 64 bit SRD iso cd's again, and verify they both verify everything correctly.

John

JohnTech's picture

Chris, I burned a new 32bit SRD cd, and tested with old and new as well as a 64bit SRD.  A lot of variables but

1. Initial tests showed mixed results in verifying from the boot CDs.  The recovery points are on a Seagate external USB2 drive.  First 64bit boot cd showed valid, then rerunning after rebooting showed invalid.

2. The final analysis:  I started doing complete power off / resets of the pc and the USB drive.  Then I moved the USB2 Seagate cable from rear connector of the pc to front panel USB2 connector.

3. As soon as I started doing the power off/resets of both pc and external usb, as well as moving the cable, the original Recovery Point of the Recovery-partition was VALID!

Conclusion:  Some type of buffering problem when booting from CD and using external USB hard drive, but power off of USB cleared the buffers.

My confidence has been restored.  Thanks for the help and suggestion.

John

SOLUTION
Chris Riley's picture

Thanks for the update.

Not heard/seen this before..