Video Screencast Help

ED800012 System Recovery 2011

Created: 18 Nov 2012 | 14 comments
BodieUK's picture

Hello All

New to this forum so please be gentle with me.
OK I have had a situation over the weekend where I did a disaster recovery test.
During the recovery I had an ED800012 error, which says internal structure blah blah crc Validation is invalid.

I then restore from the beginning of the month (the base point, starts a new of every month) and that restores.
So it must be an incremental that is at fault but how do I find out which one and how do I stop this from happening! I use BESR on every single server I sell and this had made me think abit....

Please help....

Comments 14 CommentsJump to latest comment

Markus Koestler's picture

Normally the incremental that was done last before the error occured.

*** Please mark thread as solved if you consider this to have answered your question(s) ***

BodieUK's picture

So far from the beginning of this month so i am going back bit by bit to see which one it was.
I did the recovery on the 17th. So the 16th failed, 15 failed. I then have skipped to the 9th of the month which worked so its somewhere in between.
But i still need a way of verifying points... I cant get to a point where i have a server down and i have to tell them i can only restore to xx day as there is a corruption that was not know in the backup.

Chris Riley's picture

But i still need a way of verifying points... I cant get to a point where i have a server down and i have to tell them i can only restore to xx day as there is a corruption that was not know in the backup.

You need to enable verify in the backup job (it's not enabled by default). If this is enabled, the job should fail where there is a problem that leads to corruption. You can then do something about it before it's too late..

BodieUK's picture

Ok so i have enabled this now on the new points that are being created. Is there a way of verifying the exsisting points?

Chris Riley's picture

Just be aware that enabling verify will add significant overhead to the performance of a backup. I would suggest you test this to see how long a backup takes with verify enabled/disabled.

You can use the recovery point browser to manually verify existing recovery points.

BodieUK's picture

ok  I have narrowed down the point to a point on friday the 13th......
now thats spooky...
however i can restore that date or newer. So i have restore to one older and opened the point via the browser. Now if i verify the point it passes!
so not sure where to go now. The only thing i can think of is to create a virtual machine.....

Chris Riley's picture

I'm a bit confused by your latest comments.

You say you have narrowed it down to the 13th but you are able to restore from that recovery point. How have you narrowed it down exactly? Is there a failure in the logs or something?

BodieUK's picture

I have basically been restore millions of times.. i have narrowed it down by going from the base point and restoring back day at a time.... and it fails at day 13th....

Chris Riley's picture

What error do you see when attempting to restore from this date? Can you post a screenshot of the error?

BodieUK's picture

Error ED800012 

internal structure of the recovery point file (CRC Validation) is invalid, damaged or unsupported

I can run the recovery again but there no other info.

Chris Riley's picture

OK, so that is a corrupt recovery point. And you say this passes when you do a manual verify using the recovery point browser?

Can you confirm the service pack level of SSR being used here (check in Help/About).

Chris Riley's picture

Can you please open a support case for this issue? We cannot do much about the recovery point being corrupt but the success when running a manual verify is a concern - this needs addressing.

Please let me know what the support case # is when you have it.

BodieUK's picture

Ok will do. I am busy for the next two days i will open it then and let you know.