Video Screencast Help

Eject tapes to mailslot

Created: 10 Sep 2013 • Updated: 13 Sep 2013 | 9 comments
iaw's picture
This issue has been solved. See solution.

Hi,

I have library with 24 mailslot.
How to see/install mailslot drives in netbackup?
How to manual export 100 tapes to mailslot in netbackup console gui?

Thanks

Operating Systems:

Comments 9 CommentsJump to latest comment

L. Voller's picture

Mailslots are something the library keeps track of rather than Netbackup, as they are not fully 'inisde' the robot and writeable.  Likewise, when Netbackup sends the eject command to the library, it only cares that the tapes are no longer in the slots inside the robot, and so marks the tape as 'standalone'

The closest we get to working with mailslots is selecting  "Empty media access port prior to update"  when "Update volume configuration" is selected, so that we tell the library to ingest the contents of the mailslots before the inventory is run; or adding AUTO_UPDATE_ROBOT to the vm.conf file, which (if you have a compatible library) will automatically run a robot inventory when a tape is inserted in the MAP.

To export tapes you could select the 100 in the GUI, and right click for eject.  It will fill up the mailslot, and pop up a dialouge asking if you want to continue.  Before you click 'yes' go and empty the MAP.  Once the MAP is empty you can select yes and the eject will continue.

 

I hope that helps! :)

 

 

SOLUTION
Marianne's picture

How to see/install mailslot drives in netbackup?

I think you mean slots?

The robot does not make these slots visible to backup application.

You can view contents of slots with robtest:

s p 

For robtest usage, see http://www.symantec.com/docs/TECH83129

  • To eject, select 24 tapes.
     
  • Right click, In the popup menu, select “Eject Volume From Robot” 
  • After a short while NetBackup will complete the eject pre-checks.
  • Click “Eject”.
  • Wait for the next pop up.
  • Click “Yes” to continue.
  • You can now go to the Library and remove the tapes from the mailslot/ cap.
  • NB: Only reply “Yes” once you have removed the tapes from the cap.
    If you click "Yes" before removing tapes, NBU will return the tapes back to their original slots.
     
  • Select next 24 tapes...

Supporting Storage Foundation and VCS on Unix and Windows as well as NetBackup on Unix and Windows
Handy NBU Links

SOLUTION
iaw's picture

Hi,

My mailslot is empty, but when I try to export 1 tape it says error MAP already contains media.

TLD Robotic library may bot have a MAP large enough to eject all the tapes at once. (But I just select 1 tape and eject volume from robotic)

Does MAP means mailslot?
How to make netbackup recognize that my mailslot is empty?

Thanks
 

Marianne's picture

Does MAP means mailslot?
Yes

How to make netbackup recognize that my mailslot is empty?
Get the robot to recognize that mailslot is empty. 
The message is coming from the robot. NBU is merely reporting the message.

Use robtest as per my previous post to check contents of mailslots.

 

Supporting Storage Foundation and VCS on Unix and Windows as well as NetBackup on Unix and Windows
Handy NBU Links

Mark_Solutions's picture

Are you sure your library is configured to have a MAP (or mail slot or I/O port)?

Take a look on its web gui or front panel to see if it has actually been configured to have one

What type of library is it?

Authorised Symantec Consultant

Don't forget to "Mark as Solution" if someones advice has solved your issue - and please bring back the Thumbs Up!!.

Marianne's picture

Seems you have marked more than one post - shows as 'Split Solution Pending'.

What has been the solution?

What have you been able to determine regarding your robot's mailslot?

Supporting Storage Foundation and VCS on Unix and Windows as well as NetBackup on Unix and Windows
Handy NBU Links

iaw's picture

Yes, My robotic issue is fixed.
I want to mark the first reply from L. Voller and Marianne as split solution.
What to do?

Marianne's picture

Please tell us how it was fixed?

The Community Admin will see your request for split solution and award it as per your request.

Supporting Storage Foundation and VCS on Unix and Windows as well as NetBackup on Unix and Windows
Handy NBU Links

iaw's picture

There was no problem with my robotic.
It was just a notification that there is 1 tape inside malslot.
I thought it was an error, but its a notification only.

Steps to export the tape, exactly as your both reply.

Thanks