Video Screencast Help

Email notification for failed backups are stopped

Created: 20 May 2013 • Updated: 23 May 2013 | 9 comments
This issue has been solved. See solution.

Hi All,

Please help me to configure email notification for failure backups...

i was getting before now the reports are stopped.

Please help me to identify the issue.. and let me know how to configure the email alerts for failure backups in linux master server.

 

Netbackup: 6.5.5

Master/Media server installed in Red Hat Linux

 

Operating Systems:

Comments 9 CommentsJump to latest comment

shinnet's picture

Send mail was already in place i was receiving the emails before. after changing the smtp server these emails stopped. I need to know if i have to do some changes... i mean new smtp server name have to update some where?

CRZ's picture

Those Windows TechNotes probably won't help the OP who said it's a Linux master server.

Try some test messages from your master.  Does non-NetBackup email from that server to your recipients go through and get received?

Do you see any sendmail logs in /var/log/syslog?  Or perhaps you a separate /var/log/mail.log set up?  (You'd have to check syslog.conf to be sure what's logged and where.)

Are you sure sendmail is running?  If you try to telnet on the SMTP port, do you get a response or a connection refused?

ps -ef | grep sendmail
telnet localhost 25

Or are you using a different server?  (What does "changing the smtp server" mean?)  From the master, can you try a telnet to port 25 of what you expect your SMTP server to be and see if THAT works?  (If you connect, you can type "QUIT" to drop the connection.)

Unfortunately, these problems are not usually "NetBackup" problems.  You will have to figure out what's different - what's changed between the time you were getting the emails and now.
 


bit.ly/76LBN | APPLBN | 75LBN

shinnet's picture

Changing the SMTP server in the sense, old SMTP server XXX has been changed to new SMTP server YYY now. SErver names are different not sure the ip has been changed or not.

TELNET is successfully to the new SMTP server YYY, it is getting connected.

 

 ps -ef | grep sendmail
root      4726     1  0  2010 ?        00:00:04 sendmail: accepting connections
smmsp     4736     1  0  2010 ?        00:00:00 sendmail: Queue runner@01:00:00 for /var/spool/clientmqueue
root     26897 26132  0 17:33 pts/2    00:00:00 grep sendmail
 

 

 

 

Dyneshia's picture

My apologies, missed the Master server Lunix.  Here is a tech note  specific to Unix and list the different methods .  Depending on which one you are using will determine which direction to go to troubleshoot. http://www.symantec.com/docs/TECH32539

http://www.symantec.com/docs/TECH64984  has helpful chart at the bottom which lists the results of where the email is set up .

Could you elaborate which method you are using and where email is set ?

 

 

LucSkywalker1957's picture

Try checking your /etc/aliases file:
aliases:MAILER-DAEMON: postmaster

and your /etc/mail/sendmail.cf file

DSpostmaster..com

SOLUTION
CRZ's picture

You didn't tell us whether non-NetBackup mail originating from your master was getting delivered.  Try sending a test email from your master - if you can use sendmail, you can try debug mode with the -v command line switch and your intended recipient in place of my bogus address:

master.com # sendmail -v -t CRZ@notmyrealdomain.com
Subject: Tets

test
.
CRZ@notmyrealdomain.com... Connecting to [127.0.0.1] port 587 via relay...
220 master.com ESMTP Sendmail 8.14.5/8.14.5 Tue, 21 May 2013 15:36:37 -0500
>>> EHLO master.com
250-master.com Hello localhost [127.0.0.1], pleased to meet you
250-ENHANCEDSTATUSCODES
250-PIPELINING
250-EXPN
250-VERB
250-8BITMIME
250-SIZE
250-DSN
250-DELIVERBY
250 HELP
>>> VERB
250 2.0.0 Verbose mode
>>> MAIL From:<root@master.com> SIZE=20
250 2.1.0 <root@master.com>... Sender ok
>>> RCPT To:<CRZ@notmyrealdomain.com>
>>> DATA
250 2.1.5 <CRZ@notmyrealdomain.com>... Recipient ok
354 Enter mail, end with "." on a line by itself
>>> .
050 <CRZ@notmyrealdomain.com>... Connecting to mx.superduper.com. via esmtp...
050 220 mx.superduper.com ESMTP
050 >>> EHLO master.com
050 250-mx.superduper.com
050 250-STARTTLS
050 250-PIPELINING
050 250 8BITMIME
050 >>> MAIL From:<root@master.com>
050 250 OK
050 >>> RCPT To:<CRZ@notmyrealdomain.com>
050 >>> DATA
050 250 OK
050 354 go ahead
050 >>> .
050 250 ok 1369168601 qp 20282 mx.superduper.com!1369168598!18481696!1
050 <CRZ@notmyrealdomain.com>... Sent (ok 1369168601 qp 20282 mx.superduper.com!1369168598!18481696!1)
250 2.0.0 r4LKab4l026942 Message accepted for delivery
CRZ@notmyrealdomain.com... Sent (r4LKab4l026942 Message accepted for delivery)
Closing connection to [127.0.0.1]
>>> QUIT
221 2.0.0 master.com closing connection

(Looks like I can't spell :) )

This one worked, but hopefully, yours will fail, providing some interesting clues you can share with us to assist with troubleshooting.


bit.ly/76LBN | APPLBN | 75LBN

shinnet's picture

Thanks Luc

I have changed the SMTP server name in the sendmail.cf and it started working