Video Screencast Help

Enable the history for AeX OS Add Remove Programs in 7.1 SP2

Created: 16 Nov 2012 • Updated: 07 Dec 2012 | 6 comments
This issue has been solved. See solution.

I have tried to enable the history for AeX OS Add Remove Programs in Altiris 7.1 SP2 by following the settings in Altiris 6, the same as in the following link.

Enabled "Configuration -> Server Settings -> Notification Server Settings -> Resource History -> Operating System -> AeX OS Add Remove Program"

I found that the "Inv_AddRemoveProgram" table is now for storing "add/remove program". But, not "Inv_AeX_OS_Add_Remove_Programs_spt".

There is no history table - ""InvHist_AddRemoveProgram" for "Inv_AddRemoveProgram".

For the tables:



They have no record inside.

I have successfully collected the hardware and software inventory for computers, I can see their Add/remove programs in the Resource Manager of the computer.

I have tried install and remove software from the computer. However, nothing can be captured and stored to the InvHist_AeX_OS_Add_Remove_Programs or InvHist_AeX_OS_Add_Remove_Programs_Delta.

Could you share any idea on enabling the Resource History? Thank you!

Comments 6 CommentsJump to latest comment

EathenR's picture

I think Add/Remove Programs is under Software management.

The OS should be available in AEX AC Identification.  If not, there are two Operating System table (Operating System, Operating System Windows) found under the Operating system header.

kevinlai's picture

Thanks your reply, EathenR!

Yes, I also found that Add/Remove Programs is under Software Management.
However, it cannot be enabled under

All Settings -> Notification Server -> Resource and Data Class Settings -> Resource History -> Resource Data History -> Software Management

Checked the "Add/Remove Program" and click "Save Changes" button to save.

However, it cannot save the changes. System keep prompting the following message when I leave this page.

"Are you sure you want to navigate away from this page? You will lose the unsaved changes you have made. Press OK to continue, or Cancel to stay on the current page."

Did you have such problem?

kevinlai's picture

I can save the changes finally, but I have to change to the "Resource Association History" tab and click the "Save Changes" button. I don't know why.

Thanks for the feedback!

Falquian's picture

Hi, kevinlai:

Have a look at:

Menu Settings > All settings

Select the folders: Settings > Notification Server > Resource and Data Class Settings > Resource History

There, you can enable the history for all the data classes.

Hope this helps you.

Kind regards:


If this post is useful to you, remember to mark it as a solution ;)

EathenR's picture

Just curious, are you accessing the page using IE9 or IE8? When I swicthed to IE9 I noticed it presented that dialog when saving pages. I was trying to save change in various places (contracts, software licenses, connector rules). I noticed when clicking the apply it worked as expected; however, clicking the save (save and close) button did not work because it kept presenting the dialog box to which you referred. I think this is a compatiblity problem with IE9.