Video Screencast Help

Encrypted external HD wont accept passphrase

Created: 09 Aug 2012 • Updated: 10 Aug 2012 | 6 comments
This issue has been solved. See solution.

I asked this in another post, and got ZERO replies.  Any insight would be greatly appreciated.

I have a 1TB external HD that is used as my Mac Backup and extra storage (2 partitions)

I have always been able to successfully access the drive using the passphraise.

I updated to OS X v10.7.4 and PGP WDE 10.2.1 Build 4461 PGP SDK 4.2.1.

Everything on the Mac works A-OK.

I tried to access my external HD and put in the password, the same way I have hundreds of times before the updates.  It now will not access, telling me the passphrase is incorrect.

I am 1000% sure the passphrase is correct.

It is not secured with a key pair.

The only difference between last successful access is the updating of the OS and WDE.

My other encrypted thumbdrives are not accessible either.


Comments 6 CommentsJump to latest comment

Alex_CST's picture

Have you tried installing the same PGP version when you encrypted it?  Then try and decrypt?

Please mark posts as solutions if they solve your problem!

chanlsrfer's picture

I will attempt that today and re-post.  Decrypting computer first.

chanlsrfer's picture

Decrypting of computer was completed.  I completely removed the WDE program, and reinstalled the previous version 10.2.1.  

I attempted to re-access the external HD.  Same error.  Again, I know for absolute certainty that this is the passphrase.

I saved my keypair as a pdf and attempted to delete the keys from the program itself.  I was going to re-import the keypair fresh (somehow after re-instalation the original keypair was still in the prior version instal).

I attempted to delete the keypair manually.  I was asked to confirm the deletion. I confirmed and received a new error code:

An error occurred while performing the operation: Simultaneous writes to a shared key DB detected.

I have no idea what this means or how to remedy it. Deleted program again, rebooted, reinstalled, rebooted.  Still having these same errors.

Not able to import any of my other keys to the program either.  Acts like it is going to accept them, then they do not show up in the list.

chanlsrfer's picture

Here is your solution.  You're welcome.  I'm welcome.

1. Decrypt your OS hard drive completely.

2. Re-boot your Mac and during the re-boot process hold down <cmd> R.  This will bring you to the Recovery menu for Mac.  Select the option to reinstall the OS.
The Mac will connect and ensure that you are licensed to have the OS you are asking to re-install.  It will prompt you to enter your iTunes information to access your purchase history.
The next hour or so is spent with your computer keeping it awake as it downloads the 4+GB of new OS.

3. In your new OS open PGP WDE.


3.2 Back up your public/private keypairs.  If you skip this step, proceed to throw out your HD.

4. Select "About" and then select "Uninstall" (make sure your encrypted non accessable hard drive is not attached.  PGP will not let you uninstall while it recognises the encrypted HD attached.  "But it doesnt show up in my PGP control panel" you say? Yeah, I know.  Somehow, in the back of PGP's mind, it still kinda knows there is something there)


6. There is a tech document on Symantec site somewhere that gives the scripts to run in Terminal to manually remove the PGP files (there are a bunch of stragglers that can jack up your clean re-intall)

You now have a clean install of the lowest version of your OS.
PGP is nowhere to be found on your system.

7. Download the earliest version of PGP from Symantec portal that is compatable with the OS you are now running.

8. Install PGP.  If you did this correctly it will prompt you to create a new folder for your keypairs. 

The formerly not-recognized hard drive should now be happily displayed in your PGP control panel.  You can not decrypt it yet though.  You need to have the secret key to unlock the encryption.

9. Import the keypair you saved by going to PGP>Preferences>MasterKeys.
use the + icon to add a keyset.  Drag and drop the saved key into the proper side of the menu.  Add the key.

10.  Decrypt your drive using the passphrase you KNEW you did not forget.

11. (optional) After updating your computer back to the state you had it in before the chaos ensued, it is entirely up to you to re-encrypt with software that is clearly not backwards compatible or scenario tested before updates are released.

12. (manditory) Decrypt every goddamn drive you have prior to changing anything.  Do not trust that any software is compatible or has been thuroughly tested for compatibility.

13. (optional) Write to Symantec and recommend that their project manager for new releases be executed seeing as every OS update takes months to patch, and then months more to debug.

***please ignore any spelling errors above, this took me 6 hours of troubleshooting and a 6 pack***

PGP_Ben's picture

Hi, this sounds as though you might have had a corrupted installation. Given that you had to reinstall Mac OSX and then uninstall PGP  again.  Did you try doing a fresh installation for Mac OSx 10.7.4 and installing PGP Desktop 10.2.1 to see if you have the same problem?

Anyway, i'm glad to hear that it's working for you know. This is first time that I have seen such an issue reported.

Out of curiosity: How are you deploying your OS on the Mac's? Do you have an system image with PGP installed? Or are you doing all your OS installations from scratch?

Added comments: What OS version were you on prior to the update to 10.7.4?

If/when you consider your issue resolved, please click Mark As Solution on the most helpful response.

chanlsrfer's picture

Hello Ben,
In summary:
The OSX and PGP updates were both done as updates, not clean install.  The resolution only came after a complete (manual) removal of PGP, then a clean install (being sure to eliminate PGP folder in 'documents')
I was on the most up to date version of Lion OSX 10.7.x prior to current 10.7.4. (not sure of the exact version).


I was working on OS X 10.7.x (3 maybe?) prior to the 10.7.4 release.  At that time I had the PGP WDE 10.2.1 installed and everything was working fine.  I did not access the HD regularly, as this was my CarbonCopy Cleaner backup drive, with two partitions to allow extra storage for large movie/music storage. This disk was keypair encrypted to the same keypair (no expiration date) I have always used successfully.

I did the install as advised by the forums (just looked, can't find the link that advised the proper update sequence).  I believe it was to update the PGP to 10.2.1MP1 first, then update OS X to 10.7.4.  This seemed to work like a charm, my computer rebooted and the encryption worked like it always had.
**Note: I did not do a clean install of either program.  This may have been my downfall.  Both were updated from Symantec site and Apple's Updater, respectively.**
No other changes had taken place in the time before the external failure.
My next attempt (several weeks later) to access my encrypted HD did not go well.  As usual the passphrase question popped up, but this time there was the constant error of 'incorrect passphrase'.  After clicking "cancel" the HD would not show up in the PGP desktop GUI.  It did however show up in the Apple "Disk Utility"
The recovery only took place after a complete uninstall of PGP.  First I had to decrypt my entire boot disk, then manually uninstall the PGP using the Technotes supplied on Symantec site.  This had to be done manually because PGP detected the encrypted disk (my external, even after detaching) and would not allow the removal.  My PGP folder with keypairs had to be copied, then deleted from their default spot to prevent PGP from detecting them upon reinstallation.
Now a clean install of 10.2.1MP1 was performed.  I created a new Keypair folder.  I then went to Preferences and added a "new" master key using my copied/pasted folder with my "old" keys in it.  
This allowed PGP to see my drive in the 'drives' portion of the desktop GUI, and it now would recognize the keypair and passphrase as correct.
After seeing all of this I believe the problem originated somewhere in the update package.  The keypair was not being read correctly, or the passphrase was not being accepted.