Video Screencast Help
Symantec to Separate Into Two Focused, Industry-Leading Technology Companies. Learn more.

encryption desktop 10.3.0MP3 does not mount pgp disks on OS X 10.10

Created: 24 Jul 2014 | 26 comments

this is the same issue as happened on 10.7.4 of mac os.

we need a fix right away to fix compatibility with yosemite (os x 10.10).

any information from engineering on when we can expect a fix?

PLEASE.

THANK YOU.

Operating Systems:

Comments 26 CommentsJump to latest comment

dtich's picture

this is also the case on 10.3.2MP2 btw.

need a fix asap please.

dtich's picture

also throwing this error, see attach... (this is after a fresh install of latest vers. of pgp)

Screen Shot 2014-07-24 at 5.46.46 PM.png
PGP_Ben's picture

Hi Dtitch,

In regards to the pgpwde.kext error. It appears that the driver doesn't like something about OSX 10.10 being installed. It could have to do with the fact that we use two drivers now in the current version, one which is signed (which OSX 10.9 requires) and one that is not signed. It could be getting confused which one to use on this OSX 10.10 system. This could also be related to the problem with the virtual disk not mounting also.

We have been in discussion over forum messages. I will continue to work with you there.  If anyone else is encountering this problem, it might be helpful to get more information though as well.

If/when you consider your issue resolved, please click Mark As Solution on the most helpful response.

Mike Ankeny's picture

Just to confirm, after the error, did you attempt to reinstall again over-the-top of the existing installation?  I have been seeing issues in OSX 10.9.3 and 10.9.4 where the pgpwde.kext for some reason fails to install the first time through, but on a second attempt it does work.

Let me know what the results of an over-the-top reinstall are, and we can go from there.

As far as the original post, 10.3.0 mp3 was not verified against OS X 10.9 or any of the point fixes for 10.9.  SED 10.3.1 was the first build verified for OS X 10.9, and now that you are moving to 10.10, it would be vital that you are trying the latest version of SED (10.3.2 mp2).  Even then, there is not yet any official support for OS X 10.10.  See the following for more details:

http://www.symantec.com/docs/TECH174563

dtich's picture

yes, i uninstalled and installed the latest, 10.3.2mp2, with the same results, noted in the 2nd post.  

are you suggesting i uninstall and reinstall again to try to force the kext to reinstall fully?

if yes, i will try later today.

thx

dtich's picture

just did another install of 10.3.2MP2, same result, same error -- pic attached.  is there a way i can manually install/copy this kext in? might that be some workaround? is this a cert signing issue?

thx

Screen Shot 2014-08-04 at 2.58.56 PM.png
Mike Ankeny's picture

Update: a colleague of mine was able to get the kext installed.  If he attempts to encrypt the drive, it yields an unbootable system.  While he was on, before the reboot, he attempted to create and access PGP Virtual Disks. He was not able to access hem after creation.  Though it is not good news, I just wanted to let you know.

It's not entirely unexpected since it is a pretty major release, but Yosemite may not work at all with the current version of SED.  We will continue testing, and I will try to post any relevant results.

dtich's picture

thanks for the update mike.  looking forward to whatever you figure out.

thx

lgp559's picture

Perhaps I gave up too soon but it has been my experience that it has been months after an OS X release before a working PGP version was available. The last time I checked by calling support a couple of months ago 10.9.4 was still not supported. Yosemite will be out in a couple of months and I always install Apple upgrades within a few days of release. Is it expected that Symantec will ever have a version of PGP supporting a current Apple release? I keep getting emails asking if I am going to renew my maintenance contract, but since it appears to be worthless I can't think of any reason to do it. I haven't even been able to have PGP installed on my Mac since 10.9.0 was released.

dtich's picture

hello guys. any movement on this ticket? 

when can we expect an update that runs on 10.10?

thank you very much.

Mike Ankeny's picture

Sorry for not getting back to this thread in a timely manner.  Thanks dtitch for the bump/reminder.  Current builds of SED only support up to OS X 10.9.4.  Our latest release (10.3.2 mp3) came out in late August, the next release should be sometime around the end of November or early December, and it is still not clear if Yosemite support will be included.

All I can really tell you is that it is actively being worked on by our development team (it's not just in consideration), which is better than nothing.

dtich's picture

bummer. ok. standing by...... really need.  

i'm actually surprised there aren't more yosemite users clamoring....

luckypierre's picture

I guess most people are just sighing and waiting for Symantec to catch up. Again. It's not like I should really expect £250 of software to work, or be actively supported.

I'm getting at least two of these errors - the kext error and the pgp disk error.

I take it from some of these replies that Sym are at least working on Yosemite compatibility i.e. someone has raised a ticket?

olddave48's picture

Same problem here when I installed OSX Yosemite Beta.  I had  to reformat and do a clean  reinstall of OSX maverick, it took days to get it right.  I had a good backup thank goodness. Hope to hear  that WDE has a solution soonest.

themacdoc's picture

Yesterday's release of Yosemite still breaks PGP Disks, but now it's permanent. The volumes are not seen by Finder, yet SED reports them as mounted. Desktop Encryption is version 10.3.2.15413. It also can't 'unmount' the unseen volumes.

This issue of PGP Disks apparently being mounted but not showing up on the Desktop has been going on for years, but only very sporadically, and it could always be cured by a hardware restart. Now with 10.10, it's completely broken. All PGP DIsks are useless.

I'd consider this a catastrophic failure, and one which should have been addressed long before this release went public.

Mike Ankeny's picture

Symantec Encryption Desktop version 10.3.2 mp4 is the latest release, but it still does not support Yosemite. Our support for OS X can be found here:
http://www.symantec.com/docs/TECH174563

I would advise anyone interested in Yosemite support to open a ticket with technical support, and request Yosemite support.

lgp559's picture

Perhaps there should just be a permanent ticket with technical support requesting support for the current MacOS X version. Think that would help?

dtich's picture

holy sh--t. when is symantec going to support mac os?????? i mean really???  this is so laughable. losers.

even this 'support portal' is crap. i'd open a 'support ticket' but this site is a numbered circle of hell to navigate and i simply haven't the time in life......... always so disappointed here.

Mike Ankeny's picture

As stated previously, the fastest way to get any traction would be to have tickets opened with technical support, so they could be advanced as a request for Yosemite support.  If you are having difficulty navigating the site, contacting support can be done here:
http://www.symantec.com/support/contact_techsupp_static.jsp

dtich's picture

yes. i've done mike, twice. 

i spend 15 mins trying to get around the page's insane interface and dialog behavior, finally get it in, then hours later get this in email:

In order to open a support case we need to verify that you have a current Support Agreement for your Symantec product. We show no record of current support contracts for your company.

If your company purchased a Symantec product with a Support Agreement, please provide as much of the following information as possible so we may locate the support record:

i've purchased this product semi-annually (bi-?, whatever is every other year) from symantec since it started. and pgp before that. the catch-22 is i have to renew a product that doesn't work (hasn't for months...) in order to tell the company that makes it that it doesn't work.... it's like i'm in terry gilliam's brazil.  yes, i've opened cases. more than once.

thx

olddave48's picture

I jsut opened a case in my name using all the comments above including the one from Mike at Tech to tell us to open a case

Opening a case is not  seemingly working  it is  saying

 The page at https://symantec1.secure.force.com says:

  Your request  is being worked on please  wait

The page at https://symantec1.secure.force.com says:

  Your request  is being worked on please  wait

The page at https://symantec1.secure.force.com says:  Your request  is being worked on please  wait

olddave48's picture

I jsus tried to open a case, the symantec system for new cases is broken. Goes into a LONG Wait and you never get it logged.  Need the fix so we can move to Yosemite.

olddave48's picture

I have a perpetual Maintence contract so can  our case be actioned?

 
Order Details
Customer Name:   COLEMAN DAVID
Customer Number:   59604259
Order Number:   20059305
Quantity Purchased :   1
License Key Details
Product (SKU):   PGP Whole Disk Encryption - with Bronze Maintenance Win Mac Linux - Perpetual (200008)
Product Version:   10.0
Serial Number:   1019245349
Date Added:   Data Not Available
Date Registered:   07-11-2010
Start Date:   08-10-2009
End Date:   08-09-2011
SAN:   Data Not Available
License Key Required: Yes
License Key:   Deleted by  user
License Key Company Name:   Authorized Company
License Key Customer Name:   Authorized User
Installation Instructions:   http://www.symantec.com/docs/HOWTO42066
Prior Version Key:     WDEOlderProducts Installation Details 
dtich's picture

anything??

really hurting for this now..... yosemite is well out of beta guys.  this is ... not very professional.

thanks......