Video Screencast Help

Encryption Key tag dissapeared after Upgrading to Netbackup 7.5.0.3

Created: 18 Mar 2013 • Updated: 19 Mar 2013 | 5 comments
This issue has been solved. See solution.

Hi,

I had a Soalari 10 backup system running Netbackup 6.5.5 with NBKMS (Netbackup key management) hardware encryption enabled. The system has been running for a few years without any issues.

I recently upgraded the system to Netbackup 7.5.0.3 and after that I am not able to view the Key Tag (encryption key tag is gone).

bpimagelist -backupid <backupid> -L shows that the tape is encrypted (Flags:            0x40  (Tape Encrypted)) but the Key tag is *NULL* I was able to see the key tag in previuos version.

Flags:            0x40  (Tape Encrypted)
Key tag:          *NULL*
STL tag:          *NULL*

How can I tell or be sure that the data is encrypted?

is this a new feature os a bug?

Thanks

Operating Systems:

Comments 5 CommentsJump to latest comment

CRZ's picture

This is a defect (Etrack 2793446) which is fixed in 7.5.0.4.

Would it be possible to apply 7.5.0.5 on your master?  (You could go to 7.5.0.4, but you may still experience a completely different KMS issue in the GUI display, and that one wasn't fixed until 7.5.0.5 - also, we'd really like you at 7.5.0.5 wink )


bit.ly/76LBN | APPLBN | 75LBN

evargas's picture

Thanks, I will schedule an emergency upgrade and see what happens.

 

evargas's picture

I upgraded the Netbacku to version 7.5.0.5 but stil can't see the key tag.

/#bpimagelist -backupid 367003_1363136408 -L |grep -i key
Keyword:           (none specified)
 Key tag:          *NULL*

nbkmsutil -listkgs

Key Group Name        : ENCR_INC
Supported Cipher      : AES_256
Number of Keys        : 1
Has Active Key        : Yes
Creation Time         : Wed Jul  1 14:11:53 2009
Last Modification Time: Wed Jul  1 14:11:53 2009
Description           : July 01 2009

Key Group Name        : ENCR_FULL
Supported Cipher      : AES_256
Number of Keys        : 1
Has Active Key        : Yes
Creation Time         : Wed Jul  1 14:10:02 2009
Last Modification Time: Wed Jul  1 14:10:02 2009
Description           : July 01 2009

Number of Key Groups: 2

nbkmsutil -listkeys -kgname ENCR_FULL

Key Group Name        : ENCR_FULL
Supported Cipher      : AES_256
Number of Keys        : 1
Has Active Key        : Yes
Creation Time         : Wed Jul  1 14:10:02 2009
Last Modification Time: Wed Jul  1 14:10:02 2009
Description           : July 01 2009

  Key Tag    : XXXXXXXXXXXXXXXXXXXXXXXXXX I see the key here (I replaced with xs)
  Key Name              : Full_Encrypt
  Current State         : ACTIVE
  Creation Time         : Wed Jul  1 14:14:18 2009
  Last Modification Time: Wed Jul  1 14:14:18 2009
  Description           : Full backups all retentions encryption key

Number of Keys: 1

CRZ's picture

Could you please take a new backup under one of your KMS policies and run bpimagelist against the resulting image? 

This may be a case where we won't see results with prior (ie, other 7.5.0.x) backups.  (If it is, please accept my apologies in advance for not letting you in on this yesterday!)


bit.ly/76LBN | APPLBN | 75LBN

SOLUTION
evargas's picture

Thanks for you help, I see the key tag on the new backups now.

I still can't see the encryption key tag on the backup jobs that ran after the first upgrade (from 6.5 to 75), hoperfully I will be able to restore without any issues.