Video Screencast Help

Encryption paused 0% problem

Created: 15 Feb 2011 | 4 comments

Hopefully someone can give me a few pointers - being new to PGP WDE

I am trying to use an external drive as an encrypted disk backup utilising Time Machine.

I used the procedure below and the Disk stays at 0% with Encryption Paused as the status.  In the console there has been some information about subview frames in an inconsistent state.  Does anyone have an idea how I can fix this and get the backup working properly?

Thanks in advance!

1) Whole Disk Encrypted (successfully) Mac
2) Time Machine onto an external Disk 
3) Whole Disk Encrypt that Disk.

Apple 10.6.6
PGP Desktop 10.1.1[build 10] PGP SDK 4.0.1

15/02/2011 17:21:49 PGP[4181] *** WARNING: Method selectedRowEnumerator in class COutlineView is deprecated. It will be removed in a future release and should no longer be used.

15/02/2011 17:21:49 PGP[4181] <CEchoUnifiedSplitView: 0x14c1600>: the delegate <CEchoUnifiedView: 0x14bccc0> was sent -splitView:resizeSubviewsWithOldSize: and left the subview frames in an inconsistent state:
15/02/2011 17:21:49 PGP[4181] Split view bounds: {{0, 0}, {1165, 539}}
15/02/2011 17:21:49 PGP[4181]    Subview frame: {{0, 0}, {190, 539}}
15/02/2011 17:21:49 PGP[4181]    Subview frame: {{199, 0}, {974, 539}}
15/02/2011 17:21:49 PGP[4181] The outer edges of the subview frames are supposed to line up with the split view's bounds' edges. NSSplitView is working around the problem, perhaps at the cost of more redrawing. (This message is only logged once per NSSplitView.)
15/02/2011 17:21:49 PGP[4181] *** WARNING: Method selectRow:byExtendingSelection: in class COutlineView is deprecated. It will be removed in a future release and should no longer be used.

Comments 4 CommentsJump to latest comment

mallardduck's picture

I believe that that's just outdated UI issues - not the WDE process.

Encryption can hang if the drive is failing - unfortunately there's no easy way to get SMART status on an external disk.

Sarah Mays's picture

Turn on debug logging in PGP Desktop, Log --> Debug log, try to resume the process again to see if there are any helpful error messages in PGP's Log.

some questions

What brand of external disk are you using? (i've had this issue with Lacie external drives)

Is PGP desktop you are using communicating with PGP Universal server?

The issue i had in the past was that i would try and encrypt my external drive and it would immediately move to paused, and would never resume. On the PGP universal server (3.0) it would report that the drive was fully encrypted (in minuets!~! not possible!) I had to  delete the disk from PGP universal server - re-format and re-partition the disk using disk utility on another machine that did NOT have PGP installed. setup encryption again and it worked successfully.

bbdev's picture

Thanks for the quick responses.

I got the thing working in the end after trying a lot of different things! - the drive is an external Seagate drive.

On reboot - it was still not encrypting / paused 
On Ejecting from Finder and Retrying - still not encrypting / paused
Multiple shutting down of different apps / reboots / etc later...

Rebooted / then without opening any apps / ejected / reconnected / opened PGP Desktop / resume from the drive description in the left column and encryption commenced!

Still not quite sure what happened or why it worked in the end but encrypting worked and the drive seems healthy enough (was new so it should be!)

Thanks again for the advice!  Much appreciated!

mallardduck's picture

One other thing - does that drive have one of those annoying 'virtual partitions' on it?  Even when hidden they can screw up a lot of stuff (e.g. the Hitachi ones won't mount on an airport).