Video Screencast Help

End of data set was unexpectedly encountered

Created: 04 Sep 2006 • Updated: 21 May 2010 | 13 comments

We are running:
Windows 2003 (SP1)
Backup Exec (SP4)
DELL PV-122T (DLT) (Tapes are only 2 months old)

Backups were working fine but now we are getting the following error, every backup attempt:
Unexpected end of backup set encountered on .
V-79-57344-34004 - End of data set was unexpectedly encountered.


We have checked and there are no hard read write errors in the properties, statistics tab of any of the tapes.

We have also followed the instructions in:
http://seer.entsupport.symantec.com/docs/190890.htm
But erasing the tapes reported by the verify job made no difference.

Please could you help with this problem.
Thank you

Comments 13 CommentsJump to latest comment

tejashree Bhate's picture

Hello,

Check the following

http://support.veritas.com/docs/273314

Is the device connected to a raid controller?

Recreate the job and verify


Thanks

Charles Mason's picture

Hi,

We have checked the link but it is no relevant to our case as the backup was not aborted and connecting to the remote machine is fine.

The device is connected to a PCI / SCSI Card (Adaptec SCSI Card 39160D - Ultra160 SCSI).

We have created a new Backup job, independent of the current Policy job. This job will run this evening and I will let you know if this job works.

Thanks

Charles Mason's picture

The backup has just finished but it is still reporting the same error:
Unexpected end of backup set encountered on .
V-79-57344-34004 - End of data set was unexpectedly encountered.


Any idea what the problem could be?

Asma Tamboli's picture

Hello,

Please look out for any event IDs 5,7,9,11 or 15 in the system event logs. Also, check out the following document:

http://support.veritas.com/docs/192216

Thanks

Charles Mason's picture

Hi,

Checked out the events and only Event ID 7 (crypt32) is appearing in the system log as information, as follows:
Successful auto update retrieval of third-party root list sequence number from:

Just root certificate information I believe.

I have looked at http://support.veritas.com/docs/192216, which parts do you think are relevant to this problem?


Thanks

tejashree Bhate's picture

Hello,

Event ID 7s signify bad blocks. This could be the result of a driver issue, media that is becoming faulty, or dirty read/write heads on the tape drive. Cleaning the tape drive and loading the latest tape drivers from Symantec usually helps resolve these issues.

You may refer to the following
http://support.veritas.com/docs/255501

Thanks

Charles Mason's picture

We have also tried backing up to a hard-drive which results in the same error.

Unexpected end of backup set encountered on Backup-to-Disk 1.
V-79-57344-34004 - End of data set was unexpectedly encountered.


We have also with DELL:
+ Loaded latest drivers and firmware
+ Run a cleaning tape
+ Run DELL diagnostics on the tape drive which all passed.

So I think this rules out it being a problem with the tape drive.

What else can we try?

priya khire's picture

Hello,

You have mentioned that the BE version is with SP4. Is it 10.0 5484? If yes, do upgrade to BE 10d along with the latest drivers. Also verify if the device used is compatible as per the HCL. Here are the relavant links:

Installation files: http://support.veritas.com/docs/279332
HCL:http://support.veritas.com/docs/281670
Drivers: http://support.veritas.com/docs/284707

If the issue persists, revert with the following details:

- Does the error occur on all the jobs or only on a particular one?
- What is the total media capacity?
- What is the size of the data that is being backed up?

Tim Michael's picture

Hello,

Is there a solution to this problem?  I got this error this morning after our weekly backup failed, along with three of these errors:

AOFO:  Not enough disk space on the device running the Advanced Open File Option (AOFO) to create or increment the cache file.

Windows 2000 server, sp4
Backup Exec 10.d, sp3

We are also using a Dell PV122T, and this is the first we've seen of this error.

Thanks!

Ken Rinehart's picture

Same problem.  Backup exec 10d.  Powervault 122T.  Both disk backups and tape backups get the same error.

When reading the logs, the error is listed under the verify section.  The actual backup doesn't have any errors.  Just started happening all of a sudden.

------------------------

Job ended: Saturday, October 20, 2007 at 5:17:04 AM

Completed status: Failed

Final error: 0xe000fe30 - A communications failure has occurred.

Final error category: Server Errors

Ken-

Eric Leong's picture

Hello everyone,

We are also receiving the same error, it started 2 week ago.

Unexpected end of backup set encountered on .
V-79-57344-34004 - End of data set was unexpectedly encountered.

This only appearing on one of the SQL jobs, the other backup job are running fine. I have tried to enable the agent and erasing the tapes but the error continues. Anyone have any insight to the what the error means?




Message Edited by Eric Leong on 12-21-2007 01:28 PM

Message Edited by Eric Leong on 12-21-2007 01:30 PM

Bjornlo's picture
I have gotten this on policy based jobs which are first to disk and then via a duplicate out to tape.  The error occured on the duplicate portion.
Quite annoying, the only work around I have found is to:
remove the backup to disk files in question (move them to retired media and delete them, to free up disk space)
delete the job created by the policy (select the policy in setup and there is an option for this)
recreate the job from the policy.
 
Problem goes away for a while (several months or more).
 
 
This might be adaptable to your situation, or not.  But this is how I solved it.
siddh_patel@hotmail.com's picture

Hi

We are also getting following error  in Backup Exec 12.5

Completed status: Failed
Final error: 0xe00084f9 - A communications failure has occurred between the Backup Exec job engine and the remote agent.
Final error category: Resource Errors

backup - Microsoft Information Store\First Storage Group

Unexpected end of backup set encountered on HP 1.
V-79-57344-34004 - End of data set was unexpectedly encountered.