Video Screencast Help

Endpoint Protection Client Install Fails

Created: 11 Dec 2009 • Updated: 21 May 2010 | 4 comments
This issue has been solved. See solution.

Hi,
I am installing Endpoint Protection on Windows 2003 Standard R2 64 bit server for the first time.  Everything went weel on the install of the Manager.  Now I have created an install package for the server and I am trying to install it but continue to get the error:

The SAVMain feature is must be installed with the Symantec AntiVirus Win64.  When using the ADDLOCAL property please include SAVMain in the list of features to install.

I have looked at this error on this forum as well as on Google with no help.  This is not an upgrade but a new install and none of the installation manuals have been helpful.  Can someone tell me what I am doing wrong?  Thanks!  here is the SYMEVENT.log file.

[12/08/09 11:34:40][PID:3864] --------------------------------------------------
[12/08/09 11:34:40][PID:3864] Installed:12.8.0.11  This: 12.8.0.11
[12/08/09 11:34:40][PID:3864] Installed Version (if any) is not newer.
[12/08/09 11:34:40][PID:3864] Acquiring Global\Symevent_running mutex...
[12/08/09 11:34:40][PID:3864]   Successfully acquired mutex.
[12/08/09 11:34:40][PID:3864] Installed:12.8.0.11  This: 12.8.0.11
[12/08/09 11:34:40][PID:3864]   Installed version hasn't changed while waiting on the mutex.
[12/08/09 11:34:40][PID:3864] Symevent Installer (c)1998-2006 Symantec Corporation
[12/08/09 11:34:40][PID:3864] 64-bit Installer
[12/08/09 11:34:40][PID:3864] Launched from: C:\PROGRA~1\COMMON~1\SYMANT~1\SEVINS~1.EXE
[12/08/09 11:34:40][PID:3864] Compiled Version 12.8.0.11
[12/08/09 11:34:40][PID:3864] Logging Events Beginning 12/08/2009 at 11:34
[12/08/09 11:34:40][PID:3864] Operating System Detected -> Windows Server 2003 (32/64bit) or XP (x64)
[12/08/09 11:34:40][PID:3864]   Additional Info: dwOSVersionInfoSize is 0x00000094
[12/08/09 11:34:40][PID:3864]   Additional Info: dwMajorVersion      is 0x00000005
[12/08/09 11:34:40][PID:3864]   Additional Info: dwMinorVersion      is 0x00000002
[12/08/09 11:34:40][PID:3864]   Additional Info: dwBuildNumber       is 0x00000ECE
[12/08/09 11:34:40][PID:3864]   Additional Info: dwPlatformId        is 0x00000002
[12/08/09 11:34:40][PID:3864]   Additional Info: szCSDVersion        is Service Pack 1
[12/08/09 11:34:40][PID:3864] ----------------------------------------------------
[12/08/09 11:34:40][PID:3864] CommandLine=/Q /U /NOREGAPPID SRTSP
[12/08/09 11:34:40][PID:3864] Symantec dir found using ProgramFilesDir: C:\Program Files
[12/08/09 11:34:40][PID:3864] Common Files dir location found using CommonFilesDir: C:\Program Files\Common Files
[12/08/09 11:34:40][PID:3864] Manifests directory already exists.
[12/08/09 11:34:40][PID:3864] BEGIN - WM_CREATE
[12/08/09 11:34:40][PID:3864] END - WM_CREATE
[12/08/09 11:34:40][PID:3864] BEGIN - IDM_CHECKUSAGEUPDATE
[12/08/09 11:34:40][PID:3864]   Uninstalling with known AppID (or /NOREGAPPID).  Updating Refcounts.
[12/08/09 11:34:40][PID:3864] END - IDM_CHECKUSAGECOUNTUPDATE
[12/08/09 11:34:40][PID:3864] BEGIN - IDM_UNINSTALL_UI
[12/08/09 11:34:40][PID:3864] END - IDM_UNINSTALL_UI
[12/08/09 11:34:40][PID:3864] BEGIN - IDM_UNINSTALL
[12/08/09 11:34:40][PID:3864]   RefCount C:\WINDOWS\system32\Drivers\SYMEVENT64x86.SYS reached 0.
[12/08/09 11:34:40][PID:3864]   Deleting C:\WINDOWS\system32\Drivers\SYMEVENT64x86.SYS...Deleted.
[12/08/09 11:34:40][PID:3864]   RefCount C:\Program Files\Symantec\SYMEVENT64x86.SYS reached 0.
[12/08/09 11:34:40][PID:3864]   Deleting C:\Program Files\Symantec\SYMEVENT64x86.SYS...Deleted.
[12/08/09 11:34:40][PID:3864]   Service already marked for deletion.
[12/08/09 11:34:40][PID:3864]   Deleting C:\Program Files\Common Files\Symantec Shared\SPManifests\SYMEVNT.SPM...Deleted.
[12/08/09 11:34:40][PID:3864]   Deleting C:\Program Files\Common Files\Symantec Shared\SPManifests\SYMEVNT.GRD...Deleted.
[12/08/09 11:34:40][PID:3864]   Deleting C:\Program Files\Common Files\Symantec Shared\SPManifests\SYMEVNT.SIG...Deleted.
[12/08/09 11:34:40][PID:3864]   Removed SymProtect Manifests.
[12/08/09 11:34:40][PID:3864]   Deleting C:\Program Files\Symantec\SYMEVENT64x86.INF...Deleted.
[12/08/09 11:34:40][PID:3864]   Deleting C:\Program Files\Symantec\SYMEVENT64x86.CAT...Deleted.
[12/08/09 11:34:40][PID:3864]   Deleting C:\WINDOWS\system32\Drivers\SYMEVENT64x86.INF...Deleted.
[12/08/09 11:34:40][PID:3864]   Deleting C:\WINDOWS\system32\Drivers\SYMEVENT64x86.CAT...Deleted.
[12/08/09 11:34:40][PID:3864]   Removed CAT and INF files
[12/08/09 11:34:40][PID:3864] UnRegisterWithLU() params /LUUNREG /LOG
[12/08/09 11:34:40] (SELuReg) SeLUReg32 command line /LUUNREG /LOG
[12/08/09 11:34:40] (SELuReg) BEGIN - ExtUnRegisterWithLU( )
[12/08/09 11:34:41] (SELuReg)   CoCreateInstance returned: 0x0   ptrProductReg:0x1DC9A24
[12/08/09 11:34:41] (SELuReg) END - ExtUnRegisterWithLU( 1 )
[12/08/09 11:34:41][PID:3864] Deleted try 0: C:\Program Files\Symantec\SELUREG32.EXE
[12/08/09 11:34:41][PID:3864]   Setting Sevinst delete to TRUE
[12/08/09 11:34:41][PID:3864]   Sevinst attributes okay.  Attempting to delete the copy in the Symantec Shared folder.
[12/08/09 11:34:41][PID:3864]   C:\PROGRA~1\COMMON~1\SYMANT~1\SEVINS~1.EXE marked for deletion on reboot.
[12/08/09 11:34:41][PID:3864] Cannot remove directory: C:\Program Files\Common Files\Symantec Shared, Error 145
[12/08/09 11:34:41][PID:3864]   C:\PROGRA~1\COMMON~1\SYMANT~1 marked for deletion on reboot.
[12/08/09 11:34:41][PID:3864] RemoveUninstallKey: Constructed reg key string: SOFTWARE\Microsoft\Windows\CurrentVersion\Uninstall\Sevinst
[12/08/09 11:34:41][PID:3864] Sevinst Shared Usage value delete returned 0
[12/08/09 11:34:41][PID:3864] END - IDM_UNINSTALL
[12/08/09 11:34:41][PID:3864] BEGIN - IDM_ALLDONE
[12/08/09 11:34:41][PID:3864] END - IDM_ALLDONE
[12/08/09 11:34:41][PID:3864] Cannot delete Symantec directory (145).
[12/08/09 11:34:41][PID:3864] SetUpDelete: Setup succeeded

Comments 4 CommentsJump to latest comment

Vikram Kumar-SAV to SEP's picture

Either use windows installer cleanup utility and remove the SAV entry.
from here http://support.microsoft.com/kb/290301
Or call support and get cleanwipe utility. 

Vikram Kumar

Symantec Consultant

The most helpful part of entire Symantec connect is the Search button..do use it.

SOLUTION
Rafeeq's picture

check this document seems like your previous sav is corrupted.

http://service1.symantec.com/SUPPORT/ent-security.nsf/docid/2006022212084148

install ms cleanup utility from

http://support.microsoft.com/kb/290301

remove sav
install symantec endpoint , should install fine.

AravindKM's picture

If the above suggestions not helped try installing SEP unmanaged from CD1\SEP
Pls post the SEP_INST.log which is present in the %temp% directory.. 

Please don't forget to mark your thread solved with whatever answer helped you : ) Thanks & Regards Aravind

sandeep_sali's picture

Manually uninstall Norton and old SAV  

http://service1.symantec.com/SUPPORT/ent-security....

Thanks & Regards

Sandeep C Sali