Video Screencast Help
Symantec to Separate Into Two Focused, Industry-Leading Technology Companies. Learn more.

Ensemble Menu Select not pulling in new Hierarchy Data Category

Created: 12 Dec 2012 • Updated: 12 Dec 2012 | 4 comments
This issue has been solved. See solution.

I'm sure I'm missing something... 

I'm using 7.5.

I just created a new Hierarchy Data Category and populated it for use on a form.  I then went to the form and added the Ensemble Menu Select component.  When I went to configure it, the new category does not show in the Picker.  I only see the Default category and the Incident Management one.  I tried the Get Hierarchy Category component and fed it the Category ID from the new category, and then set it in the Ensemble Menu Select component, but the component won't validate, even though all of its parameters appear to be set properly.

Please help me find the error of my ways. :)

 

Comments 4 CommentsJump to latest comment

reecardo's picture

Just curious... have you tried restarting IIS and then running your flow?

etk1131's picture

Hi Reecardo,

I have restarted IIS and the Symantec Workflow Server service without any luck.  I'm still only showing the Default and Incident Management categories. Please see the below screenshot.

Is there a required initialization to update the Hierarchy Category Source?

reecardo's picture

Should have mentioned this previously... how about restarting the Workflow service? Also, have you tried reloading your project?

Also, this will only fetch categories that the user has permission to... the user being the credentials defined in the task tray tool used to connect to your Process Manager instance. For example, if you're using admin@symantec.com to connect to PM in task tray, then admin@symantec.com needs to have CanView permissions to the hierarchy category for it to come back.

SOLUTION
etk1131's picture

Thanks Reecardo!

I had to give permissions to view the Category to more than what was listed and it showed up.

I appreciate the quick responses!