Video Screencast Help
Symantec to Separate Into Two Focused, Industry-Leading Technology Companies. Learn more.

Enterprise Vault (10.0.2) - Synchronization failed

Created: 27 Jan 2013 • Updated: 01 Mar 2013 | 10 comments
This issue has been solved. See solution.

Hi Guys , 

 

I'm trying to solve an issue i've encountered with for couple of days now without success. 

When trying to sync one of our users vault's (outlook 2010 x64) I've encountered with the following error message in the middle of the procces

"Failed : Item retrieval failed on server" . 

After googling this issue I found the following post :

http://www.symantec.com/business/support/index?page=content&id=TECH70956 

Unfortunatlely - after implementing the suggested workaround - it didn't help , the sync still fails at the same point .

At that point I tried to Verfiy/Rebuild the vault's index but both of the procedures failed due to a missing item . 

In the event viewer I could find bunch of abnormal events such as :

Reference: CStore::InitializeDBAccess()/Either VaultStoreEntryId is empty or connection to Storage database is not available  

 

Now -  I'm pretty lost .... 

 

Any suggestions will be greatly appreciated ,

Thanks, 

Shlomi. 

 

 

 

Comments 10 CommentsJump to latest comment

Chau Tran's picture

Could you do a full Client Trace and post the log file here?

Regards,

Chau Tran

ASC, STS, SCS and MCITP

JesusWept3's picture

I'm not really sure if a client trace will help because you're saying you tried to rebuild the index and its giving those errors, correct?

Is this happening for all users or just the one?

Have you performed a DR on either the Directory or Vault Store databases recently?

What you might need to do is do a dtrace of whatever is throwing that event, which im going to guess is Storage Online (Dtrace StorageOnlineOpns)

You may just want to try exporting out the archive to a PST file, see if it exports out completely or gives any errors

But honestly, you may be best off opening a case with symantec because something really isn't right for you to be getting those errors

Shlomi's picture

Hi JesusWept3, 

First, thank you for posting. 

The problem happens only on this specific mailbox . I've tried the client dtrace log and the pst export as well.

Unfortunately - I couldn't export the whole mailbox to pst (approx 12k items failed :() .

 

Anyway , I followed your recommandation and logged a support ticket @ Symantec.

 

Thanks for your help ,

Shlomi

JesusWept3's picture

I think what you will end up doing is an EVSVR doing a repair database linkages

My best guess is you have items that were archived in something like \myFolder... EV creates threereferences to \MyFolder in SQL

One in the Root table and one in the ArchiveFolder table of the directory database and one in the Vault table of the VaultStore database

What could have happened is that you had myFolder in both directory and vault store databases, then did a restore or recovery on the directory database so now it doesn't have the root/ArchiveFolder entries anymore and thus can't link emails back to their folders

That's my best guess, but definitely support is your best bet, and an EVSVR report will see if this is widespread or just this one user

Hopefully it turns out to be something like the SQL server changed and the sqlserver column in VaultStoreEntry was never updated or something

SOLUTION
Shlomi's picture

Thanks again for your reply. 

 

Will keep you guys prompted when a solution will be found.

 

Fury's picture

Have you tried to configure a new Windows/Outlook profile for the user and then tried a reset of VC ?

Do you have items missing or items missing with content and whats the count ?

You can run the Verify + Auto Sync Operation followed by a Rebuild
if there are Missing items with an option to 'Ignore items that cannot be Indexed'.

What is the error when you access https://evserver/enterprisevault/clientdiagnostics.aspx ?

Please post the full client trace

 

Shlomi's picture

Hi Fury , thank you for your post ! 

As for your question : 

Have you tried to configure a new Windows/Outlook profile for the user and then tried a reset of VC ?

I did , I tried to create the same profile under a new PC - failed as well. 

Do you have items missing or items missing with content and whats the count ? 

I do have 1 missing item in this vault , Rebuild & Verify procedures are failing as well due to this item. 

 https://evserver/enterprisevault/clientdiagnostics.aspx

I wasn't familiar with this service - when I search for a specific vault I cannot find any record (for this mailbox or any other ... ) should I enable this service first ? 

Regarding the full client trace - as far as I can tell - there is no indication for this failure in the logs ... (the log holds confidntial information therefore I cannot publish them ..) 

 

Thanks for your help ! 

Fury's picture

- If its only one item which is failing you can track the same from the indexmissing.log and perform a dumpsaveset to confirm if it can be extracted.

- However Verify + Auto Sync Operation followed by a Rebuild with an option to 'Ignore items that cannot be Indexed' should get the Missing count to 0 but it should not fail the VC Sync..

- Yes you need to enabled the ClientDiagnostics first...

 

Shlomi's picture

Well ... after enabling the diagnostic server and starting to sync the problematic mailbox The weird thing is that even after the procedure fails on the client side – the diagnostic tool still hangs on “Downloading” .

Any ideas ? 

Thanks .