Video Screencast Help

Enterprise Vault 8 - File Migration

Created: 06 Sep 2012 • Updated: 11 Oct 2012 | 4 comments
This issue has been solved. See solution.

Okay....

Run into a brick wall here.

Got a new server in place, let's call it NEW-SERVER. Currently I run EV8 SP5 on multiple file servers OLD-SERVER1, OLD-SERVER2, OLD-SERVER3 etc etc. I'm consolidating the old servers onto one new one. New server setup with FSA and Archive Point setup on the console etc etc.

Identified some project folders which are dormant i can use for testing. Let's use the example of ProjectX of being a folder of files of archived and non archived files i wish to migrate.

Firstly I Robocopy the folder structure and non archived files using the command robocopy \\OLD-SERVER1\SHARENAME\PROJECTX \\NEW-SERVER\SHARENAME\PROJECTX /e /xa:O

Job done. Everything migrates except the stubs. Next i want to migrate the stubs.

From the command line on the EV-SERVER i use the command fsautility -m -s \\OLD-SERVER1\SHARENAME\PROJECTX -d \\NEWSERVER\SHARENAME\PROJECTX

Completes with errors. Migrates most of the stubs but a few fail with "Create destination placeholder - Failure". So reading into this, one of the problems is Server 2008 file / share permissions, so i spend all afternoon reviewing this, trying different things - no success.

So i think - right, let's re-do the share on the new server, so i move the PROJECTX folder to a temp folder on the new server. Delete share, recreate new share (same name), move PROJECTX folder back, re-do permissions from scratch and re-run the fsautility -m with the same syntax as above -expecting to see progress.

Now it doesn't run - As soon as i instigate fsautility -m i get the following:

Error: Failed to find archive point on destination path and above: \\NEWSERVER\SHARENAME\PROJECTX

Arghhh. I check the Archive Points on the console and they are all still there. But when i do it via the command line - archivepoints read \\NEWSERVER\SHARENAME i get Archive point on the specified folder does not exist.

 

If i delete the archive point from the console - does it delete all the archived data? How on earth do i rectify this - obviously i now see EV does not like a share being deleted and recreated?

Is it simply a case of running this command fsautility -a -s \\NEWSERVER\SHARENAME\ -l 0

I'm nervous now as i'm starting to get outside my comfort zone!

 

Thanks in advance.

 

Comments 4 CommentsJump to latest comment

Retro Kid's picture

I should add as well, we are stuck on EV8 SP5 because EV9 needs a later version of SQL than 2000 -  something which our small business cannot afford to upgrade :-(

ZeRoC00L's picture

You will have to update the database table with the location in the server/share:

http://www.symantec.com/business/support/index?page=content&id=TECH144810

If this response answers your concern, please mark it as a "solution"

TypoProne's picture

So it looks like you had one issue and encountered another while trying to fix the first. You can use FSAUtility to recreate an archive point. If you use the Archive point utility you will create a duplicate archive point and therefore archive. You can then edit the archive point to point it to the desired archive.
 

I think teh other poster shows you another way to move the stuff... but I think your method shoudl be fine too. I would encourage a dtrace of FSAUtility while reproducing the initial error on some items to further narrow the focus of your issue.

 

If this is still an issue...please keep us up to date. If it is resolved by someone here or yourself... please post and flag the approprate post as is needed so we can all share and direct limted volentary assistance where it is needed most.

 

Thanks for the posting.

SOLUTION