Video Screencast Help

Enterprise Vault and Discovery Acclerator upgrade path

Created: 07 Mar 2013 • Updated: 27 Mar 2013 | 9 comments
This issue has been solved. See solution.

We're currently running EV 8.0 sp3 and DA 8.0 sp3.  Our target version is 10.1.13 as we plan on upgrading to Exchange 2013 in the near future.

I think I've figured out in which order these upgrades need to take place but would like confirmation that I have it correct.

1. Upgrade DA to 8.0 SP5

2. Upgrade DA and EV to 9.0.3

3. Upgrade DA and EV to 10.0.13

Also in step 1, do I need to install a new license key.  I realize I will need to in the following upgrades but will I need to obtain a new license key upgrading DA from 8.0 sp3 to 8.0 sp5?

Another licensing question, when I check the licensing portal, I do not see license keys for V10.  Only V9.0.  We're still in a support agreement so I'm not sure why this is.

Thanks in advance for any insight or confirmation you can offer.

Operating Systems:

Comments 9 CommentsJump to latest comment

idaman22's picture

Please take a look at these 2 technotes ofr the answers to your questions.

Licensing - http://www.symantec.com/docs/TECH54592

Supported upgrade paths for Enterprise Vault (EV), Compliance Accelerator (CA), Discovery Accelerator (DA) and Discovery Collector. - http://www.symantec.com/docs/TECH53174

JesusWept3's picture

So first of all, like idaman22 posted, you can do the following upgrade paths

1. DA8 SP3 -> DA8 SP5
2. EV8 SP3 -> EV9 SP4
3. EV9 SP4 -> EV10 SP3
4. DA8 SP5 -> DA10 SP3

Then install the EV 10 SP3 API or the EV 10 SP3 binaries on the DA Server to make sure its all at the current version.

As for the license, you can use the current license to run EV/DA 10 SP3, however you will be out of compliance. Your best bet is to contact symantec and see why the EV10 Licenses aren't available to you.

SOLUTION
Kenneth Adams's picture

Lmlarson,

JesusWept3 is correct about the license issue.  You can use your current license for the upgrade, but you need to contact your Symantec Account Manager to see why you can't access the EV 10 license.

As for the upgrade, JesusWept3 is slightly incorrect.  After 8.0 SP3, the DA installed version must be the same as or newer than the installed EV version.  As such, your upgrade path should be

1) DA 8.0 SP3 to 8.0 SP5.

2) DA 8.0 SP5 to 9.0 SP3.

3) EV 8.0 SP3 to 9.0 SP3.

4) DA 9.0 SP3 to 10.0 SP3.

5) EV 9.0 SP3 to 10.0 SP3.

A few things to take into consideration:

1) Ensure you have plenty of free disk space for the DA Customer database's transaction log.  We recommend 4 times the physical size of the DA Customer database file.

2) The less data you have to upgrade, the faster the upgrade will occur, so

--- accept or reject any searches that are in a pending state (prefer reject to remove the data froicm the database)

--- stop any exports that are running

--- if there are any cases with Analytics enabled, disable Analytics if possible.

3) Remember to backup the configuration and customer databases before starting the upgrade and after each upgrade step.

4) Also remember to allow time to run a quick set of tests after each upgrade.  Something simple like running a search, reviewing the hits, and exporting some items to ensure those processes work properly.

5)When you upgrade the EV servers, install the EV binaries instead of the EV API on the DA server, please.  We've had instances where not all dlls get registered with the EV API.  This causes DA to not function properly.

Somewhere along the upgrade path you'll have to change to Windows Server 2008 R2, presuming you're not already running that OS on your existing servers.  Once you're on EV 9.0.3, you can use the Server Migration Tool to migrate your EV servers to 64-bit hardware / OS.  Follow the instructions with this tool and you should be find.

Ken

Ken Adams

Backline Support for CA, DA, ACE, UCE, PSTD, ARMS, EVDC
US Support Region

JesusWept3's picture

You only need to go to DA9 if you intend on actually staying on EV9 for any length of time, which could be recommended if you want to stabalize the system for a week or two and make sure everythings working before moving on.

But honestly, there is nothing wrong with going from DA8 SP5 straight to DA 10 SP3 as long as you make sure everythings shut down so that searches, holds etc aren't being placed whilst you go from EV8 -> EV9 -> EV10

Kenneth Adams's picture

While JesusWept3 is correct about the upgrade of DA from 8.0 SP5 (8.0.5) to 10.0 SP3 (10.0.3), you will be in an unsupported environment if you perform that upgrade after you upgrade EV to 10.0.3.  As such, you would need to upgrade DA from 8.0.3 to 8.0.5, then to 10.0.3.  Once that's done, you would upgrade EV from 8.0.3 to 9.0.3 to 10.0.3.

We in Support prefer caution when upgrading, hence the recommendation to ugrade in the steps I noted in my earlier post as they would allow for proper testing to ensure all is working well and to capture new backups of the databases prior to the next upgrade.

Ken

Ken Adams

Backline Support for CA, DA, ACE, UCE, PSTD, ARMS, EVDC
US Support Region

JesusWept3's picture

OK just for my own edification, if you do EV8 -> EV9 -> DA8 SP3 -> DA8 SP5 -> DA 10 SP3 -> EV10 SP3, what about that makes it unsupported if they're all on the same versions? but its the DA9 thats being skipped?

Just having a hard time knowing what the difference between
DA8 SP3 -> DA8 SP5  and then EV9 SP4 to EV10 SP4 -> and then DA8 SP5 -> DA10 SP3
as opposed to
DA8 SP3 -> DA8 SP5 -> DA 10 SP3 and then EV9 SP4 -> EV10 SP3

what is the difference that makes it unsupported?

Kenneth Adams's picture

I hope you ment upgrading EV to 10.0 SP3 instead of 10.0 SP4 as 10.0 SP4 is not out yet.

Remember that, starting with EV/CA/DA 8.0.3, we began using the VaultInterest table to prevent archive deletions if there is a CA Department or DA Case that has run a search against archives that are to be deleted (via Move Archive or just normal deletion).  As such, 8.0.3 is the starting point where CA and DA must be at the same or newer major and minor release as EV.  In your suggested path, the upgrade from EV 8.0.3 to 9.0.4 to 10.0.3 before upgrading DA from 8.0.5 to 10.0.3 puts DA in an unsupported configuration should something happen during the upgrade of the DA configuration and customer databases.

Also remember that DA 10's Custodian Manager now uses incremental updates to Custodian data so that we only synchronize changes instead of the entire Custodian when some change has been made in AD or Domino to any User account.  As such, the upgrade of the CM database may take longer to get the database fully synchronized, which could have some impact on uprading the DA Customer database(s).  We would need the DA environment in a supported configuration should anything happen during that synchronization to cause EV Support to be engaged through a work ticket.

Ken Adams

Backline Support for CA, DA, ACE, UCE, PSTD, ARMS, EVDC
US Support Region

Lmlarson's picture

I have one more question.  I went to upgrade discovery accelerator from 8.0 sp5 to 10.0.3.  Keep in mind our Vault it still 8.0 sp3, with plans to upgrade also.  But when I began the upgrade of Accelerator to 10.0.3 the prerequisite screen indicated that Evault 9.0 service and api runtime were required.  An earlier post led me to believe that I could upgrade Discovery to 10.0.3 even though Vault is still at 8.0 sp3.  But again, the prerequisite screen told me otherwise.  Can I do this or do I need the Vault at 9.X ?

Kenneth Adams's picture

Per the DAReadMeFirst_en.htm file with DA 10.0.3:

Component - Discovery Accelerator server software

Prerequisite software - Enterprise Vault.  As a minimum, you require a 9.0 or 10.0 version of the Enterprise Vault Services or Enterprise Vault API Runtime.

So, this tells us that you need the EV 9 or 10 binaries or API installed on the DA server in order to upgrade to DA 10.0.3.  If you have a version of EV installed on the DA server that does not match the EV version installed on the EV Indexing and Storage Service server(s), DA searches and exports will not always work properly. They may work initially,but will eventually stop working properly until you get the EV servers upgraded to the same version as is installed on the DA server.

Ken

Ken Adams

Backline Support for CA, DA, ACE, UCE, PSTD, ARMS, EVDC
US Support Region