Video Screencast Help
Give us your opinion and win with Symantec! Please help us by taking this survey to tell us about your experience with Symantec Connect, so that we can continue to grow and improve.  Take the survey.

Enterprise Vault Collection

Created: 13 Aug 2014 • Updated: 22 Aug 2014 | 13 comments
This issue has been solved. See solution.

Hello,

I'm looking for help with the Collection feature.

I am running EV 10.0.4 and enabled the collection on my single partition using the recommended Symantec article.
Currently there's no full backup being completed yet, so I got an error regarding this in the Console.

Is the collection agent checks the completion of a backup before collecting files from the partition?
If not, why it doesn't collect my files?

I got this event in the EventLog:

A Partition's Collector run has finished.

Partition Root Path: D:\EVStorage\Express Vault Store\Express Vault Store Ptn1

Archived items: 0
Files added to collections: 0
Collections: 0

Time taken for the run [H:M:S]: 0:27:13

For more information, see Help and Support Center at http://entced.symantec.com/entt?product=ev&languag...
 

Much Thanks.
 

Operating Systems:

Comments 13 CommentsJump to latest comment

Rob.Wilcox's picture

Yes, the collector will only collect savesets that have been backed up.

AndrewB's picture

i'd really recommend doing a full backup of your environment before implementing new changes. however, if you want to "trick" EV into thinking it's been backed up you can use a trigger file. more on that here:

How to use a trigger file (IgnoreArchiveBitTrigger.txt or PartitionSecuredNotification.xml) for devices that do not support the Archive bit
Article:TECH35610  |  Created: 2004-01-19  |  Updated: 2014-05-02  |  Article URL http://www.symantec.com/docs/TECH35610

Andy Becker | Authorized Symantec Consultant | Trace3 | Symantec National Partner | www.trace3.com

zeffy's picture

Still not working (even when backup trigger is used):

A Partition's Collector run has finished.

Partition Root Path: d:\EVStorage\Express Vault Store\Express Vault Store Ptn1

Archived items: 0
Files added to collections: 0
Collections: 0

Time taken for the run [H:M:S]: 0:15:21

For more information, see Help and Support Center at http://entced.symantec.com/entt?product=ev&languag...

zeffy's picture

Events (cleared before using the "Run Now" on the partitions collections tab):

Capture.PNG

Indication for backup success:

Capture2.PNG

Settings for collector:

Capture3.PNG

GabeV's picture

Hello zeffy,

Could you please capture a screenshot from the 'Backup' tab? If Enterprise Vault is still marking items as secured, you should see unsecured items under the backup tab. Also, checked the SQL databases fragmentation. If Enterprise Vault has never marked items secured and the SQL fragmentation is high, it might be affecting the process as well. Once the items are marked as secured, then EV will start collecting the savesets, thus, it's a two-steps process.

In addition, as Rob mentioned, collect a dtrace for StorageFileWatch, set/clear backup mode and review the dtrace log file.

“Success is not final, failure is not fatal: it is the courage to continue that counts.”–Winston Churchill

Rob.Wilcox's picture

So, it might be that they won't be collected until 10 days after backup?

Have you tried running a DTRACE?

SOLUTION
zeffy's picture

Could be. I don't know how the mechanisim works with the "older then" setting. Is it older then last backup?

How can I setup DTRACE for collector?

Thanks.

Rob.Wilcox's picture

You'll need to DTRACE the StorageFileWatch process.

The online help explains a little bit about the settings, particularly:

Collect files older than. Enter the amount of time that must elapse since items were archived before they are eligible for collection.

Note the following:

  • Enterprise Vault does not collect files until they have been backed up. Do not set the elapsed time to less than your backup frequency, otherwise Enterprise Vault wastes resources repeatedly checking whether the files have been backed up.

  • To aid indexing performance, Enterprise Vault should index items before they are collected. You should therefore allow a minimum of one day before items are collected.

  • A long delay provides no benefit, except that until collection occurs the items are retrieved more quickly.

Rob.Wilcox's picture

Did you get any further with this issue?

zeffy's picture

Hi

Yes,

The archiving is completed now.

I used the trigger file and it started collection.

Do you have any idea how to identify archived cab's? what kind of extension is used?

AndrewB's picture

glad to hear that setting up the trigger file helped you achieve your goal.

Andy Becker | Authorized Symantec Consultant | Trace3 | Symantec National Partner | www.trace3.com